LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   cant ssh to a home server open a gprs connection using proxy (https://www.linuxquestions.org/questions/linux-networking-3/cant-ssh-to-a-home-server-open-a-gprs-connection-using-proxy-644572/)

nass 05-24-2008 08:24 PM

cant ssh to a home server open a gprs connection using proxy
 
hello everyone,
i am trying to figure out y i can not ssh connect to my home server from the internet... the specific client connection is carried out using a gprs modem and i connect through my isp through an http proxy server...

ssh nass@myhomeserver.no-ip.org -p80
gets me the following error:
FATAL: failed to begin relaying via HTTP
ssh_exchange_identification: Connection closed by remote host

ehat is this? how should i tackle it?

route -n returns:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.6.6.6 0.0.0.0 255.255.255.255 UH 0 0 0
ppp0
0.0.0.0 0.0.0.0 0.0.0.0 U 0 0 0
ppp0

the nameservers belong to another ISP but it shouldnt really matter...

if i establish the connection using wvdial i get to have internet on firefox, but if i try to connect to ssh at home it fails to connect..

nslookup and dig fail to do name resolution too...
any ideas?
nass

framp 05-25-2008 03:31 PM

Quote:

Originally Posted by nass (Post 3163744)
ssh_exchange_identification: Connection closed by remote host

Have a look into /var/log/messages on the ssh server. If you don't find any helpful messages increase the log level in /etc/ssh/sshd_conf and check the log file again.

nass 05-26-2008 11:04 AM

i don't think the attempt to establish an ssh connection ever reaches the openssh server (which btw is a slackware 11 machine)..

raising the LogLevel in the client side though (an ubuntu 8.04 laptop) gives this...:

Quote:

nass@starlight:~$ ssh nass@myhomeserver.no-ip.org -p80
debug2: ssh_connect: needpriv 0
debug1: Executing proxy command: exec connect-proxy -H 192.168.200.10:9401 synthnassizer.no-ip.org 80
debug1: permanently_drop_suid: 1000
debug1: identity file /home/nass/.ssh/identity type -1
debug1: identity file /home/nass/.ssh/id_rsa type -1
debug1: identity file /home/nass/.ssh/id_dsa type -1
FATAL: failed to begin relaying via HTTP.
ssh_exchange_identification: Connection closed by remote host
nass@starlight:~$
on the client side /var/log/messages doesn't give any additional info either...

in /etc/ssh/ssh_config on the client (ubuntu) side i have added support to connect through the mobile service provider proxy server
Quote:

ProxyCommand connect-proxy -H 192.168.200.10:9401 %h %p
if i try the connect-proxy command stand alone i get the following debug output:
Quote:

root@starlight:/etc/ssh# connect-proxy -d -R both -H wap@192.168.200.10:9401 myhomeserver.no-ip.org 80
DEBUG: No direct address are specified.
DEBUG: relay_method = HTTP (3)
DEBUG: relay_host=192.168.200.10
DEBUG: relay_port=9401
DEBUG: relay_user=wap
DEBUG: local_type=stdio
DEBUG: dest_host=synthnassizer.no-ip.org
DEBUG: dest_port=80
DEBUG: Program is $Revision: 1.96 $
DEBUG: resolving host by name: synthnassizer.no-ip.org
DEBUG: failed to resolve locally.
DEBUG: connecting to 192.168.200.10:9401
DEBUG: begin_http_relay()
DEBUG: >>> "CONNECT synthnassizer.no-ip.org:80 HTTP/1.0\r\n"
DEBUG: >>> "\r\n"
DEBUG: <<< "HTTP/1.1 403 Forbidden\r\n"
DEBUG: http proxy is not allowed.
FATAL: failed to begin relaying via HTTP.
root@starlight:/etc/ssh#
i strongly believe it has to do with the dns server queries... i have used a couple of valid nameservers in /etc/resolv.conf but they are from another internet service provider... and yet i have internet in firefox if i just enable proxy server through the connection settings...

the routing table looks like:
Quote:

root@starlight:/etc/ssh# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.6.6.6 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
0.0.0.0 10.6.6.6 0.0.0.0 UG 0 0 0 ppp0
root@starlight:/etc/ssh#

please notice that there can't be a problem with the ssh configurations, since whenever i am @ home, and connect this laptop to the internet through my home wifi, i obviously connect everywhere (without using the proxy command of course)...

hope this helps abit
nass


All times are GMT -5. The time now is 04:14 AM.