-   Linux - Networking (
-   -   can't reach outside the local network!! (

oyfly 06-09-2004 09:59 PM

can't reach outside the local network!!
Here's my situation:
I've got my RedHat9(7.2, 7.3 also tried) hooked up on network though ethernet card.
I use static IP provided by ISP.
All the IP configure setups are correct.
On the same pc, I have dual-boot system with XP.

Having no problem with XP in doing internet, I cannot reach the internet with my RedHat.
I can ping the neighbors in my local network(which means the lan card works properly), but I cannot ping the gateway, not to mention the outside the network.

Someone please help me out from this frustrating situation..


bruno buys 06-10-2004 12:08 AM

What kind of local network are you in? Its strange, because you say you´re in a local network, but there´s a static ip provided by ISP? If you are in a local network, most likely you have a intranet ip like 192.168.x.x.

Also, there´s no special reason to not be able to ping the gateway, as this is just another computer on the network.

mnitian 06-10-2004 05:25 AM

I was having the same problem with my pc
In my case netmask was changed when i corrected it it worked fine

oyfly 06-10-2004 08:09 PM

Thanks, mnitian, I solved!
As I changed my netmask from to, my linux machine made its way though to the world outside.
But, still wonder why my XP on the same machine works well with both netmasks.

from Korea.

WeRD 06-11-2004 08:16 AM

I've got problem with my Internet connection on Slackware 9.1. I've got RaLink RT2400 Wireless LAN card.
My network is unreachable.
I can ping broadcast address but that's all. I can't surf on the web etc. when i try to ping other IP I can't.
Configuration is correct because on WinXP on the same machine everything works OK.
I was trying this card also on Fedora Core2 and Mandrake 9.1 without any results.

All times are GMT -5. The time now is 04:18 PM.