-   Linux - Networking (
-   -   Can't ping hostnames (

Nox UK 04-19-2005 02:58 PM

Can't ping hostnames
I have a linksys adsl modem/router/dhcp server that connects 3 computers to each other/internet , and i'm dual booting windows/FC3 on the machine i'm having probs on - its a fairly new instal, but I have been messing about a bit (in an attempt to further my knowledge!) and for testing, pinging hostnames works fines from windows <washes mouth out>

from command prompt,
"ping" works fine
"ping floto" doesn't, just says unknown host.

the dhcp table on the linksys box shows the computer names and the addresses assigned to them.

i can also resolve/nslookup external websites fine, but not my internal network machines.

I tried disabling iptables, but i've never touched that (from services prog) but it made no difference.

Any ideas/hints as to where I should start looking? Thanks for any assistance.


beaucoup 04-19-2005 03:42 PM

The simplest solution in Linux would be to specify your host/IP mappings in the /etc/hosts file. I'm not sure how to manually specify hosts in Windows...

You might try adding (or whatever your router's internal address is) to your DNS server list, though I'm not sure if Linksys routers run internal DNS servers on them.

Nox UK 04-19-2005 04:01 PM

forget the windows side of things, thats going in the bin when i'm comfortable enough :D (and works fine anyway with the ping hostname anyway)

I had allready thought about the manually editing the host file, but my dhcp server only has a 3 day lease period, and no way of changing it, it also seems to just give to the first machine requesting it, regardless of lease! then 101 to the second. Tad annoying!

Static ip was the other option, but then i may as well not use dhcp at all :/


beaucoup 04-19-2005 04:07 PM

You can't expect consistant dynamic IP distribution from a Linksys box, I'm afraid :P If you really do only have 3 machines on your network, than static IPs may simplify things. Note that this doesn't mean you have to turn your router's DHCP server off; just assign yourself an address outside of it's dynamic range.

For example, I belive Linksys routers by default reserve the range - for DHCP. Static and dynamic IPs, then, can coexist peacefully on the same network as long as you don't staticly assign anything in that range.

All times are GMT -5. The time now is 03:49 AM.