LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Networking (http://www.linuxquestions.org/questions/forumdisplay.php?f=3)
-   -   Can't make Putty/ssh connection to Linux (http://www.linuxquestions.org/questions/showthread.php?t=4175443053)

RileyTheWiley 12-26-2012 07:40 PM

Can't make Putty/ssh connection to Linux
 
Cast of characters:
- Ventris, a win8 machine
- Atticus, a Fedora 14 machine

They are on the same router. Each can ping the other by IP address, each can load web pages and ping the world by hostname. They don't know each other's hostnames, but can ping each other by IP address.

When I run 'ssh uname@atticus' from atticus, I am prompted for a password and log in successfully.

When I run putty from Ventris and point it at atticus' ip address with settings on SSH, I get a timeout. The putty log on ventris exists but is empty. The SSH log on atticus does not gain a new entry (it does show the successful login from atticus).

I used netstat to verify that SSHD on atticus is using port 22 and it is open for both 0.0.0.0:22 and *:22.

I have checked the firewall on atticus and enabled SSH using TCP on port 22. This has also failed with the firewall disabled.

I have checked Windows Firewall (McAfee) on Ventris, and opened port 22 for TCP and UDP traffic.

What do I have to do?

schneidz 12-26-2012 07:50 PM

can you show us the outcome of:
Code:

sshd -d -d -d
on the server
and:
Code:

ssh -v -v -v
on the client.

RileyTheWiley 12-26-2012 09:48 PM

Quote:

Originally Posted by schneidz (Post 4857393)
can you show us the outcome of:
Code:

sshd -d -d -d
on the server
and:
Code:

ssh -v -v -v
on the client.

Don't have ssh on the client, using putty.

Server says:
[root@atticus ~]# /usr/sbin/sshd -d -d -d
debug2: load_server_config: filename /etc/ssh/sshd_config
debug2: load_server_config: done config len = 551
debug2: parse_server_config: config /etc/ssh/sshd_config len 551
debug3: /etc/ssh/sshd_config:34 setting SyslogFacility AUTHPRIV
debug3: /etc/ssh/sshd_config:64 setting PasswordAuthentication yes
debug3: /etc/ssh/sshd_config:68 setting ChallengeResponseAuthentication no
debug3: /etc/ssh/sshd_config:79 setting GSSAPIAuthentication yes
debug3: /etc/ssh/sshd_config:81 setting GSSAPICleanupCredentials yes
debug3: /etc/ssh/sshd_config:95 setting UsePAM yes
debug3: /etc/ssh/sshd_config:98 setting AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
debug3: /etc/ssh/sshd_config:99 setting AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
debug3: /etc/ssh/sshd_config:100 setting AcceptEnv LC_IDENTIFICATION LC_ALL LANGUAGE
debug3: /etc/ssh/sshd_config:101 setting AcceptEnv XMODIFIERS
debug3: /etc/ssh/sshd_config:107 setting X11Forwarding yes
debug3: /etc/ssh/sshd_config:130 setting Subsystem sftp /usr/libexec/openssh/sftp-server
debug1: sshd version OpenSSH_5.5p1
debug3: Not a RSA1 key file /etc/ssh/ssh_host_rsa_key.
debug1: read PEM private key done: type RSA
debug1: private host key: #0 type 1 RSA
debug3: Not a RSA1 key file /etc/ssh/ssh_host_dsa_key.
debug1: read PEM private key done: type DSA
debug1: private host key: #1 type 2 DSA
debug1: rexec_argv[0]='/usr/sbin/sshd'
debug1: rexec_argv[1]='-d'
debug1: rexec_argv[2]='-d'
debug1: rexec_argv[3]='-d'
debug3: oom_adjust_setup
Set /proc/self/oom_adj from 0 to -17
debug2: fd 3 setting O_NONBLOCK
debug1: Bind to port 22 on 0.0.0.0.
Bind to port 22 on 0.0.0.0 failed: Address already in use.
debug2: fd 3 setting O_NONBLOCK
debug3: sock_set_v6only: set socket 3 IPV6_V6ONLY
debug1: Bind to port 22 on ::.
Bind to port 22 on :: failed: Address already in use.
Cannot bind any address.

jschiwal 12-26-2012 09:59 PM

You can call putty from the command line with the -v (verbose) option. You can also look at the graphical interface's event log. Check for a verbose option.

If cygwin can be installed on Windows 8, you can use it's openssh client, which is the same one Linux uses.

If a live Linux distro will run on the Windows 8 machine (UEFI issues?) you can use the client there.

Logging in to SSH from the same machine as the server won't be very useful.

RileyTheWiley 12-26-2012 10:58 PM

Quote:

Originally Posted by jschiwal (Post 4857437)
You can call putty from the command line with the -v (verbose) option. You can also look at the graphical interface's event log. Check for a verbose option.

If cygwin can be installed on Windows 8, you can use it's openssh client, which is the same one Linux uses.

If a live Linux distro will run on the Windows 8 machine (UEFI issues?) you can use the client there.

Logging in to SSH from the same machine as the server won't be very useful.

2012-12-26 20:52:15 Looking up host "192.168.0.4"
2012-12-26 20:52:15 Connecting to 192.168.0.4 port 22
2012-12-26 20:52:36 Failed to connect to 192.168.0.4: Network error: Connection timed out
2012-12-26 20:52:36 Network error: Connection timed out
2012-12-26 20:54:02 Writing new session log (raw mode) to file: putty.log
2012-12-26 20:54:17 ----- Session restarted -----
2012-12-26 20:54:17 Looking up host "192.168.0.4"
2012-12-26 20:54:17 Connecting to 192.168.0.4 port 22
2012-12-26 20:54:38 Failed to connect to 192.168.0.4: Network error: Connection timed out
2012-12-26 20:54:38 Network error: Connection timed out


Client putty log is still empty

RileyTheWiley 12-26-2012 11:05 PM

Quote:

Originally Posted by jschiwal (Post 4857437)
You can call putty from the command line with the -v (verbose) option. You can also look at the graphical interface's event log. Check for a verbose option.

If cygwin can be installed on Windows 8, you can use it's openssh client, which is the same one Linux uses.

If a live Linux distro will run on the Windows 8 machine (UEFI issues?) you can use the client there.

Logging in to SSH from the same machine as the server won't be very useful.

Now I am using a Linux VM that is hosted through VMware workstation on Ventris:

[eric@localhost ~]$ ssh 192.168.0.4
ssh: connect to host 192.168.0.4 port 22: Connection refused

Hmmm ... cannot find a log file on the fedora vm.

Riley

RileyTheWiley 12-27-2012 02:49 AM

Needed to set the interface as trusted in the firewall. Solved.

Thanks to all.

Riley


All times are GMT -5. The time now is 03:29 AM.