-   Linux - Networking (
-   -   can't load webpages (

chrisrouleau 12-27-2005 12:17 PM

can't load webpages
Hi, I've just recently installed Fedora Core 4 on my pc. My motherboard uses the nForce4 chipset. I've successfully installed the linux drivers for nForce provided by nvidia's website. The funny thing is I get an IP address from DHCP, I can ping any website, I can access my router and mess with settings ( which I didn't ). However when I try to type a URL in firefox nothing happens. Once in a great while I'll get google to load, then I can type something to search for and it actually works, but if I click on any links or type anything in the URL nothing happens. It doesn't matter what browser I use. My home network is setup in the following manner. My computer connects to linksys router which connects to a router / DSL modem. I have dual boot so when I load windows XP the internet works just fine. Please help, I've been at this for hours. Thanks!

note: as I've been playing around with it, sometimes I've been able to access secure websites like my UofM MS exchange webmail account, or a moodle portal which contians my classes. So either some some settings are only allowing certain pages to load, or it's extremely slow to the point where it seems like it's not working at all. Thanks again I look forward to you're answers!

Chris Rouleau

routers 12-27-2005 08:23 PM

I thinks this problem related with your dns setting, u can check or alter /etc/resolv.conf ( add your provider dns server ) and if u want (or like) to set static LAN ip just go to konsol proceed "setup" > Network Configuration = asign the ip u want to use for your machine

chrisrouleau 12-28-2005 04:47 PM

The thing is, I already tried that. I've set my primary dns to the ip of our DSL modem and the 2nd dns to the ip provided by our isp. I don't think I should have to use a static IP because I also have kubuntu installed on another partition, the internet works just fine on it. The following is the contents of the resolv.conf file for kubuntu which is the exact same as that of FC4. If kubuntu works, the so should FC4, which is does to a point. It's just that FC4 wont load webpages for some reason. I think the network part is in fact working. So, I'm stumped.

search domain.actdsltmp

The thing is I can ping any website from the terminal but I just can't load it in the browser.

routers 12-29-2005 05:52 AM

ok here is trouble shooting :-

open your browser proceed

if u can see this page then ok, otherwise

if u can see this page then now the problem is ur dns so proceed

edit /etc/resolv.conf

nameserver <- leave this one line only

and try again

if still cannot then this is not dns problem :)

chrisrouleau 01-02-2006 11:06 PM

Ok, I got it working finally. You were right, it was DNS. I deleted my router as the primary and made my modem ( the 2nd DNS ) my primary and that fixed it. I have to update the resolv.conf file every time I load linux because it keeps reseting it and I still can't figure out why the default DNS configuration only affects FC4 and not windows or kubuntu. However, thanks for your help, it worked!

All times are GMT -5. The time now is 02:55 PM.