-   Linux - Networking (
-   -   Can't get passwordless ssh working (

thorney 11-27-2005 10:41 PM

Can't get passwordless ssh working

I followed the Howto on how to use keys to allow passwordless ssh login and I'm still having trouble. I ran the command: ssh-keygen -t dsa
and then the command: cat ~/.ssh/ | ssh <user>@<server> "cat - >> ~/.ssh/authorized_keys"
on the client machine. Then I checked whether the key in ~/.ssh/authorized_keys on the server was the same as ~/.ssh/ on the client and the were the same. Then I went into /etc/ssh/sshd_config and everything looks good (to me anyway). Does anyone have any ideas?!!!


thorney 11-27-2005 10:43 PM

I forgot to mention:

When I checked the sshd_config file it was on the server (just in case you thought I checked it on the client) and then I restarted sshd and tried again and still got a passwd prompt.

dnorseman 11-27-2005 11:05 PM

Check the permissions on the keys should be read/write only by user, otherwise ssh will refuse to match keys. Does that help?

thorney 11-27-2005 11:08 PM

Yes that was it!! Awesome thanks!!!!!

All times are GMT -5. The time now is 07:50 AM.