-   Linux - Networking (
-   -   Can't get my WIRED PCMCIA network card working in Knoppix (

ploskinj 03-31-2007 09:19 PM

Can't get my WIRED PCMCIA network card working in Knoppix
Hi, thanks you any help you can offer on this problem. It's really driving me crazy.

I was curious about Linux so I have tried several versions on my old laptop. Ubuntu doesn't seem to recognize my PCMCIA slots so I tried Knoppix. I really like the desktop environment and it runs well on my crappy laptop but I can't get connected to the internet or anything with my PCMCIA WIRED card. I tried Googling around and checking out articles here but I couldn't find anything on this topic.

Here is everything I know


Toshiba Satellite 1555cds
128 RAM

Distros tried: KNOPPIX_V5.1.0CD-2006-12-30-EN.iso

Network card:
D-Link DFE-690TXD, claims to work with Linux on the back of the box

When I boot Knoppix it says "PCMCIA found, starting cardmgr." There are no error messages or anything.

If I open up a terminal in Knoppix and type "lspcmcia" I get this:

Socket 0 bridge : [yenta_cardbus] (bus ID: 0000:00:13.0)

Socket 1 bridge : [yenta_cardbus] (bus ID: 0000:00:13.1)

Shouldn't it list my network card here?

I'm VERY new to Linux.

Thanks for any help you can offer, this is really frustrating for me because without the NIC I really can't use this laptop for anything at all. I'm more than willing to try other distros if there is one that would work better, I'm actually downloading OpenSUSE right now to give that one ago.


ploskinj 04-01-2007 02:17 AM

Update, I installed SUSE and it's running well but still no luck with my PCMCIA card. Also, I've noticed that my USB is suffering from the same systems.

With Windows 98 both the USB and the PCMCIA cards worked, now they don't.

I feel like I'm missing something or doing something stupid wrong.

Any help is hugely appreciated.

All times are GMT -5. The time now is 12:32 PM.