-   Linux - Networking (
-   -   Can't get Intel 82557 Network MiniPCI working (

celem 01-03-2007 05:15 PM

Can't get Intel 82557 Network MiniPCI working
I have an old Gateway Profile 3 machine. I have loaded PCLinuxOS MiniMe p.93a on it and everything seems to work except for the network interface. It used the intel eepro100 driver and while eth0 seems to be configured I cannot reach the network. It seems to fail to properly use DHCP. I tried loading the e100 driver via the control panel but it fails. I installed the latest version of the e100 driver and it still fails. The network works as I can plug a windows box into the same cable and it reached the network fine. Any help would be appreciated.

lspci reports 8086:1229 (rev 09), which is the Intel 82557/8/9 rev 09 board. The actual board is a Xircom MPCI3A56G-100P MiniPCI adapter.

ifconfig output:

eth0 Link encap:Ethernet HWaddr 00:10:A4:17:89:98
RX packets:4398 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1425052 (1.3 Mb) TX bytes:4788 (4.6 Kb)

lo Link encap:Local Loopback
inet addr: Mask:
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1176 (1.1 Kb) TX bytes:1176 (1.1 Kb)

lsmod output:

Module Size Used by
eepro100 30800 0
e100 34724 0
mii 5696 1 eepro100

celem 01-04-2007 05:33 PM

I am fortunate in that I have two nearly identical Gateway Profile 3 machines. One I purchased at a county government auction and the other I purchased on eBay. The county government machine came with Win2K-Pro installed and it works fine. The eBay machine came with no OS and it is the one onto which I have installed PCLinuxOS. This morning I took both machines apart (not easy with a Profile) and moved the MiniPCI network card from the known good machine into the PCLinuxOS machine that I am having problems with. Guess what - it works. My problem seems to be that the MiniPCI network card that came in the the PCLinuxOS machine is bad. It sort of looked like it worked yet somehow its problem apparently interfered with DHCP.

Now I have to go find another of the obsolete MiniPCI network cards on eBay.

The folks at the forum were a big help.

P.S: While I wait for a new MiniPCI network card, I installed a PCMCIA WiFi card on the Profile 3 and I am using it to add packages to the MiniMe load.

All times are GMT -5. The time now is 11:52 PM.