LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Can't detect network card built-in to motherboard (https://www.linuxquestions.org/questions/linux-networking-3/cant-detect-network-card-built-in-to-motherboard-253583/)

rsumbeling 11-11-2004 09:08 AM

Can't detect network card built-in to motherboard
 
Hi Linux gurus! I've successfully installed slackware linux 10 into our HP PC, I configured the network during the setup and made it DHCP. Now the problem is when I configured its network on the shell with "ifconfig eth0 <ipaddress>... netmask 255.255.255.0" i got an error that says: "eth0: error fetching interface information: Device not found"

The ethernet card of my PC is not in the PCI-interface, and it is built-in to the motherboard.

Please help me configuring my network card and Linux machine's IP configuration... :(

Thanks a Lot!

r0b0 11-11-2004 09:38 AM

Run this command as root user and post the output here (use a floppy to transfer, don't try to re-type :)

lspci

judge_neo 11-11-2004 09:40 AM

can you post your output from ./lspci plz

rsumbeling 11-11-2004 10:02 AM

Hi! thanx for ur kind reply!!!
Here's the output of the lspci command... what do u think is wrong based from the lspci output???

my ethernet card by the way is built-in to my motherboard, its not PCI-based....thanks


00:00.0 Host bridge: Intel Corp. 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 03)
00:02.0 VGA compatible controller: Intel Corp. 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)
00:1d.0 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #3 (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801DB (ICH4) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to PCI Bridge (rev 82)
00:1f.0 ISA bridge: Intel Corp. 82801DB (ICH4) LPC Bridge (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801DB (ICH4) Ultra ATA 100 Storage Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801DB/DBM (ICH4) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 02)
03:0a.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)

bathory 11-11-2004 10:27 AM

The last line of lspci says that you have a broadcom ethernet controller. Go here to d/l the driver for your ethernet controller

rsumbeling 11-11-2004 11:23 AM

Thanx a lot bathory...

I got another issue with the driver you've given me....

on the readme file, there is a instruction for the installlation of the bcm driver, the first two says:

"1. Install the source RPM package:

rpm -ivh bcm4400-<version>.src.rpm

2. CD to the RPM path and build the binary driver for your kernel:

cd /usr/src/{redhat,OpenLinux,turbo,packages,rpm ..}

rpm -bb SPECS/bcm4400.spec

or

rpmbuild -bb SPECS/bcm4400.spec (for RPM version 4.x.x)"

it was successful,

instruction 3 says:

"3. Install the newly built package (driver and man page):

rpm -ivh RPMS/i386/bcm4400-<version>.i386.rpm"

when did that exactly my command was: "rpm -ivh RPMS/i386/bcm4400-3.0.7-1.i386.rpm", of course, I was on the right directory.

but on that 3rd instruction, i get the error message:

"error: Failed dependencies
/bin/sh is needed by bcm4400-3.0.7-1"

I assumed that I've gotta shift to bourne shell (sh), which I did, but I still get the same error message!!! :-(

Did I miss something??? Please help!!!

Thanks!!!!

rsumbeling 11-11-2004 11:30 AM

By the way I'm using slackware 10 and kernel 2.4.26 :)... is it still compatible with this bcm 4400 3.0.7-1 version that I downloaded from you the site that u gave me???


Thanks a lot!

judge_neo 11-11-2004 11:51 AM

did you try runnig the command as root?

rsumbeling 11-11-2004 01:28 PM

hi judge neo and bathory! well i guess ive completed installing the driver by doing the following:
--------------
The following are general guidelines for installing the driver. Refer to
DISTRIB.TXT for additional installation notes for various Linux distributions.

1. Create a directory and extract the files:

tar xvzf bcm4400-<version>.tar.gz

2. Build the driver bcm4400.o as a loadable module for the running kernel:

cd src
make

3. Test the driver by loading it:

insmod bcm4400.o

4. Install the driver and man page:

make install

See RPM instructions above for the location of the installed driver.

5. To configure network protocol and address, refer to various Linux
documentations.
--------------

but there's another problem, when i tried to reboot the machine, i run the command:

ifconfig eth0 <ipaddress>... netmask 255.255.255.0"

i got an error that says: "eth0: error fetching interface information: Device not found" again!!!

did i successfully installed the driver? or what would be the way to configure my built-in ethernet card?

thanks for bearing my stupidy in linux, im very new to linux...

cheers!

rsumbeling 11-11-2004 01:48 PM

by the way, i was logged in as root...

thanks!

peter_robb 11-11-2004 04:54 PM

Yes the driver built correctly, but it needs to be moved to the /lib/modules/2.6.~/kernel/drivers/net/ directory
then do depmod -a

This makes it available for modprobe at boot time..

Your current kernel version can be found from uname -r
Each kernel version has it's own modules directory..

You should also add an alias for eth0 to specify the module..
Usually in /etc/modules.conf add a line
alias eth0 bcm4400

rsumbeling 11-11-2004 06:13 PM

Hi! Thanks a lot Peter, my Ethernet card is finally up at boot time! thanks a lot! ur the man! but i still have another question... but its better to have a new thread for this... please take a look at my thread named "DHCP configuration and incoming telnet, ssh"


thanks and more power!


All times are GMT -5. The time now is 11:48 AM.