-   Linux - Networking (
-   -   Cant connect to VPN (

English_Man 04-15-2007 01:25 PM

Cant connect to VPN
Hi there, I am using 'Kubuntu 7.04, Feisty Fawn' on my Acer Aspire 3100 laptop.

The wireless network is working fine, but I need to get my VPN connection with back.

Relakks supply a PPTP VPN server, and I have a domain, username and password. Under M$ this connection works great.

I have installed everything I need, and all the GUI config programs too. KvPN works ok, I add all the info and it connects, but then disconnects with the message saying 'remote modem hung up'.

PTPPConfig wont load, its installed but wont load. When I try to start it I get the following message.

root@Nicki:~# pptpconfig

Fatal error: php-gtk: Could not open display in /usr/bin/pptpconfig.php on line 31

And line 31 of that file is;

# load the php-gtk functions

Thats all the info I have, if anyone can help me fix this, I would be extremely grateful.

Thanks in advance-

scottblayney 04-15-2007 08:19 PM

Re: VPN problem
I have a similar problem with vpnc connecting to a Cisco VPN (Pix). This was working until I installed Feisty Fawn. I now connect and get disconnected within a minute. There may be something broken in PPTP. I would suggest checking for bugs at the Launchpad Bug Tracker.

jonathan4322 04-17-2007 05:16 AM

I use this one instead and it's working.
# /usr/sbin/pppd file /etc/ppp/peers/< tunnel-name >

nonsense28sal 05-15-2007 08:08 PM

Relakks on Kubuntu Feisty Fawn
I was able to get Relakks working using the GUI Network manager under Kubuntu Feisty.

First, make sure Knetwork Manager and KVpnc are installed through Synaptic or whatever package manager you prefer. Once it's installed, right click on the Knetwork manger icon in the system tray. It looks like the plug of an Ethernet cable. Go to VPN Connections and configure. Add a new connection.

Choose the following options:

Under Connection:
Connection Name: Relakks
Type: Windows (VPN) PPTP

Under Authentication:
Of the options check only "Refuse EAP".
("Refuse Chap" "Refuse MS Chap" and "Authenticate Peer" should all be unchecked).

Under Compression & Encryption:
ONLY CHECK "Require 128 bit MPPE encryption"

Under PPP Options:


"Use Peer DNS"
"Exclusive Device Access (UUPC Style lock)"

For the following fields:

MTU 1400
MRU 1416
lcp-echo-failure 10
lcp-echo-interval 10

Under Routing:
"Peer DNS through Tunnel"

That's all I had to do and it works well. One caveat: it does not work with my WRT54G2 router. I have to plug my Linux box directly into my cable modem for it to work properly. Although, this is not just a problem with Linux as I have this same issue on Windows. YMMV

English_Man 05-16-2007 02:20 PM

I have tried to do the same, but everytime I right click then VPN Connections and configure, nothing happens, I get mo new window.

I have also tried to re-install knetworkmanager.

I have also made sure that KVPNc is installed.

Is there anything else I need.

nonsense28sal 05-17-2007 04:44 PM

Needs network-manager-gnome
Hi English_Man.

I did a fresh install of Kubuntu Feisty at work today and wanted to see if I could get Relakks working from scratch.

There is a bug in knetworkmanager that requires network-manager-gnome in order to configure VPN.

I also had to install the following packages on the fresh install:

knet, network-manager-dev, network-manager-openvpn, network-manager-pptp, network-manager-vpnc, pptpd, pptp-linux, ipppd

After I installed the packages, I went ahead and rebooted. After that, with the instructions already posted above, I was able to connect to Relakks.

English_Man 05-18-2007 12:39 PM

Thank you so much, nonsense28sal, for your time and help, it now works perfectly.

Thanks again,


nonsense28sal 11-10-2007 03:47 PM

Update information for Gutsy Gibbon Kubuntu 7.10 for PPTP and VPN
Hi All.

I installed Gutsy this morning and followed my own instructions above for getting Relakks VPN/PPTP up and running. My efforts failed.

After some Googling around, I discovered there is a bug in knetworkmanger and an issue with how it refers (or in this case does not refer to) ppp & pptp.
There is a work around using Gnome's Network Manager.

I had to do the following:

Install Network Manager Applet through the Add/Remove in the Ubuntu menu.

Install the plug-in for your connection type - either network-manager-pptp, network-manager-vpnc (Cisco) or network-manager-openvpn (use Synaptic Package Manager or apt-get).

Left click the network manager applet (two monitor screens one behind the other probably in the bottom right of your screen) and select VPN Connections->Configure VPN->Add, then enter your connection details. There may be another icon that looks similar to this, which will bring up a dialog 'Connection Properties' if you left click it - this is not the one you want. Reboot if the applet is not visible.

Left click the network manager applet and select VPN Connections then click on your connection to connect.

If your new connection is greyed out and unselectable, or all you see is Manual Configuration...:
Backup /etc/network/interfaces to /etc/network/interfaces.original.

Delete all lines from /etc/network/interfaces not including the string "lo" (leaving two lines, probably the first two, beginning auto and iface).


If the above step leaves you with no internet connection at all, replace the original file and reboot.

I had to reboot a couple of times as well as add my Relakks information and then go back in and reedit.

It took a little patience, but I am posting this from my VPN connection.

I hope this information helps others!

alMubarmij 07-13-2008 08:04 AM

Is there a way to easy GUI access into Windows VPN server?

All times are GMT -5. The time now is 09:33 PM.