LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Can't connect to the internet with cable modem and SUSE 9.1 (https://www.linuxquestions.org/questions/linux-networking-3/cant-connect-to-the-internet-with-cable-modem-and-suse-9-1-a-352957/)

Hrothgar15 08-13-2005 04:41 PM

Can't connect to the internet with cable modem and SUSE 9.1
 
Can anyone help me in setting up my Ethernet network card to be able to connect to the Internet? If it helps, I'm on a Dell Dimension 9100 running SUSE 9.1 with KDE. Using the Internet works fine with windows. The ethernet cable connects from the computer to a router (which also has the cable of my other computer), and the router is connected to the cable modem. Thanks in advance.

aznluvsmc 08-13-2005 05:34 PM

First of all we need to check that the nic is receiving an IP address from the router.

Issue the following command as root:

ifconfig

Hrothgar15 08-13-2005 05:49 PM

OK, I did that, and it says the following:

lo Link encap: Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436
RX packets:318 errors:0 dropped:0 overruns:0 frame:0
TX packets:318 errors:0 dropped: 0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes: 20418 (19.9 Kb) TX bytes:20418 (19.9 Kb)

Also, I've gone to Control Center and went to "Network Devices," and it recognizes my network card and says it configures. However, I can't connect to the Internet. Thanks in advance.

aznluvsmc 08-13-2005 05:54 PM

Ok, the problem is that the network card actually isn't configured even though YaST may say it is. Try deleting the network card and then reconfiguring it.

This problem usually occrus when the network card is different from the last configuration. I always have this problem at school when I change computers using my removable hard drive. SuSE has this naming convention where the device file name for the NIC contains the MAC address so that you can't use a different NIC with it.

Anyways, give that a shot and let us know.

Hrothgar15 08-13-2005 07:38 PM

Alright, I tried that (removed it from the list, YaST found it again, and I reconfigured) but still no luck. Any ideas? I'm really starting to worry. I mean, I was able to connect so easily with Windows, not so with Linux.

aznluvsmc 08-13-2005 11:15 PM

After setting it up again does ifconfig show the network card? If not, try typing ifconfig -a to query all network cards that Linux detects.

cdat 08-14-2005 03:49 AM

hey m experiencin d same problems
windows just seems 2 b a lot better than linux now :(

cdat 08-14-2005 03:54 AM

hey do ul kno abt ny version of linux tat is much better at n/ws and d site i can download it from thanx ppl

Hrothgar15 08-14-2005 09:05 AM

There are two entries, lo and sit0. Is this good?

aznluvsmc 08-14-2005 08:27 PM

This is not good. ifconfig -a should have returned an entry for your NIC. What does YaST list your network card as (ie: manufacturer, type). We should probably verfiy that SuSE supports that NIC. Usually, if it can recognize the name then it should support it.

The only other thing I can think of is to try configuring the card manually by typing in as root:

ifconfig eth0 192.168.1.100

You should use an IP address that won't be assigned by the DHCP server to avoid a conflict. After running that command try ifconfig -a again and test if you can get on the Internet.

ciotog 08-15-2005 10:01 AM

My router acts as a dhcp server, so to get an ip address from it I have in /etc/rc.d/rc.local the following:
Code:

/sbin/dhcpcd eth0
That's with Slackware, I'm not sure if the local startup config file is the same with SUSE.

Hrothgar15 08-15-2005 08:55 PM

Hmm...I tried ifconfig eth0 192.168.0.100, but it doesn't recognize the interface of eth0.

YaST recognizes my newtork card as an ATI Ethernet Controller? Is this good? Also, does this have anything to do with a driver that I have to install?

aznluvsmc 08-15-2005 11:23 PM

Does ATI even make NICs? I don't think they do so it Linux may have mis-detected it. I assume this is a built-in NIC on the M/B?


All times are GMT -5. The time now is 02:25 AM.