LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-06-2008, 06:26 AM   #1
kiswahili
LQ Newbie
 
Registered: Feb 2008
Posts: 4

Rep: Reputation: 0
cant connect to internet thru a LAN


I am in a LAN where users in Windows can connect to internet using broadband.I am using opensuse 10.2 and can't connect to internet.I am new in linux and this is my 2nd week using this
 
Old 02-06-2008, 07:20 AM   #2
jimbo1954
Member
 
Registered: Oct 2006
Location: High Wycombe, Bucks, UK.
Distribution: Debian and Fedora Core in equal measure
Posts: 264

Rep: Reputation: 33
OK, so if users in the LAN can get to the Internet, then there is a way of getting there. However, it may be through a proxy.

Have a look at the browser config of one of the (working) windows machines. In (for instance ) Firefox, go to Tools/Options/Advanced (tab network)/Settings. Down the bottom of the window, you will see a place where you can tell the browser the name of the proxy. Copy this information into your linux browser, and it may be all you need.

If that doesn't work, please provide more information, like Browser name/version, your actions, exact error you get, and we can see if we can get closer to the prob
 
Old 02-06-2008, 07:27 AM   #3
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Cool cant conect to internet thru a lan

First in yast2 there is a option internet devices
Here you can configure a lan card that is supported by suse
If the ethernet card is not supported by suse You
have only one option than to buy a ethernet that is suported by suse PCI slot Not supported occurs mostly by a lan card on board

I had the same problem with my new computer I was lucky to have ethernet card from old pc that one was supported by suse


good luck
 
Old 02-11-2008, 11:00 PM   #4
kiswahili
LQ Newbie
 
Registered: Feb 2008
Posts: 4

Original Poster
Rep: Reputation: 0
still cant connect to net via lan

Went to the settings option of my browser and found that:
All other options are disbled!
i.e autodetect proxy settings for this netwrk and manual proxy config disabled,
the one that is being used is "Direct connection to the internet"

Am using mozilla firefox as my browser!
I appreciate your help guys!
Help me connect to the internet.

went to yast network devices,no change

Last edited by kiswahili; 02-11-2008 at 11:04 PM.
 
Old 02-12-2008, 02:41 AM   #5
jimbo1954
Member
 
Registered: Oct 2006
Location: High Wycombe, Bucks, UK.
Distribution: Debian and Fedora Core in equal measure
Posts: 264

Rep: Reputation: 33
OK, lets do some basic diagnostics:

in a terminal window, issue the command "ifconfig".

You should get an output which includes the line: "inet addr:217.149.127.10 Bcast:217.149.127.63 Mask:255.255.255.192" with addresses and masks that are something like that but not necessarily the same, and another line that says "UP BROADCAST RUNNING MULTICAST" .

Firstly, if the line just says "BROADCAST RUNNING MULTICAST" you have a problem with the card not starting properly, most likely because it cannot sense that it is connected to a switch or hub, so if this is the case, ensure that you have a straight-through RJ45 cable connection to your switch or hub. If it says "UP BROADCAST RUNNING MULTICAST", then we can continue. If not, and you can't see a reason for not being fully UP, then post back and we'll look some more.

Next, look at the address specified in the output; in the example above 217.149.127.10. If there is no address specified, the interface has not been configured correctly, and must be either configured with a fixed IP address, or configured to get one via DHCP (no room here to describe DHCP fully...google is your friend!). If there is an address, go on, if not, post back with full details.


Issue the command "ping 217.149.127.10", replacing the address here with the address that you got from your command output when you did the "ifconfig" command. What the "ping" command does is it tries to send echo-request packets to the address specified. In this case it is the address of the box you are on, so we are testing the ability of the box to see its own interface. If you get a response to your ping, then the interface is up and good, if not, then post back with all details collected so far. use cntl-c to stop the ping repeating, or it will go on indefinately. When you stop it with cntl-c, it will provide a summary output showing amongst other things the %age of successful pings. We need to see 100%.

At this point, you need to ascertain the address of your default gateway, and my guess is that you won't have got this far without finding some "issues" anyway, so post back and tell us what you have found. This is not a difficult diagnostic process when you are used to it, but there are many simple steps, and many choices of "next step" so bear with me, we'll sort this out!
 
Old 02-14-2008, 10:24 AM   #6
kiswahili
LQ Newbie
 
Registered: Feb 2008
Posts: 4

Original Poster
Rep: Reputation: 0
This is the message that i get when i ping:
10.1.1.237 ping statistics ---
103 packets transmitted, 103 received, 0% packet loss, time 102025ms
rtt min/avg/max/mdev = 0.029/0.036/0.044/0.004 ms

which i guess means the same as 100% successful!
Appreciate your help!
 
Old 02-17-2008, 12:33 PM   #7
jimbo1954
Member
 
Registered: Oct 2006
Location: High Wycombe, Bucks, UK.
Distribution: Debian and Fedora Core in equal measure
Posts: 264

Rep: Reputation: 33
OK, so it looks like you can get to your own interface. Thats a start!. Now issue the command "route". you should get an output something like this (if you don't, post back with what you have got back):
debian:/home/user# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
81.2.96.32 * 255.255.255.240 U 0 0 0 eth2
192.168.123.0 * 255.255.255.0 U 0 0 0 eth1
default 33.96.2.97.in-a 0.0.0.0 UG 0 0 0 eth2

find the "default" line, and now find the address associated with it, in this case it is 33.96.2.97...except that this is backwards, because its an "in-arpa" name, not an address. No probs, just reverse the numbers like this: 97.2.96.33 (obviously use the numbers your route command threw up) and ping that. You are now pinging the default gateway.

If you can ping that, that's good. If not, post back. Either way after this work, go to one of your windows machines that works now, and do an "ipconfig /all" from a command window and post up the results. When we have all that, we should be able to get somewhere!
 
Old 02-21-2008, 04:19 AM   #8
kiswahili
LQ Newbie
 
Registered: Feb 2008
Posts: 4

Original Poster
Rep: Reputation: 0
when i type route in terminal in linux i get:

IP routing table
Destination Gateway Genmask Flags Metric Ref Use
Iface
10.1.1.0 * 255.255.255.0 U 0 0 0 eth0

loopback * 255.0.0.0 U 0 0 0 lo


I cant see the DEFAULT address!!!!
in Windows when i type ipconfig/all in dos i get:
C:\Documents and Settings\mukapen>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : muchiri
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : JNET Intelligent Technologies

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : JNET Intelligent Technologies
Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast Eth
ernet NIC
Physical Address. . . . . . . . . : 00-19-66-4B-30-0F
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 10.0.0.33
Subnet Mask . . . . . . . . . . . : 255.255.240.0
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . : 10.0.0.1
DNS Servers . . . . . . . . . . . : 10.0.0.1
Lease Obtained. . . . . . . . . . : Thursday, February 21, 2008 1:16:24
PM
Lease Expires . . . . . . . . . . : Thursday, February 21, 2008 1:36:24
PM

PPP adapter JNET Inteligent Technologies:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : 00-53-45-00-00-00
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 10.5.7.169
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 10.5.7.169
DNS Servers . . . . . . . . . . . : 10.5.7.1
NetBIOS over Tcpip. . . . . . . . : Disabled
 
Old 02-21-2008, 04:37 AM   #9
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
It looks to me that you didn't opt to use DHCP when you configurated the network device.
Run through the Network Devices configuration in YaST2.
 
Old 02-22-2008, 03:10 AM   #10
jimbo1954
Member
 
Registered: Oct 2006
Location: High Wycombe, Bucks, UK.
Distribution: Debian and Fedora Core in equal measure
Posts: 264

Rep: Reputation: 33
Something odd going on here! Your Windows "ipconfig /all" output shows that there is no default gateway:

<snip>
"Physical Address. . . . . . . . . : 00-19-66-4B-30-0F
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 10.0.0.33
Subnet Mask . . . . . . . . . . . : 255.255.240.0
Default Gateway . . . . . . . . . :"
<snip>

The "Default Gateway" field is empty.But you say the Windows browser works (but the Linux browser doesn't)

Now if this windows machine is able to access the Internet, I assume that the Browser has an address set up as a proxy, so go into Tools/Internet Options/Connections/LAN Settings on the browser, and see what is configured there.

I am guessing that there will be a name or an address entered there; what it is doing is telling the browser to send ALL its traffic to a certain address (that of the "Proxy"), rather than sending each request to the target www server. The proxy is a device that takes all requests, filters them, and issues them to the wider Internet.It may be that this has been set to the address of the Internet router, and the router is proxy-ing. It's not a valid configuration, but it may work

If there is an address in there, then that should be included in your Linux browser configuration. If not, post up what you see and we'll see where we go from here
 
Old 06-05-2008, 11:29 PM   #11
eCubeH
LQ Newbie
 
Registered: Jul 2007
Posts: 12

Rep: Reputation: 0
Jimbo - I have been following all your instructions, they are great. Why did you not complete it? I am on a Compaq desktop with Fedora 9 (dual boot with Win Vista), connected to a LAN of Windows computers (with dual boot Fedora 9), with broadband modem connect directly to the switch. Internet works fine on the Windows side on the LAN.

I followed your instructions on Fedora 9, came up to the point of pinging the gateway, which in my system is 192.168.1.1. When I ping this, I get the response, though when I ping the reverse as you suggested 1.1.168.192, I get destination net unreachable.

How do I proceed?

Bala
 
Old 06-06-2008, 09:25 AM   #12
lsteacke
Member
 
Registered: Jul 2007
Distribution: Ubuntu
Posts: 99

Rep: Reputation: 16
Pinging the reverse ip of your default gateway is only necessary in specific cases, when it is an in-arpa name. Its a good sign that you can ping 192.168.1.1. We'll probably next need to check DNS. Post the output of

Code:
cat etc/resolv.conf
Does this ip match the ip address of the DNS server on vista?
 
Old 06-06-2008, 11:30 PM   #13
eCubeH
LQ Newbie
 
Registered: Jul 2007
Posts: 12

Rep: Reputation: 0
/etc/sysconfig/network-scripts/ifcfg-eth0

Thanks lsteake. That did it. I entered the Primary & Secondary DNS in the file /etc/sysconfig/network-scripts/ifcfg-eth0, as
DNS1=202.56.224.153
DNS2=59.144.127.17

And rebooted. (or perhaps stopped and restarted Network Manager).
Now the /etc/resolv.conf file has these settings.
And now the net connection is established.

Also, I disabled SELinux.
And I disabled and then later enabled Firewall.
Don't know the consequences of these.
Firewall is enabled presently (some services were enabled automatically and I left it at that), and SELinux presently disabled.

Next I am working on 2 things - Samba share and Wireless DI-524 connect (through the DES 1016D switch). Have to sort through many links, if there any you recommend, would appreciate it, though I am aware that's not the subject of this posting.
 
  


Reply

Tags
internetconnection


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
connect to internet trough wireless others connect to me with lan Amir Menesy Linux - Wireless Networking 1 11-13-2007 08:28 PM
Lan can't connect to Internet hairi Linux - Networking 3 04-19-2006 03:12 PM
No Internet but LAN and VPN connect LAN work fine??? xavior SUSE / openSUSE 7 11-09-2005 01:14 PM
Can't connect to the internet through my LAN... help? bigmetalrabbit Fedora 5 10-03-2005 01:46 AM
Can't connect to internet through the LAN Whatshisface Linux - Networking 18 02-09-2004 10:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration