LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-07-2004, 07:40 PM   #1
jasarien
Member
 
Registered: Apr 2004
Location: Wales, UK
Distribution: Fedora Core 3
Posts: 31

Rep: Reputation: 15
Cant connect to internet!! augh!


Ok, I've just installed Fedora Core 1... I set up the eth0 device to get IP address via DHCP... which it couldn't apparantly..>
I'm using Windows XP Pro's ICS to share my internet connection...

I set my firewall security down a notch on Winxp, and now Linux can obtain an ip: 192.168.0.170 - now I know this is on the same IP range as the XP machine, but there is still no internet connectivity whatsoever within Linux...

Any ideas!?
 
Old 04-07-2004, 09:28 PM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Does your nose run and your feet smell? Linux should serve Windows, not the other way 'round!

Does the WindowsXP box have a DHCP server installed and is the DHCP server running?

What is the result of ping <winxp box name> from the linux box?

Linux Networking HOWTO
 
Old 04-07-2004, 10:23 PM   #3
Dobly
LQ Newbie
 
Registered: Apr 2004
Location: Sydney
Distribution: Fedora Core 1 (Yarrow)
Posts: 23

Rep: Reputation: 15
fancypiper

I'm in the same boat as jasarien. I can't get Linux to use the connection I have shared on my XP box.

Quote:
Linux should serve Windows, not the other way 'round!
For me anyway, it is fully my intentention to use Linux to serve Windows, once I am sure I'll be able to get my USB ADSL modem working in Linux. Until that time, it will have to be the other way around.

I don't understand your link to the index of the long winded How To on Linux networking. I spent about 15 mintues there and could not find a section on connecting Linux to a Windows shared internet connection. Is there one there? Perhaps you could supply a more accurate link to pin point the chapter it is in. Thanks heaps.

I'll try that ping <winxp box name> thing in a few hours time (when I get home from work) and post my result here.

Last edited by Dobly; 04-07-2004 at 10:24 PM.
 
Old 04-07-2004, 10:42 PM   #4
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Little infogiven yeals vague (to you as of now) links as info is the help rule,. I am afraid.

Asking smart questions

Promising thread I found with a board search.

How does Windows XP connect to the internet and how many NICs are installed on it?

In other words, you need to describe your existing hardware setup and configuration, what you tried, the result, etc.
 
Old 04-07-2004, 11:13 PM   #5
Dobly
LQ Newbie
 
Registered: Apr 2004
Location: Sydney
Distribution: Fedora Core 1 (Yarrow)
Posts: 23

Rep: Reputation: 15
How right you are fancypiper. Sorry i was so 'vauge'.

Box 1:
WinXP
Internet Connections shared
USB ADSL Modem
1 x NIC (192.168.0.1)
2 other Windoze machines (192.168.0.2 and 192.168.0.3) using the shared connection.

Box 2:
Linux (Fedora Core 1)
No modem (yet)
1 x NIC (192.168.0.55)
Gateway set to 192.168.0.1 (the XP box)

I can ping from one box to the other, no problem. Just that when I try to connect to the net, (open Mozilla and try http://www.google.com) it does not work.

I have not tried http://<googles IP address> but I will when i get home tonight.

Thanks for the 'Promising' link. Looks like it might have the answer. I have more stuff to try when i get home.

Thanks also for the 'Smart Questions' link. Touche!
 
Old 04-07-2004, 11:46 PM   #6
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
So you are manually assinigning the local area network IPs and accessing the internet via the usb asdl modem using DHCP to assign your internet IP. If that device has the plugs that the cords from the computer NICs plug into, that device is the default gateway, which is usually assigned to 192.168.0.1

Edit your /etc/hosts file to read something like this:
Code:
127.0.0.1       <linuxboxname>        localhost.localdomain   localhost
192.168.0.<N1>	<WinXPboxname1>
192.168.0.<N2>	<WinXPboxname2>
192.168.0.<N2>	<WinXPboxname3>
192.168.0.<N2>	<linuxboxname>
I also use an /etc/resolv.conf file:
Code:
# Duron 950 uillean box /etc/resolv.conf file
domain infoave.net
nameserver 192.168.0.1
nameserver 206.74.254.2
nameserver 204.116.57.2
I got the numbers (besides the default gateway 192.168.0.1 from my ISPs support page.

Then try pinging each box on the LAN, then ping something like http://www.google.com/ for testing.

Last edited by fancypiper; 04-07-2004 at 11:53 PM.
 
Old 04-08-2004, 12:19 AM   #7
Dobly
LQ Newbie
 
Registered: Apr 2004
Location: Sydney
Distribution: Fedora Core 1 (Yarrow)
Posts: 23

Rep: Reputation: 15
First up, the ADSL modem plugs only into a USB port on the XP box. There are no cords from it running to the NIC.

The NIC in the XP box has a Cat5 cable to a switch. All the machines are plugged into this switch.

Next, when I enter in these values...

<linuxboxname> localhost.localdomain localhost

how can I confirm the correct values.. I know that I just did the install and entered in values for these. I just want to check that i put the correct parts of what I entered into the right spots. Are there commands to show me these values.. Would ifconfig be that command? (I'm not on my Linux box now so i cant' try it)

Next, what is this line..?

domain infoave.net

Is that your ISP or your local domain?

Finally, when you say "I also use an /etc/resolv.conf file" are you suggesting that you don't need to use it, that it was always there and you just filled it in, or that you had to create it and put the values in? And if the latter is the case, do you have to tell the machine to use that file, or will Linux always look for it?
 
Old 04-08-2004, 12:40 AM   #8
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Quote:
Originally posted by Dobly
First up, the ADSL modem plugs only into a USB port on the XP box. There are no cords from it running to the NIC.

The NIC in the XP box has a Cat5 cable to a switch. All the machines are plugged into this switch.
OK I believe your box with the IP of 192.168.0.1 will be the default gateway/
Quote:
Next, when I enter in these values...

<linuxboxname> localhost.localdomain localhost

how can I confirm the correct values..
127.0.0.1 is your loopback address for your box also your HOSTNAME can be assigned to it with what I posted above
Quote:
I know that I just did the install and entered in values for these. I just want to check that i put the correct parts of what I entered into the right spots. Are there commands to show me these values.. Would ifconfig be that command? (I'm not on my Linux box now so i cant' try it)
My result:
Code:
Thu Apr 08 12:31 AM root@uilleann ~ # ifconfig
eth0      Link encap:Ethernet  HWaddr 00:D0:09:EA:78:2F
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:1134 (1.1 Kb)
          Interrupt:12 Base address:0xd800
 
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2718 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2718 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:458495 (447.7 Kb)  TX bytes:458495 (447.7 Kb)
 
ppp0      Link encap:Point-to-Point Protocol
          inet addr:207.144.87.244  P-t-P:206.74.14.59  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1524  Metric:1
          RX packets:15984 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16373 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:14917369 (14.2 Mb)  TX bytes:1523872 (1.4 Mb)
Quote:
Next, what is this line..?

domain infoave.net

Is that your ISP or your local domain?
My ISP provider is named infoave.net
Quote:
Finally, when you say "I also use an /etc/resolv.conf file" are you suggesting that you don't need to use it, that it was always there and you just filled it in, or that you had to create it and put the values in? And if the latter is the case, do you have to tell the machine to use that file, or will Linux always look for it?
Some distros overwrite this automatically, so I usually keep a backup to replace it when the automatic stuff screws it up for me. I just replace it and I am back in buisness.

Theoretically if you set up a cache maneserver on your gateway box, (192.168.0.1), the others can find the numbers from the name without having to contact your ISPs nameservers.
 
Old 04-08-2004, 03:34 AM   #9
jasarien
Member
 
Registered: Apr 2004
Location: Wales, UK
Distribution: Fedora Core 3
Posts: 31

Original Poster
Rep: Reputation: 15
sorry to waste your time... i got mine working now..... I dunno why, but Linux wouldn't pick up any DNS servers with the DHCP... it got an IP address, but no DNS... So I had to specify the 2 DNS servers for my ISP manually, and it works now..

And yes, you are right, I fully support that linux should server windows, but I haven't totally figured out how to do that yet, any HOWTO's around?
 
Old 04-08-2004, 06:26 AM   #10
Dobly
LQ Newbie
 
Registered: Apr 2004
Location: Sydney
Distribution: Fedora Core 1 (Yarrow)
Posts: 23

Rep: Reputation: 15
fancypiper

You are Da Man!

It worked

I did the edits you suggested to /etc/hosts and /etc/resolv.conf .

I then did the pinging you suggested and I was happy to find that I could ping 216.239.57.104 (google).

I then opened Mozilla and there is was, the Google home page.

I am typing this now from my Linux box.

Thanks so much for you help. I learned heaps in my search for an answer on this one.

For my next 'trick' I am going to mount an ntfs parition, then install the ADSL USB modem on this box and then setup Samba. Oh, the joy that awaits me.

Thanks again fancypiper!
 
Old 04-08-2004, 11:18 AM   #11
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Linux Networking HOWTO
 
Old 04-08-2004, 05:05 PM   #12
jasarien
Member
 
Registered: Apr 2004
Location: Wales, UK
Distribution: Fedora Core 3
Posts: 31

Original Poster
Rep: Reputation: 15
Thanks, I'll take a look at it
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
When i connect on the internet I want root not to access the internet !! skouket Linux - Security 12 07-10-2005 01:17 PM
Messed up my Internet Settings (can't connect to the internet) Almazick Linux - Wireless Networking 0 09-07-2004 07:23 PM
can't connect to the internet:linux dont read my internet address droplsh Linux - General 1 02-29-2004 08:32 PM
Can connect broadband but can't connect Internet satimis Linux - Networking 4 01-31-2004 08:58 PM
augh! stupid mail!!! asc3ndant Linux - General 1 03-06-2003 05:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration