-   Linux - Networking (
-   -   Can't activate network device (

ozstar 10-31-2003 02:32 AM

Can't activate network device

I have RH8 with a NIC card that it recognises on boot. I am using Gnome GUI and trying to connect to a LAN hub which connects to a router which connects to a cable modem.

My other boxes are XP and all are fine on the network and web.

I am not sure about the addresses and host name I am to use in the configuration wizard.. Where do I get these from?




linuxbotx 10-31-2003 02:34 AM

DHCP should do all that for you. Do you have DHCP enabled?

Robert0380 10-31-2003 02:37 AM

wizards suck.

open an terminal and type the following:


if you dont see eth0, try:

/sbin/ifconfig -a or /sbin/ifconfig/eth0

you should get info on eth0 either way, -a will show u all interfaces.

if you see eth0 now, but didnt see it with just an /sbin/ifconfig

then try /sbin/ifconfig eth0 up

then, if the router issues ip addreses for your network (DHCP):

dhcpcd eth0 to get an ip address

this should work. if not, let us know where it went all bad for you.

ozstar 10-31-2003 03:40 AM


I got a result only with the-a. It was..

RX Packets all 0's
TX packets all 0's
no collisions txque 100
RX bytes 0 TX bytes 0
Int 10 etc

with /sbin/ifconfig eth0 up - no result, just went to next empty command line

with dhcpcd eth0 - no such file or dir

Thanks again..

ozstar 10-31-2003 04:24 AM

I have since done.. /etc/rc.d/init.d/dhcpd start and it just took me to the next empty command line.

I then did a /sbin/ifconfig and got this..

RX packs 156 errors rest are 0's
TX packs all 0's
collisions 0 txqueue 100
RX bytes 17608 (17.1kb) TX bytes 0
Int 10

Maybe closer ??

ozstar 10-31-2003 05:16 PM

Help still needed please.

As well as the above post, when I ping I get ' 'Network Unreachable'

ozstar 10-31-2003 05:49 PM

This is my latest effort - but its still not getting thge network.

with ifconfig I have..

Line 1. Link encap: Ethernet HWaddr 00:60 etc
Line 2. UP BROADCAST etc
Line 3. RX Pack 1161 errors - rest are 0's
Line 4. TX packs all 0's
Line 5. Collisions 0's - TX eque 0's
Line 6. RX bytes 143421 TX 0
Line 7. Int 10 base o

I also get a loopback congig which does give the inet address on the second line .. 127.0.01 Masl. also UP LPPOP RUNNING

With lspci I get the card..

00:0d.0 Ethernet Controller: Realtek Semi Conductor Co .RTL-8139/ etc...

lsmod I get..

8139too -- I noticed this # is in the Realtek line.

I am lost here as I still cannot get to the network. I am missing something somewhere but have no clue where to go now.

musrum 11-01-2003 11:39 AM

Alright, you have the interface up. Now try

dhcpcd eth0

Then go back and try ifconfig eth0. Tell us what you see. If your access provider gave you a "DHCP Server Name" (most don't), then you need to use:

dhcpcd -h HOSTNAME eth0

Where HOSTNAME should be replaced by the DHCP hostname that your provider gave you.

Now, the problem is, you don't want to go through this every time you restart your computer. I don't use RedHat, so I can't give you specific instructions. Some else doubtless will.

However, the comment made before that 'wizards suck' is a bit limited. Once you learn how to administer a Linux system with out wizards, then for you they will suck. But till you have learned enough to do that, wizards can be a great help. So go ahead and try the wizard again. The key point is that you need to tell the wizard that you want to use DHCP. It should work for you now.

ozstar 11-01-2003 08:07 PM

Hi and thanks.. Got excited to think I am so close but..

I get the 'command not found' message with dhcpcd eth0. I have tried it at root in sbin and etc./rc.etc but still the same answe. I am not sure how I can make a search of all files across the HD to find it either.

Thnks so far, really appreciate the help.

ozstar 11-02-2003 05:00 AM

Still trying...

I am not sure whether I have done the correct thing or not but I have entered,

ifconfig eth0 up

With ifconfig eth0 I now see the NIC is UP with..

inet adr 192. 168.168.110 Broadcast

RX packs 429 errors
TX 41 errors
collisions 0
TX Bytes 76148

I used the address becaise the network already has XP boxes with IP's up to 108. The gateway is

I can ping all the IP's within that range including gateway 1, but get the 'unknown host' when I put an name address in say,

I am not sure if I have the correct figurers in the GUI Network Config area. They are..

Eth0 IS active.
(Edit) Auto DHCP
(Route) Destin Netwk - Gateway
(Hosts) IP Name LinuxBox Alias localhost.localdomain localhost
(DNS) Primaray Se Domain name: MSHOME.NET

Please advidse me what I have incorrect.

ozstar 11-02-2003 05:37 AM

Ah Ahh.. I have got the network. Not sure what happened, but have the above configs (I think( I will check. but..

I can't get to the Internet. The gateway IS for all the others on the LAN.

Please help with this one last bit here.. I've spent 3 days on this..


Robert0380 11-02-2003 05:43 AM

try /sbin/dhcpcd eth0

sounds like it's not in your path. sorry i forgot to put /sbin/ on the front of it in my original post. if this is the case, you'll get the same error if you leave it off of ifconfig.

make sure u are doing this as root also.

ozstar 11-02-2003 06:01 AM


Yes I checked it again in root and /sbin/ but both times I get the error 'No such file or directory' Strange!

ozstar 11-02-2003 06:06 AM

I can actually get to all my boxes on the LAN now although just see their dirs but can't get [past that to the files altho I have some of them shared.

I also get to the Linux box from my main XP box. So this is all okay but still can't get the Internet .

So close but so far....

Robert0380 11-02-2003 06:06 AM

so this..

#updatedb (leave off the # of course, that's just tye symbol for root prompt)
#slocate dhcpcd | grep /dhcpcd | less

and see if u see the command in one of the *bin folders

you could even try

#slocate dhcpcd | grep bin/dhcpcd | less

on my system it gave me


All times are GMT -5. The time now is 10:56 AM.