-   Linux - Networking (
-   -   Cannot ping router - DHCP not working (

PieSquared 03-23-2007 07:16 PM

Cannot ping router - DHCP not working
I am a newbie to Linux and Ubuntu, so please excuse any stupid questions. :)

The problem that I am having is that after installing Ubuntu, I am not able to access the internet. More specifically, I cannot ping the router and the DHCP is not working.

ping -c 5 outputs:
PING ( 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable

The second line is repeated 5 times. By the way, the reason that says "From" is because I have assigned the IP adress by executing "sudo ifconfig eth0 netmask up". After executing sudo dhclient again, it outputs "connect: Network is unreachable" and ifconfig eth0 does not show an IP adress.

When executing dhclient, this is the output:

Listening on LPF/eth0/00:c0:a8:87:26:7d
Sending on LPF/eth0/00:c0:a8:87:26:7d
Sending on Socket/fallback
DHCPDISCOVER on eth0 to port 67 interval 3 (this line is repeated several times)
No DHCPOFFERS received.
No working leases in persisent databasee - sleeping.

Other relevant information (as gathered from other forums):



Kernel IP routing table
Destination Gateway Genmask Flags Metric Reg Use Iface

I've tried to solve this, however, no solution seems to help. Please help, and if any other information is needed I'll try to provide it.

dxqcanada 03-23-2007 08:43 PM

How do you know the DHCP server is still working ?

When you manually assigned an IP address to your interface (and you do not run dhclient) ... can you ping the router ?

PieSquared 03-23-2007 08:53 PM

I don't know whether the DHCP servers are working :(

But what I posted above is what you are asking for. If I assign a static IP, then pinging the router ( still doesn't work, because it gives me the "Destination Host Unreachable". That is what the ping I showed was for. Sorry if I did not make this clear.

dxqcanada 03-23-2007 09:08 PM

If you run ifconfig ... are there any packets received ?

I assume you have checked the physical link ie. cable ... port on hub/switch.

PieSquared 03-23-2007 09:32 PM

Yes, I have checked the physical connection :D

Here is the output of ifconfig:

Link encap: Ethernet HWaddr 00:C0:A8:87:26:7D
inet6 addr: fe80::2c0:a8ff:fe87:267d/64 Scope: Link
RX packets: 11947 errors:0 dropped:0 overruns:0 frame:0
TX packets: 1495 errors:0 dropped:0 overruns:0 frame:0
collisions:0 txqueuelen:1000
RX bytes: 733532 (716.3 KiB) TX bytes:505895 (494.0 KiB)
Interrupt:201 Base address:0xcc00

It also gives the stuff for lo. I think this means that it is receiving packets, right?

Petro P 03-23-2007 10:33 PM

Firstly, try telling dhclient what interface to look on


sudo dhclient eth0
Just a thought. If this doesn't work, try making eth0 your default route


sudo route add default eth0
Then try dhclient as stated above. Still not working? Let's try manually assigning an IP.


sudo ifconfig eth0 192.168.x.x netmask
sudo ifconfig eth0 up

But we're not done yet, because even though we set the right IP address and subnet mask, we still need to set the default gateway.


sudo route add default gw 192.168.x.1
Now type 'route' - you will probably have something like me now:


Kernel IP routing table
Destination    Gateway        Genmask        Flags Metric Ref    Use Iface    *      U    0      0        0 eth1
loopback        *          U    0      0        0 lo
default        UG    0      0        0 eth1

Since your /etc/resolv.conf seems to be fine, I won't go over it much, but you might want to try setting your nameserver to simply your default gateway.

Here's my /etc/resolv.conf as an example


# Generated by dhcpcd for interface eth1
search no-domain-set.bellcanada

Mind you, DNS will play no part in being able to ping your router.

Hope this helps.


PieSquared 03-23-2007 11:05 PM

I tried what you suggested, however, it did not help. Here is the output of "route", as it was a bit different from yours:


Kernel IP Routing table
Destination      Gateway        Genmask        Flags  Metric  Ref    Use  Iface      *      U      0        0      0    eth0
default        UG      0        0      0    eth0
default          *            U      0        0      0    eth0

Pinging the router ( still gives me the "Destination Host Unreachable" message.

Any other suggestions?

Petro P 03-23-2007 11:51 PM

Try removing this entry from the routing table:


default          *            U      0        0      0    eth0
It could be creating some conflicts. The next step after this is to check the physical wiring and stuff... there's really not much else you can do - clearly the OS is picking up the ethernet card if the interface exists, and if you're able to set parameters like ip address with no problems then there's no software faults as far as I could tell.

Try resting your router (power off, keep it off for a few minutes, turn it back on)
Try using another ethernet patch cord
Try connecting the computer via crossover cable to another system and making them communicate to isolate whether this problem is reproducible with other networks

Let us know how it goes.

PieSquared 03-24-2007 10:39 AM

No, removing that does not help.

As I understand, it can access the ethernet card, but not the router, because pinging the router or any other computer on the network results in the Destnation Host Unreachable. (All the other computers are running XP)

The same computer is also running Windows XP, and if I reboot into Windows, the internet works fine, so I don't think this could be a hardware problem.

Resting the router does not seem to help either. I'll try to see whether the same problem is reproductible with either networks though. Thanks for the suggestion.

jmbrink26 03-24-2007 11:21 AM

Ok, in Ubuntu, try this:

In the shell, type: "/etc/init.d/networking stop", hit Enter, then type "/etc/init.d/networking start", and hit Enter. That will stop/restart DHCP, and TCP/IP.

Then go back to your /sbin/ifconfig, and it should have a valid IP. If you're still having issues, clear the routing tables on your router. Sometimes, that's all it is.

PieSquared 03-24-2007 11:49 AM

Same result as before if I try to ping the router or another computer on the network: "Destination Host Unreachable"

What exactly does that message mean?

Petro P 03-24-2007 12:01 PM


Originally Posted by PieSquared
Same result as before if I try to ping the router or another computer on the network: "Destination Host Unreachable"

What exactly does that message mean?

It means that your machine is replying to you that it can't access the target network.

Try running

dmesg | tail
to get kernel messages - run this right after your ping or whatever. I found a thread at with a guy that seems to have a similar problem - here's the link:

PieSquared 03-24-2007 03:47 PM

It is a similar problem, but on this computer everything works fine on Windows XP, so it can't be a hardware problem (I don't think)

The output from dmesg | tail after ping is basically this:

eth0: link up, 100mbps, full-duplex, lpa 0x41E1
eth0: no IPv6 routers present
NET: registered protocol family 17
PPP generic driver version 2.4.2
NET: Registereed protocol family 24


acid_kewpie 03-24-2007 04:00 PM

ok, seems fairly odd, subnet is fine and such, which would be my first point of call.

i've seen various things like icmp packets coming back malformed and such, we can back up to a lower level farily easily though.

firstly, is this host listed in your arp records? it shouldn't be based on the host unreachable message. after pinging it, run "arp -n" to list the known entries. if it's not, let's also look at the initial arping and icmp packets. run "tcpdump -vn arp or icmp" and try a ping. if it's not in the arp cache, you should firstly see the arp broadcast, and then IF the arp is successful, the icmp echo request itself. you'd probably want to totally fluch to arp cache first too.

PieSquared 03-24-2007 04:13 PM

Sorry, I didn't exactly understand everything you just said, but here's what I did:

After pinging, arp -n (as you said) outputs:

Address                  HWtype  HWaddress                Flags Mask                  Iface                      (incomplete)                                          eth0

If, after that, I run "tcpdump -vn arp or icmp" it says:

tcpdump: no suitable device found

I'm afraid I didn't completely understand the last part. How do I flush the arp cache? Do I need to?

Thanks for looking into this.

All times are GMT -5. The time now is 07:00 PM.