-   Linux - Networking (
-   -   Cannot find wireless network anymore after reboot last night (

ck1 12-06-2012 03:55 PM

Cannot find wireless network anymore after reboot last night
Hope someone can help me relatively soon. I have been having a similar issue.

Last night everything was working perfectly fine. This morning when I booted up BT5, wicd could not locate any wireless networks. I have tried just about everything I can think of.

dmesg does not bring up any issue with my wifi card. I am using a Broadcom Corporation BCM4311

The output of ifconfig is (for wlan0):

Link encap: ethernet HWaddr 00:19:38:24:26:c9
RX packets:0 erroors:0 dropped:0 overruns:0 frame:0
TX packets:0 erroors:0 dropped:0 overruns:0 frame:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

The output of iwconfig is:

IEEE 802.11bg ESSIDff/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thrff Frament thrff
Encryption keyff
Power Managementff

I have run ifconfig wlan0 up multiple times. I have tried running 'dpkg-reconfigure wicd' and 'update-rc.d wicd defaults' to set it back to defaults.

I am wondering if maybe I have something blacklisted by mistake and it is interfering, yet I am not too familiar with /etc/modprobe.d

wicd-gtk displays no errors that I can see. Anybody have any other tips? It was fine last night....a simple shut down screwed this up..

SouthernC 12-06-2012 05:53 PM

what is the output of "iwlist wlan0 scan" ? does it show the ssid of your network ?

ck1 12-06-2012 05:58 PM

the output is:

wlan0 No scan results

frankbell 12-06-2012 09:50 PM

Do you have other wireless devices that you have used to test your router/access point? If not and if the computer is portable, test it at a location with public wireless.

It's important to isolate the source of the problem before you tear your hair out with software. True, it's unlikely that your router/access point has turned turtle, but, if it has, no amount of software troubleshooting on the computer can fix the problem.

I've had situations where a wireless connection held until it was broken, as by a reboot, and then the device could not reconnect. The problem was solved by rebooting the router. The router kept existing connections, but would not accept new ones.

ck1 12-06-2012 09:52 PM

Yes it works I use 3 other.computers on it and my phone

---------- Post added 12-06-12 at 10:53 PM ----------

I've also reset the router multiple times

frankbell 12-06-2012 09:54 PM

I would still suggest testing the computer at a public access location, if you can. It could be the wireless card has gone west.

Have you tried using a wired connection to make sure overall networking still works?

Edit: This stinks. I know; I've been there.

ck1 12-06-2012 10:06 PM

my card doesnt pick up the neighbors any more or my phone AP.

ck1 12-06-2012 10:08 PM

my wired still seems to work great

SouthernC 12-06-2012 10:55 PM

what output does /etc/network/interfaces file have in it ? should look similar to this
auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp
wpa-ssid yournetwork
wpa-psk yourpassword
assuming you dont use static and allow dhcp set your ip etc

SouthernC 12-06-2012 11:01 PM

accidentally double posted

markush 12-07-2012 06:03 AM

If you have a laptop, it's possible that there's a button anywhere which enables and disables wifi on the laptop. Pressing this button by accident is one of the most common causes for unexplainable wifi-problems.


ck1 12-07-2012 08:35 AM

I have enabled and disabled wifi multiple times with the on/off button. I know it is on now b/c the card is recognized in iwconfig and dmesg doesnt bring any more error up anymore.

As for /etc/network/interfaces:

-bash: /etc/network/interfaces: command not found

eantoranz 12-07-2012 03:03 PM

that should be a cat:

cat /etc/network/interfaces

---------- Post added 12-07-12 at 06:04 PM ----------

And that will have some meaning in case you are running a debian derivative and not using Network Manager.

ck1 12-07-2012 03:05 PM

The output of cat /etc/network/interfaces follows:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp

auto ath0
iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp

frankbell 12-07-2012 07:32 PM

Try booting to a Live CD of something and testing the wireless. I would suggest Mint or some other distro known for including lots of drivers.

If it doesn't work in that situation, the odds of a hardware failure seem much more likely.

Good luck.

All times are GMT -5. The time now is 02:31 PM.