-   Linux - Networking (
-   -   Cannot connect to wireless (intel pro 2915abg) in backtrack 4 r2 (

unassassinable 01-11-2011 11:03 PM

Cannot connect to wireless (intel pro 2915abg) in backtrack 4 r2
I am on an IBM thinkpad t43 using backtrack 4 r2. Wireless works in windows (/dev/sda1), openSUSE 11.3 (/dev/sda2), but not backtrack (sda3)


#cat /proc/pci

02:02.0 network Controller: Intel Corporation PRO/Wireless 2915ABG [Calexico2] Network Connection (rev 05)
Subsystem: Intel Corporation Device 1010
Flags: bus master, medium devsel, latency 64, IRQ 11
Memory at c0200000 (32-bit, non-prefetchable) [size=4K]
Capabilities: <access denied>
Kernel driver in use: ipw2200
Kernel modules: ipw2200


# lsmod | grep ipw
ipw2200              129580  0
libipw                22696  1 ipw2200
cfg80211              120768  2 ipw2200,libipw
lib80211                3070  2 ipw2200,libipw


#ifconfig  (this is the entry fr my wireless card)
eth1      Link encap:Ethernet  HWaddr 00:13:ce:56:1e:0c
          inet6 addr: fe80::213:ceff:fe56:1e0c/64 Scope:Link
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:57 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:17568 (17.5 KB)
          Interrupt:11 Base address:0xe000 Memory:c0200000-c0200fff


eth1      IEEE 802.11abg  ESSID:"buttars"
          Mode:Managed  Channel:0  Access Point: Not-Associated
          Bit Rate:0 kb/s  Tx-Power=20 dBm  Sensitivity=8/0
          Retry limit:7  RTS thr:off  Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

I previously tried to manually connect to my open wifi router sitting right next to me using these commands (keep in mind this laptop is triple booted and wifi works in winXP, and openSUSE 11.3):


#iwlist eth1 scan (it did not find anything)
#iwconfig eth1 essid buttars
#dhclient wlan0

I used to get errors while booting that showed up in dmesg as something like "ipw2200 module failed error -2". Searching the forums I found this command:


#cp -v /lib/firmware-2.6.34/ipw* /lib/firmware/
That cleared up the errors and from then on I had eth1 in ifconfig.

Can anyone point me in the right direction?


Person_1873 01-13-2011 09:00 AM

can you post the output of ifconfig eth1

unassassinable 01-14-2011 03:04 AM

I did above.

Anyway, I took it to school today, and scanned for our wireless. It actually found it and was able to connect. I didn't do anything from the time I ran that copy command and connected at school except turn it off for the night. So Im amusing the copy command worked and it just needed a hard boot. That or a good nights rest...which is what I need right about now.


Person_1873 01-14-2011 10:43 AM

another thing may be that your intel wireless drivers may be locked to the wrong channel range and your school network just happened to be in that range, it's a common issue with intel wireless cards, i can't remember the URL but a quick google should find it

All times are GMT -5. The time now is 03:31 AM.