-   Linux - Networking (
-   -   Cannot connect to Samba Server over VPN on Windows Network (

trout256 09-08-2005 10:12 PM

Cannot connect to Samba Server over VPN on Windows Network
I was finally given permission to try an experiment at work, which is to setup a linux file server that our entire division could make use of. I was given a Windows box and allowed to wipe it clean and put Suse 9.1 on it. I then ran the online updates, and installed the Samba server, and setup some share folders for testing.

Our satellite sites all have Windows 2000 machines that connect to our corporate network via broadband connections using the MS VPN and PPTP.

Now, all of the machines at the office (local LAN where the Suse machine is plugged into) can see the Samba shares and access them perfectly, no problems.

Of course, the Windows 2000 machines at the satellite sites using the MS VPN cannot "see" the Suse machine at all. These machines can still see the Windows workgroups, domain machines, and shares via the VPN, but not the Linux machine or its shares.

I have been reading the posts at this site, but I must be missing something. Why is this not working?

It seems to me that it should be possible for the Windows machines at the satellite sites to still use their original Windows network shares and such, and also be able to access this new Linux machine and its shares, all using the infrastructure and the MS VPN like everyone is used to.

Please help! I am quite impressed with Linux, and I am quite optimistic that I am just missing some key points and that this is really easy and not impossible. I really hope someone can shed some light on this! I will be happy to give more information if necessary. Thanks!


Matir 09-08-2005 10:45 PM

Can you ping the samba server? Access its shares via \\IPADDRESS? Is the samba server on the same subnet as everything that can be seen?

trout256 09-11-2005 12:52 PM


Thank you so much for your help! Sorry for the time to reply; work, children, the dog, etc.

I did a test ping from a satellite site and it worked. I then tried \\IPADDRESS\SHARE (had to use XX_XX format) and it worked perfectly from the satellite sites and from the office.

Now, I have another question that hopefully you can help me with (can you tell I am new to Linux or what?). Everything worked perfectly for a number of hours. Then, I lost the connection to the Suse 9.1 machine. I have not been back at the office since then, so I do not know if that machine actually "crashed" or has gone into some kind of mode that I do not want it to go into or what. Are there settings regarding "always on" behavior for Linux I am missing or something of that nature? I need this machine to stay on 24/7.



Matir 09-11-2005 12:57 PM

There might be some ACPI related settings on the SuSE machine, it's hard to know. If you knew what happened, this would be a far easier question to answer. :)

trout256 09-11-2005 02:33 PM


Well, I did not make any changes to ACPI settings that I am aware of. Do you know, does SUSE 9.1 default to some kind of ACPI powerdown, disconnect, etc. setting after a certain amount of time?

I will know more beginning next week, and I will post the information for you to check out if there is no obvious solution I can apply without help.

Thanks again for your ongoing help!


Matir 09-11-2005 03:25 PM

I honestly do not know about the SuSE defaults. Never used it myself.

trout256 09-12-2005 09:52 PM


Well, the SUSE machine is up and running. It does not appear to have crashed.

At the office, anyone can get to the Samba share using \\IPADDRESS\XX_XX using Windows clients. However, at the satellite sites, over the MS VPN, the SUSE machine is unreachable. I tried to PING it at IPADDRESS and get nothing now.

I do not understand why a PING to the Samba server over the MS VPN worked so well before, and now has ceased to work. As far as I know, there were no changes made to the SUSE/Samba server machine.

I tried restarting the SUSE machine, but it made no difference. Now, the only way to access the Samba share is at the office. It is unreachable over the MS VPN.

Any ideas how to solve this ridiculous problem?


Matir 09-12-2005 11:51 PM

Any chance the VPN is, for some reason, blocking that particular IP?

kbrec85 10-17-2006 06:16 PM

similar problem
Hey, new to the forums and I dont like to start new threads.

Im having a similar problem with Red Hat. I set up samba server on the linux server and am able to access all the shares over the network. However, when I connect via VPN from a remote XP machine, I can not "see" the server using either the LAN IP or the computer name. I also can not connect via SSH through the VPN portal. I can connect via SSH using the WAN address and the website on that server is visible online.

Im quite new to Linux and I cant figure out why I can access windows shares via vpn, and the smaba shares via the LAN, but can access the samba shares via VPN. The only thing I could find is a few random posts on different sites about needing to set up Samba as a WINS server, but the files theyt tell me to modify outside of smb.conf dont seem to exist on this server.

Any help would be greatly aprreciated.


kbrec85 10-19-2006 05:59 PM

Here is my smb.conf file btw (created it from scratch as this is my first time working with samba or Linux for that matter)


  workgroup = WORKGROUP
  server string = Linux Server
  log file = /var/log/samba/%m.log
  hosts allow = 192.168.1. 192.168.0. 69.17.44.
  security = user
  encrypt passwords = yes
  smb passwd file = /etc/samba/smbpasswd
  socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
  wins support = yes
  name resolve order = wins lmhosts host bcast

  comment = Web Site Files
  path = /var/www
  browseable = yes
  writable = yes
  public = yes
  read only = no

  comment = Test Share
  path = /export/samba/test
  browseable = yes
  writable = yes
  public = yes
  read only = no

  comment = My Home Directory
  browseable = yes
  writable = yes
  public = yes
  read only = no

Also, the hosts allow setting was added after I got this problem as the network im connection from is 192.168.0.* and the network im connection to is 192.169.1.* I also added the Wan ip adresses of the network im connecting from, just in case, but that change has had no impact that I can see.

kbrec85 10-23-2006 07:28 PM

been banging my head against this one for about a week now, still no luck. Anyone have any suggestion on where might be a good place to start looking?

Burl 09-07-2007 10:26 AM

I had a similar problem connecting to an internal linux web server though our vpn. (two Linksys BEFVP41 gateways) I could ping windows machines though th VPN but not the linux machine. My solution was to add an ARP entry manually on the linux box for each windows machine that needed to connect to it. I put all the arp commands in script that runs at boot so I just have to keep that file updated when new machines come online. My arp entry look like:

arp -v -H ether -s 02:00:54:55:4E:01 is the remote windows machine connecting to linux box and 02:00:54:55:4E:01 is the mac address of the windows machine.

All times are GMT -5. The time now is 09:40 AM.