-   Linux - Networking (
-   -   Cannot connect to LANs - ifconfig and iwconfig show no devices (

spiderjim 11-16-2009 04:55 PM

Cannot connect to LANs - ifconfig and iwconfig show no devices

I've been using Linux for a couple of years now, but this is the first time I've ever had to do anything like deal with hardware etc.. I've also read as much online material about my problem as I can, with no success. So I'm a sort of psuedo-n00b!

I've just got a new Samsung R522 laptop. It has the following network cards:

Marvell Yukon 88E8057 PCI-E Gigabit Ethernet Controller

Realtek RTL8192E Wireless LAN 802.11n PCI-E NIC

These devices both work fine in Windows.

I've just dual-booted the machine with Scientific Linux 5.4. If you haven't heard of it before, Scientific Linux is a derivative of Enterprise Linux, which uses Fedora / Red Hat. It has the 2.6.18 kernel, with x86_64 architecture.

Unfortunately, I can't get either network card to work. This means I can't connect to a LAN, either hard-wired or wirelessly.

Here is the output of "/sbin/lspci"


00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M92 LP [Mobility Radeon HD 4300 Series]
01:00.1 Audio device: ATI Technologies Inc R700 Audio Device [Radeon HD 4000 Series]
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. Unknown device 8192 (rev 01)
06:00.0 Ethernet controller: Marvell Technology Group Ltd. Unknown device 4380 (rev 10)
Here is the output of "/sbin/ifconfig"



Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:1853 errors:0 dropped:0 overruns:0 frame:0
TX packets:1853 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2285068 (2.1 MiB) TX bytes:2285068 (2.1MiB)
And the output of "/sbin/iwconfig"


lo - no wireless extensions
sit0 - no wireless extensions
And the output of "/sbin/lsmod"


Module Size Used by
vfat 46529 1
fat 85873 1 vfat
usb_storage 118561 1
ndiswrapper 258784 0
autofs4 63049 3
hidp 83521 2
rfcomm 104681 0
l2cap 89281 10 hidp,rfcomm
bluetooth 118853 5 hidp,rfcomm,l2cap
lockd 101297 0
sunrpc 198537 2 lockd
ip_conntrack_netbios_ns 36033 0
ipt_REJECT 38977 1
xt_state 35265 2
ip_conntrack 91621 2 ip_conntrack_netbios_ns,xt_state
nfnetlink 40457 1 ip_conntrack
iptable_filter 36161 1
ip_tables 55201 1 iptable_filter
ip6t_REJECT 38849 1
xt_tcpudp 36289 10
ip6table_filter 36033 1
ip6_tables 50049 1 ip6table_filter
x_tables 50505 6 ipt_REJECT,xt_state,ip_tables,ip6t_REJECT,xt_tcpudp,ip6_tables
cpufreq_ondemand 42449 1
acpi_cpufreq 47937 1
freq_table 40889 2 cpufreq_ondemand,acpi_cpufreq
dm_multipath 56153 0
scsi_dh 41665 1 dm_multipath
video 53197 0
hwmon 36553 0
backlight 39873 1 video
sbs 49921 0
i2c_ec 38593 1 sbs
button 40545 0
battery 43849 0
asus_acpi 50917 0
acpi_memhotplug 40261 0
ac 38729 0
radeon 148193 0
drm 115561 1 radeon
ipv6 432289 19 ip6t_REJECT
xfrm_nalgo 43333 1 ipv6
crypto_api 42945 1 xfrm_nalgo
parport_pc 62313 0
lp 47121 0
parport 73165 2 parport_pc,lp
snd_hda_intel 584593 1
joydev 43969 0
snd_seq_dummy 37061 0
snd_seq_oss 65473 0
snd_seq_midi_event 41025 1 snd_seq_oss
snd_seq 87777 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 41557 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 77377 0
snd_mixer_oss 49985 1 snd_pcm_oss
snd_pcm 116681 2 snd_hda_intel,snd_pcm_oss
snd_timer 57161 2 snd_seq,snd_pcm
sr_mod 50789 0
snd_page_alloc 44113 2 snd_hda_intel,snd_pcm
snd_hwdep 43593 1 snd_hda_intel
cdrom 68713 1 sr_mod
uvcvideo 87497 0
compat_ioctl32 41793 1 uvcvideo
videodev 58689 1 uvcvideo
v4l1_compat 44613 2 uvcvideo,videodev
snd 100073 11 snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwd ep
i2c_i801 41813 0
sky2 82501 0
v4l2_common 57153 3 uvcvideo,compat_ioctl32,videodev
soundcore 41825 1 snd
shpchp 70893 0
i2c_core 56129 2 i2c_ec,i2c_i801
serio_raw 40517 0
sg 70377 0
pcspkr 36289 0
dm_raid45 99657 0
dm_message 36289 1 dm_raid45
dm_region_hash 46145 1 dm_raid45
dm_mem_cache 38977 1 dm_raid45
dm_snapshot 51977 0
dm_zero 35265 0
dm_mirror 54609 0
dm_log 44993 3 dm_raid45,dm_region_hash,dm_mirror
dm_mod 101521 11 dm_multipath,dm_raid45,dm_snapshot,dm_zero,dm_mirror,dm_log
ahci 69449 2
libata 209489 1 ahci
sd_mod 56513 5
scsi_mod 196697 6 usb_storage,scsi_dh,sr_mod,sg,libata,sd_mod
ext3 168401 2
jbd 94385 1 ext3
uhci_hcd 57433 0
ohci_hcd 55925 0
ehci_hcd 66253 0
I've attempted to install the drivers for the network devices. In the cases of the Marvell ethernet NIC, I've used the driver (sk98lin) from this website:

For the Realtek wireless device, I've tried to install a Windows driver using ndiswrapper, which was installed with the OS. Both drivers "appeared" to install correctly. Unfortunately nothing has changed.

The command "/usr/sbin/ndiswrapper -l"


net819xp : driver installed
device (10EC:8192) present
The output of "dmesg | grep ndiswrapper" is


ndiswrapper version 1.55 loaded (smp=yes, preempt=no)
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMIndicateReceiveNetBufferLists'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisAllocateNetBufferAndNetBufferList'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisAllocateMdl'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMFreeNetBufferSGList'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisFreeNetBufferList'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisFreeMdl'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMDeregisterScatterGatherDma'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMOidRequestComplete'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMSetMiniportAttributes'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisOpenConfigurationEx'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMIndicateStatusEx'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMAllocatePort'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMNetPnPEvent'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMFreePort'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMSendNetBufferListsComplete'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisAllocateIoWorkItem'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisFreeIoWorkItem'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisQueueIoWorkItem'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMSetBusData'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMRegisterMiniportDriver'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMDeregisterInterruptEx'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisAllocateMemoryWithTagPriority'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMGetBusData'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMRegisterScatterGatherDma'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMSynchronizeWithInterruptEx'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMRegisterInterruptEx'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisAllocateNetBufferListPool'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisFreeNetBufferListPool'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMDeregisterMiniportDriver'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMAllocateNetBufferSGList'
ndiswrapper (load_sys_files:206): couldn't prepare driver 'net819xp'
ndiswrapper (load_wrap_driver:108): couldn't load driver net819xp; check system log for messages from 'loadndisdriver'
usbcore: registered new driver ndiswrapper
The output of "dmesg | grep sk98lin" is


(yes, that's an empty return from that last command.)

Here's the really interesting thing! The "system-config-network" tool lists both devices, as "eth0" (the Marvell device) and "eth1" (the Realtek device), BUT, if I try to activate either device, they say the "device does not seem to be present, delaying initialization".

If anyone can offer any help, give me any ideas how I can get EITHER network device to work, and connect to my LANs, I'd be very, very grateful.

This has been driving me crackers for a couple of weeks now, and I need to get it sorted it ASAP. I've been trying to follow the user guides both here and elsewhere, but to no-avail.

Thanks for any help!

nimnull22 11-16-2009 05:08 PM

Can you do hwinfo --netcard


vishesh 11-16-2009 10:47 PM

May be wrong driver is assigned to yoor hardware. Recompiling kernel with proper driver may solve your problem.


spiderjim 11-17-2009 06:59 AM

nimnull22 and vishesh, thanks for your replies! Now I'm really going to show how little I know about all this:

vishesh, I'm not sure how to recompile my kernel, or if it's even possible in Scientific Linux (SL). I'm not even sure of the SL kernel source is available, (see here ). Could you expend a little on what you said, please?
EDIT - would it be advisable to upgrade my kernel? I've read that the latest kernel (2.6.32 I believe) might offer support for either or both of my network controllers. Do you think this is worth a try? If so, can I use any kernel, e.g. from I'm willing to try upgrading my kernel, despite my inexperience.

nimnull22, I'll paste up the results of "hwinfo --netcard" ASAP.

Thanks again for your help!

spiderjim 11-17-2009 01:34 PM

hi again, nimnull22.

I looked for the hwinfo, as you asked, except I couldn't find the command in my system - it returns


bash: hwinfo: command not found
Furthermore, I looked for any file "hwinfo" using the "locate" feature, but nothing was returned. I have several other "hw"-like commands, e.g. "/usr/bin/hwbrowser", which brings up the hardware browser which has a network devices section. This shows:


Marvell Technology Group Ltd. Unknown device 4380

Device Information
Manufactuer: Marvell Technology Group Ltd.
Driver: sky2
Device: /dev/eth0
I've tried "ifconfig" again, but it still just returns the "lo" device.

Any thoughts?


nimnull22 11-17-2009 03:16 PM

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. Unknown device 8192 (rev 01)
06:00.0 Ethernet controller: Marvell Technology Group Ltd. Unknown device 4380 (rev 10)

This not good.

Scientific Linux is a derivative of Enterprise Linux, which uses Fedora / Red Hat.
In this case check if you have "lshw" utility, but I have no idea how to use it. If you do not have it, try to find rpm with it.

If you installed sk98lin driver for ethernet, you can find out is it loaded or not by "lsmod |grep sk98".
Tell us please exact name of the ethernet driver. Also (if you have) you can use "modinfo <name_of_the_driver>" utility.
So if driver is called sk98lin, use modinfo sk98lin, from root console.

spiderjim 11-20-2009 05:02 PM

OK, after much soul searching, kernel searching, and much, much anger, I've decided upon the following workaround for my problem:

* my distro is Scientific Linux 5.4, which is based on the 2.6.18 kernel (released I believe in Feb 2007).

* the newest kernel is the 2.6.32 kernel, released in Nov 2009.

* it seems the older kernels do not support the most recent hardware. This would make sense, if not solve my problem.

* after about 5 botched attempts to upgrade my kernel in Scientific Linux, I've instead switched distro's to Fedora 12, which comes with the 2.6.31 kernel, which DOES support my Marvell Yukon ethernet card. I can now access LANs through a hard-wired connection! Although this kernel does support the RTL8192 wireless controller, it does not support the RTL8192e, which mine is. Apparently the 2.6.32 kernel does have support for this RTL8192e wireless controller.

If anyone can explain to me why the guys at Scientific Linux are using a kernel that is ostensibly 3 years out of date, I'd be interested. Also, if anyone can give me tips on

(a) getting my Fedora 12 to connect to wireless networks with me RTL8192e wireless card, or

(b) easily upgrade my kernel to 2.6.32 in Fedora 12,

I'd be very grateful!

rohitmehta 11-21-2009 04:10 AM

Linux Commands To Check Network Connection

lsof vs netstat – which of these two Linux networking commands works better, if you want to find out which Linux networking program is running on or openning a TCP/IP network port? Take a look on these commands output, you might get the answer then.

Netstat is almost a generic networking command, although its functions or features might be varied across the diverse system platforms. The Linux netstat command is used to check or print the TCP/IP network activities of both active (established) and inactive (listening) ports. You can tweak the netstat command with its supported option switches for more useful TCP/IP network statistics.

I used to run netstat -tulpan on both Redhat and Debian Linux servers for network-related support calls. These netstat command option switches will tell me what a networking program is doing – the TCP/IP protocol in used (TCP / UDP), number of bytes dropped, local network port and its connected port at remote server (established) or local listening port of the daemon (server), the name and process ID of the networking program.

Today, however, I couldn’t find an in-house developed daemon (which we call it XML-Server) with my favourite netstat -tulpan command!

As shown in the diagram, login with root user ID and executing command netstat -tulpan | grep 2020 shows that the network port 2020 is opened and listening for connection, but the XML-Server program is unknown. When grep network port number 389, I can see the Open-LDAP daemon as well as its associated process ID in the list. (So, I’ve login as root and only root user privilege can run netstat with -p option to print all networking utilities that are running on the Linux system!).

After googling, I learnt a new Linux command. Essentially, lsof is another great Linux command used to print or find out the system resources that are currently using or holding by Linux processes!

Now, executing lsof -i | grep 2020 or lsof -i | grep xmlserver is showing me the XML-Server daemon and its process ID. Then, I can issue kill -9 command to kill off XML-Server program as part of the troubleshooting process.

Of course, I can simple run ps -elf | grep xmlserver to get the process ID and kill it. But, what if you only know the network port but not the program name, or the network port and program are both being unknown?!

All times are GMT -5. The time now is 05:12 PM.