LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-08-2004, 04:10 PM   #1
gszekely
LQ Newbie
 
Registered: Jun 2004
Posts: 2

Rep: Reputation: 0
Cannot configure xircom modem on suse 9.1


Hi,

I have a Compaq Armada m700 laptop with SuSe 9.1 on it. When I installed SuSe it didn't detect my built in modem, so I plugged a Xircom LAN/Modem combo (PCMCIA) in. It installed automatically and asked for configuration. I chose all the defaults. As I try to connect to the Internet I get the following error in Kinternet:

Code:
SuSE Meta pppd (smpppd-ifcfg), Version 1.16 on linux.
Status is: disconnected
trying to connect to smpppd
connect to smpppd
Status is: disconnected
Status is: lurking
Status is: disconnected
pppd[0] died: pppd options error (exit code 2)
I run lscpi -v and I got the following about this card:

Code:
0000:02:00.0 Ethernet controller: Xircom Cardbus Ethernet 10/100 (rev 03)
        Subsystem: Xircom Cardbus Ethernet 10/100
        Flags: bus master, medium devsel, latency 64, IRQ 11
        I/O ports at 4400 [size=256M]
        Memory at 10400000 (32-bit, non-prefetchable) [size=2K]
        Memory at 10400800 (32-bit, non-prefetchable) [size=2K]
        Expansion ROM at 00004000 [disabled]
        Capabilities: [dc] Power Management version 1

0000:02:00.1 Serial controller: Xircom Cardbus Ethernet + 56k Modem (rev 03) (prog-if 02 [16550])
        Subsystem: Xircom CBEM56G-100 Ethernet + 56k Modem
        Flags: medium devsel, IRQ 11
        I/O ports at 4480 [size=256M]
        Memory at 10401000 (32-bit, non-prefetchable) [size=2K]
        Memory at 10401800 (32-bit, non-prefetchable) [size=2K]
        Expansion ROM at 00004000 [disabled]
        Capabilities: [dc] Power Management version 1
Then I checked the configuration of Kinternet and it was set to:

device: /dev/ttyLT0

listed /dev and there was no ttyLT0.

After that I found a posting on this site that offered to make

ln -s /dev/ttyLT0 /dev/modem

I ceated the dynamic link but when I try to dial I still get the same error as when I started (pppd[0] died: pppd options error (exit code 2)).

Can someone help me?

gszekely
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cant configure my conexent modem on suse 9.1 hossamsuse Linux - Hardware 1 04-04-2005 03:44 PM
How to configure cable modem under SUSE 9.2? unicon SUSE / openSUSE 2 03-10-2005 02:38 AM
Modem on a GATEWAY SOLO 5300 (Xircom MPCI Modem 56) xowl Linux - Laptop and Netbook 1 01-20-2005 10:48 AM
Xircom 56 modem ( on solo 5300 laptop ) freelinuxcpp Linux - Laptop and Netbook 2 08-23-2003 06:33 PM
How to configure Actiontech PCI modem in SuSe 7.3 Jules-1 Linux - Newbie 9 02-27-2002 06:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration