LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-25-2005, 12:55 AM   #1
soumyadas
LQ Newbie
 
Registered: Aug 2005
Posts: 2

Rep: Reputation: 0
Cannot configure ethernet adapter


Hi All,

I am new to Linux (using Suse 9). So facing a lot of problems in configuring all the things properly in my Dell laptop. I am unable to configure Broadcom 440x ethernet adapter. Yast shows it to be Dell ethernet adapter and says it to be configured as eth0. But actually it is not configured properly. I downloaded the driver for the adapter , installed it, tried to load the object module bcm4400.o with insmod bcm4400.o But it gives an error. (init_module: No such device, Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.) Didn't get anything about it. Please help.

Thanks in advance for any help.

Regards,

Soumya
 
Old 08-25-2005, 01:43 AM   #2
Pete M
Member
 
Registered: Aug 2003
Location: UK
Distribution: Redhat 9 FC 3 SUSE 9.2 SUSE 9.3 Gentoo 2005.0 Debian Sid
Posts: 657

Rep: Reputation: 32
soumyadas

You may find that Suse already has the bcm4400.o module particularly as your NIC is configured as eth0

Check on the command line with lsmod which modules are loaded, you should also find it in /usr/src/linux/drivers/net

Pete
 
Old 08-25-2005, 01:57 AM   #3
soumyadas
LQ Newbie
 
Registered: Aug 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Hi Pete

Thanks for the reply. However, I tried to load the module bcm4400.o going through manual installation after booting from the CD. But it asked for the parameters and I knew nothing about it, so it failed to load the module. If you can tell what to give as parameters.

Soumya
 
Old 08-25-2005, 02:06 AM   #4
Pete M
Member
 
Registered: Aug 2003
Location: UK
Distribution: Redhat 9 FC 3 SUSE 9.2 SUSE 9.3 Gentoo 2005.0 Debian Sid
Posts: 657

Rep: Reputation: 32
Soumya

I don't use a Dell laptop or bcm4400.o but I will do some research for you

Pete
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configure ethernet adapter rec Linux - Newbie 12 03-17-2004 12:35 AM
can't configure ethernet adapter mbsdad Linux - Networking 2 10-23-2003 10:47 AM
Ethernet adapter not listed... Stalkz Linux - Newbie 1 10-17-2003 11:47 PM
How do I configure a Cnet 200 Pro Ethernet adapter w/MDK 9.1 enigma Z Linux - Networking 0 10-01-2003 06:30 PM
Ethernet Adapter mprice74 Linux - Laptop and Netbook 2 09-09-2003 11:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration