-   Linux - Networking (
-   -   cannot conect to ftp or http on server. HELP! (

ReSync 06-27-2002 10:37 AM

cannot conect to ftp or http on server. HELP!
I'm pretty new to linux, and I have just been able to set up an server at home(using an old P200 computer). The ftp ond http works fine on the server but i can't connect to the server from an other computer in my network. Why? just ask if you need more info about my system...

Griffon26 06-27-2002 10:58 AM

If I understand correctly, you are able to connect to ftp/http from the linux box itself?

If so, read the manual for hosts.allow and edit /etc/hosts.allow and /etc/hosts.deny if necessary.

Also check if you are not running a firewall by running iptables -L (for kernels 2.4.x) or ipchains -L (for kernels 2.2.x). Post the output here if you don't know what to do with it.

Oh, and I almost forgot: what kind of message do you get when you try to connect? Simply connection refused or something else?

ReSync 06-27-2002 11:02 AM

Thanks for the reply.

Yes I'm able to connect to ftp and http from the server, but not outside.
I'l check out the config files.

Don't think I have any firewall because when I installed RH7.2 I choosed to not install a firewall....

ReSync 06-27-2002 11:36 AM

When I trie to ping the server I get no reply why? and I know my LAN cards are working....

hanzerik 06-27-2002 03:05 PM

Try to ping a computer from your server.

ReSync 06-27-2002 03:48 PM

Can't do that either hanzerik. But when I trye to ping the server from a windows machine I get this error msg:
"Destination host unreachable"

Mara 06-27-2002 04:35 PM

There can be many reasons, from hardware problems (nics, cables etc) to software ones(is your nic conifigured? use ifconfig and see if there's 'eth0', if not use ifconfig eth0 your_ip_here)

ReSync 06-29-2002 05:57 AM

Never mind the qustion. I solved it my self. I set the IP's my self and they where but then I changed them to and then it worked, Why did it work with ..1. and not ..0.?

Mara 06-29-2002 03:44 PM

Hmm, maybe there was a simple, small thing wrong and when reconfiguring you set it right?

All times are GMT -5. The time now is 02:25 AM.