-   Linux - Networking (
-   -   Cannot bring up Eth0 (

jamespetts 07-30-2004 07:48 AM

Cannot bring up Eth0
I am having some basic problems with my networking: I have just installed Mandrake 10 on a PIII-600 machine that was working fine in Win2K yesterday (including networking). I have not changed my network card, the configuration of the rest of the network, nor the NIC's PCI slot since it was working under Win2K.

However, I cannot get even basic networking (pinging other machines on my home LAN) to operate after I installed Linux. When I have installed Mandrake Linux before (on another machine), I had no problems with networking; indeed, it installed automatically, and I was able to access internet updates during the install process (via my ICS gateway).

I set up the machine to use DCHP (as is necessary when working with an ICS gateway (Win XP Pro)), but, on bootup, it either fails to start Eth0 at all (red [FAILED]), or, when I disabled network hotplugging, purported to work, but assigned an odd IP address (, incompatible with the network which requires 192.168.0.x, and then, when I try to ping, it does not even attempt to send packets, but responds "network unreachable". It will ping localhost and with no problems.

I am using a 3Com 3C905B-TX network card, which is correctly detected in the network configuration tool, and the appropriate drivers selected.

Does anybody have any idea what might be the problem? I have run the network configuration tool countless times with no success. Thank you in advance for any help :-)

Booster 07-30-2004 11:27 AM

What's the output if you type "ifconfig"? I'm guessing that it will only show "lo", not eth0, if so, try:
ifconfig eth0
(change ip to suit)

then type ifconfig again to see if it's there, if so, try pinging your gateway, if that fails, try pinging the address you assigned to eth0 and see what happens.

jamespetts 08-02-2004 01:23 PM

Thank you very much for your reply :-)

Actually, though, ifconfig returns information for eth0 as well as lo, stating that eth0 is using the illegal IP and subnet mask mentioned above. Trying to set the IP manually using ifconfig has no effect: it still reports it set at the same IP address and subnet mask. This might be because the ICS gateway (the XP machine) is setup to allocate addresses via DCHP, however; I also configured the Linux machine in question to receive its IP address via DCHP.

The trick seems to be to get it to recognise the correct subnet mask, and get a network-legal IP address allocated to it...

michaelk 08-02-2004 04:22 PM

ifconfig eth0 192.168.0.x netmask up

Change x to the desired address.

jamespetts 08-02-2004 05:32 PM

Thank you for your suggestion :-) However, I tried that, and had no success: the settings were exactly the same as before, with the bad IP addresses. I have some doubts that setting the IP address manually will work if there's a DCHP server about, anyway.

michaelk 08-02-2004 07:09 PM

I do not know the workings of XP's ICS but your correct it could be a DHCP problem if your lease time is small or an incompatablity between linux and windows. There should be a DHCP client running on MDK, probably pump or dhclient. Kill it and then try to manually configure an IP address.

To check the status when its running:
pump -i eth0 --status

j4b 08-03-2004 02:27 AM

Also on FC2
I have just built an FC2 configuration. All went well until eth0 attempted to activate. Bummer

AMD 2-500 CPU
3Com 3C900 - COMBO NIC

D-Link DI-704P router to a DSL modem
(Router also hosts this W-XP machine -- otherwise I'm completely in the dark.....)

The network configuration tool sees the 3Com NIC
It fails on activation.

During FC2 bootup there are some "FW" messages. Does FC2 default some type of firewall?

manually configure eth0
--> ifconfig eth0 netmask up
--> ping fails

activity lite on NIC and router indicates a connection.

I'm lost.

jamespetts 08-03-2004 06:42 AM

After another attempt at running the network config tool, miraculously and without explanation, it started to work. Very odd indeed.

All times are GMT -5. The time now is 10:32 PM.