-   Linux - Networking (
-   -   cannot bring up bnep interface (

avalonit 10-26-2010 04:53 AM

cannot bring up bnep interface

I'm trying to make my machine a bluetooth Internet access point (PAN profile). I'm following howto.

Everything works well except that bnep0 interface cannot be assigned an IP and brought up.

It seems that the bluetooth usb adapter I'm using is working fine because I also have a bt gps receiver and it works fine with it (rfcomm + a simple gps monitoring application). Also the nokia phone pairs with the computer and tries to acquire address. How do I know?
Well bnep0 interface gets created by the pand. I have in my dev-up script:
ifconfig bnep0 netmask
udhcpd /etc/bluetooth/pan/pan.udhcpd

The ifconfig program fails with:
SIOCSIFFLAGS: Cannot assign requested address
The udhcpd daemon actually hears the dhcp requests from the phone but cannot answer. That's real funny because bnep0 interface is not shown to be up.

I'm trying to manually issue the ifconfig command as root while the bnep0 interface is present but I am facing the same error. I tried the "ip link" command equivalent to no success :\

Any idea why the bnep0 interface cannot be brought up? It cannot be brought up even without setting IP address (ifconfig bnep0 I'm out of ideas so please help!

P.S. FYI bluetooth dongle is:
Bus 001 Device 114: ID 1131:1001 Integrated System Solution Corp. KY-BT100 Bluetooth Adapter
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 1.10
bDeviceClass 224 Wireless
bDeviceSubClass 1 Radio Frequency
bDeviceProtocol 1 Bluetooth
bMaxPacketSize0 16
idVendor 0x1131 Integrated System Solution Corp.
idProduct 0x1001 KY-BT100 Bluetooth Adapter
bcdDevice 3.73
iManufacturer 1
iProduct 2
iSerial 0
bNumConfigurations 1

All times are GMT -5. The time now is 11:24 AM.