LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-02-2006, 07:06 AM   #1
Rick809
LQ Newbie
 
Registered: Aug 2006
Posts: 7

Rep: Reputation: 0
cannot access localhost


I been trying to fix this for the last 2 days. Can someone help me?

I have read countless post regarding this issue but found nothing that helped.

What was done:

I am able to ping localhost and 127.0.0.1
I can access the default page if I type in the ip address 192.168.2.3

I think have disable the firewall and checked the httpd.conf to make sure that port 80 is listening. I have forwarded port 9999 and port 80 on the router.

What am I missing? Please help
 
Old 08-02-2006, 07:30 AM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 20,522

Rep: Reputation: 3589Reputation: 3589Reputation: 3589Reputation: 3589Reputation: 3589Reputation: 3589Reputation: 3589Reputation: 3589Reputation: 3589Reputation: 3589Reputation: 3589
Your post is missing a few details.
It appears that the webserver works from the local PC with its IP address. From the local PC you should be able to use localhost (or 127.0.0.1), its IP (192.168.2.3) or the PCs hostname as the URL (i.e. http://hostname) and see the default web page.

What do you mean by cannot access localhost? Are you trying to see the webpage from the internet or from another networked PC?

What distribution/version of linux are you running?
 
Old 08-02-2006, 07:41 AM   #3
Rick809
LQ Newbie
 
Registered: Aug 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Sorry about not giving you the full details. I am new at this.

What I am really trying to do is this, I have a public ip address that I am able to ping, but it does not allow me to access the default page on my webserver. I have forwarded ports on the router, disabled firewalls etc. to no avail. But i can access the webserver by using 192.168.2.3 from my other computer

I am running centos 4
 
Old 08-02-2006, 11:27 AM   #4
cs.cracker
LQ Newbie
 
Registered: Mar 2005
Distribution: Gentoo
Posts: 22

Rep: Reputation: 15
What type of internet service do you have? Most ISPs block port 80 for residential plans. To verify, try listening on a different port, like 81, 82, or 8080, and going to http://whatever:81 (or whatever port you chose).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Just installed webmin, can't access off localhost jon_k Linux - Software 16 01-30-2012 05:04 PM
Unable to access port 80 from anywhere but localhost hecter Linux - Security 1 10-07-2004 08:12 AM
Can not access localhost from local machine - RedHat 9 acepukas Linux - Networking 3 12-09-2003 01:17 PM
localhost access denied another_eric Linux - Networking 2 10-10-2003 08:35 PM
Not getting Localhost access for CUPS JaseP Linux - Networking 3 12-16-2002 12:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration