LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-30-2004, 07:18 AM   #1
shane42
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Rep: Reputation: 0
Can ping into box but not out of box


Red Hat Linux 9.0

I am connected to my ISP via a wireless radio. They have issued two public IP's. However, the IP address that I actually use on the two boxes I have connected to the internet are in the private range 172.16.46.XX.

The wireless modem is connected to a switch. The two boxes are connected to a switch. The gateway IP is 172.16.44.1, netmask is 255.255.252.0. The first box (NT) works fine when I use either IP address the ISP told me to use (172.16.46.19 which maps to 69.26.221.50 and 172.16.46.206 which maps to 69.26.221.51). Neither works correctly when I use it on the Linux box.

On the linux box I have verified the interrupt on the card ( = 11 when it boots). In network config it is set to 11. HOWEVER IFCONFIG SHOWS INTERRUPT AS 22. I have tried deactivating and activating eth0 but the interrupt does not change as shown in ifconfig. I cannot set the interrupt to 22 in network config. Setting it to 11 or unknown does not change the symptoms. The card is a natsemi DP3815 (Netgear). Motherboard is ABIT 1S7-G with APIC version 1.4 enabled. The PCI bus also has an Adaptec 29160 on it, nothing else. When the system boots the interrupt shown associated with network card is 11. The boot information does not show that any other device uses that interrupt.

I have disabled the firewall. iptables -L -n shows no filters.

The symptoms are as follows:
I cannot ping the gateway IP 172.16.44.1 (at least no response is received) from the linux box.

I cannot ping anything else either (other than IP of the linux box itself)

No other IP protocol works on the linux box.

I can ping and receive a response when I ping the IP 172.16.46.206 (the
linux box) from IP 172.16.46.19 (the NT box)

I can ping and receive a response when I ping the mapped IP
69.26.221.51 (= 172.16.46.206) of the linux box from the NT box.

I can even ssh into the linux box (using 172.16.46.206) from any
NT box on my lan via the NT box gateway (172.16.46.19 = 69.26.221.50)

After I ping either the NT box or the gateway IP from the linux box,
arp -a -n on the linux box shows the correct mac address associated
with those IP's even though I receive no response.

When I ping the linux box from the NT box. The NT box receives replies,
but running tcpdump on the linux box at the same time shows NO echo
packets received or replied to. The same happens when I ssh into the
linux box (works, but tcpdump logs no packets)

I am mystified.
 
Old 07-30-2004, 07:32 AM   #2
shane42
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Original Poster
Rep: Reputation: 0
changing interrupt does not work

I manually set the interrupt of the PCI slot that has the net card to 9. Changed bios APIC version from 1.4 to 1.1. Changed network config to use interrupt 9. ifconfig now shows interrupt as 9. Same symptoms as above.
 
Old 07-30-2004, 07:39 AM   #3
shane42
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Original Poster
Rep: Reputation: 0
tcpdump does show echo request / reply

After changing the interrupt to 9 one symptom changed. When I ping the ip of the linux box, tcpdump shows the echo request and reply. I still cannot ping out (destination host unreachable) when I ping the gateway.

route --inet shows

172.16.44.0 * 255.255.252.0 U 0 0 0 etho
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 172.16.44.1 0.0.0.0 UG 0 0 0 eth0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot ping XP box Dogface1SG Linux - Networking 7 02-07-2006 07:20 PM
Cannot ping linux box from XP box antare Linux - Networking 10 03-10-2005 10:48 AM
XP Box won't connect to internet thru RH9 Box (firewall/dhcpd), it can only ping fire Rhapsodic Linux - Networking 4 07-10-2004 03:02 PM
Can ping box to box thru router - good sign? toastermaker Linux - Networking 15 12-07-2003 12:00 AM
can't ping win98 box meebert Linux - Networking 10 09-15-2001 07:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration