Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 03-23-2005, 07:56 PM   #1
Registered: Jun 2003
Distribution: Slackware 12.2, CentOS
Posts: 42

Rep: Reputation: 15
Can connect to ftp, but can't display list

I know these questions have been posted, but the answers are either over my head or too convoluted, so please, bare with me.

I have slackware 10.0 running apache. I setup apache to listen for port 2800, setup a dyndns account and connecting to my local box is a cinch! So logically, my next step is to want to ftp and ssh....but one small problem: my ISP blocks all ports < 1000.

Not to worry though, I'm not a total poser, as I google like a muther trying to find a way to get this to work. I find "port forwarding". So I dump a bunch of user comments into a big bowl and start to mix.

I go into my router at work (where the local linux server is) and forward ports 2121, 2122,2123,2124,2125 to my local ip which is

Go into my proftpd.conf file, comment out inetd, uncomment standalone and change the port # to 2121.

proftpd restart and away I would go....

open up an ftp client, use my dyndns to connect using port 2121....connected successfully....WOOHOO...but there is a problem:

when I ls I get the following error:

227 Entering Passive Mode (192,168,1,130,129,139).

so I google some more....find out that I need to shut off passive mode, so I go back into my ftp configuration (on the client) and do this....try to reconnect and get the follow error:

200 Type set to A
CWD /home/websites/

250 CWD command successful.
PORT 192,168,2,101,18,231

500 Illegal PORT command
ERROR 40500 Illegal PORT command

So this is where I stand..... As I've googled, I get information like, "you need to set passive mode to this port or that port"...uhhh like WHERE! What file? <VirtualHosts>....I see this directive in httpd.conf, (*dumb ?) I wouldn't insert an ftp directive in the apache conf, would I??) I don't know, maybe one is just suppose to know these things...

At anyrate, thanks for reading my banter, hopefully, there is someone out there with the patience of a kindergarten teacher that can explain what I need to do to get my ftp working outside of my LAN at work.


Old 03-24-2005, 07:05 AM   #2
Senior Member
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
In active mode you have to assign the server an IP number and port number.

So for a regular server, those settings would be:

IP: (this is an example, use your settings)
port: 21

Look through your configuration file for the FTP server, and make teh adjustments.
Old 03-24-2005, 01:18 PM   #3
Registered: Jun 2003
Distribution: Slackware 12.2, CentOS
Posts: 42

Original Poster
Rep: Reputation: 15
This is my proftp.conf file that I assume is the config file for ftp:

# This is a basic ProFTPD
# configuration file.
# It establishes a single server and a single anonymous login.
# It assumes that you have a user/group "nobody" and "ftp"
# for normal/anonymous operation.

ServerName "ProFTPD Default Installation"
ServerType standalone
#ServerType inetd
DefaultServer on

# Port 21 is the standard FTP port.
Port 2121
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask 022

# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
# at once, simply increase this value. Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances 30

# Set the user and group that the server normally runs at.
User nobody
Group nogroup

# This next option is required for NIS or NIS+ to work properly:
#PersistentPasswd off

SystemLog /var/log/proftpd.log
TransferLog /var/log/xferlog

# Normally, we want files to be overwriteable.
<Directory /*>
AllowOverwrite on

# A basic anonymous FTP server configuration.
# To enable this, remove the user ftp from /etc/ftpusers.
<Anonymous ~ftp>
RequireValidShell off
User ftp
Group ftp
# We want clients to be able to login with "anonymous" as well as "ftp"
UserAlias anonymous ftp

# Limit the maximum number of anonymous logins
MaxClients 50

# We want 'welcome.msg' displayed at login, and '.message' displayed
# in each newly chdired directory.
DisplayLogin welcome.msg
DisplayFirstChdir .message

# Limit WRITE everywhere in the anonymous chroot
<Limit WRITE>

# An upload directory that allows storing files but not retrieving
# or creating directories.
# <Directory incoming/*>
# <Limit READ>
# DenyAll
# </Limit>
# <Limit STOR>
# AllowAll
# </Limit>
# </Directory>

Old 03-25-2005, 08:01 AM   #4
Senior Member
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Ok, you have set a log in /var/log/proftp.log.

Check it out to see what kind of error happens.

Also you have your FTP client listening on port 2121 instead of 21. Change this also.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Display CVS module list neranjana Linux - Software 1 01-14-2005 03:57 AM
Cannot list dir via FTP Ephracis Linux - Software 7 12-11-2004 06:24 PM
Display a list of files in a folder in apache Snorideguy Linux - Software 4 02-26-2004 01:05 PM
Hang on LIST or STOR in FTP Torm3nt Linux - Networking 8 01-29-2004 12:07 AM
Can OpenLdap display a mailbox list automatically??? Vince0000 Linux - Newbie 2 10-06-2003 04:02 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:16 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration