LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-15-2005, 07:26 PM   #1
Martin Strand
LQ Newbie
 
Registered: Apr 2005
Posts: 16

Rep: Reputation: 0
Can't login to ProFTPd


I set up ProFTPd and got it working fine with anonymous logins 'upload' 'download' and 'anonymous' in three different directories:
Code:
ServerName                      "ProFTPD"
ServerType                      standalone
DefaultServer                   on
Port                            21
ServerLog                       /www/ftp/log
Umask                           022

MaxInstances                    10
User                            ftp
Group                           upload

AllowOverwrite                  off

# Bar use of SITE CHMOD by default
<Limit SITE_CHMOD>
  DenyAll
</Limit>

<Anonymous ~ftp>

  UserAlias                     upload ftp
  UserAlias                     download ftp
  UserAlias                     anonymous ftp

  MaxClients                    10
  UserDirRoot                   On
  AuthAliasOnly                 on
  RequireValidShell             off

</Anonymous>
But now I can't log in for some reason:
Code:
# ftp localhost
Connected to localhost.
220 ProFTPD 1.3.0rc1 Server (ProFTPD) [127.0.0.1]
Name (localhost:root): anonymous
421 Service not available, remote server has closed connection
The log only says:
Code:
(localhost[127.0.0.1]): FTP session opened.
(localhost[127.0.0.1]): ProFTPD terminating (signal 11)
(localhost[127.0.0.1]): FTP session closed.
I've tried restarting several times with no luck. Weird thing is, everything worked fine until a few days ago. I didn't change any configuration or anything though, it just stopped working.
Help?

Last edited by Martin Strand; 06-16-2005 at 04:02 AM.
 
Old 06-15-2005, 09:54 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 257Reputation: 257Reputation: 257
Logs? Errors in logs? Have you tried restarting it? And why are you using telnet to test your proftpd connection? telnet doesn't have any idea who anonymous is just cause your using port 21.. why don't you test it by using an ftp client or using ftp from the command line..
 
Old 06-16-2005, 04:11 AM   #3
Martin Strand
LQ Newbie
 
Registered: Apr 2005
Posts: 16

Original Poster
Rep: Reputation: 0
Well, the log doesn't say anything:
Code:
(localhost[127.0.0.1]): FTP session opened.
(localhost[127.0.0.1]): ProFTPD terminating (signal 11)
(localhost[127.0.0.1]): FTP session closed.
Rather frustrating...
 
Old 06-16-2005, 10:39 AM   #4
Martin Strand
LQ Newbie
 
Registered: Apr 2005
Posts: 16

Original Poster
Rep: Reputation: 0
Ok, deleted ProFTPd and recompiled it with the same options and now it works using the exact same config.
Problem not solved but at least it's gone.
 
Old 06-16-2005, 10:46 AM   #5
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 257Reputation: 257Reputation: 257
Quote:
Originally posted by Martin Strand
Ok, deleted ProFTPd and recompiled it with the same options and now it works using the exact same config.
Problem not solved but at least it's gone.
Why are you uninstalling and reinstalling though? Did you try a simple restart first? A simple kill -HUP might have done the trick.. and I'm still baffled why your testing it using the telnet command. Why don't you actually try to use FTP instead to test a FTP server..
 
Old 06-16-2005, 10:55 AM   #6
Martin Strand
LQ Newbie
 
Registered: Apr 2005
Posts: 16

Original Poster
Rep: Reputation: 0
I did use ftp, I tried restarting several times and I also checked all logs. I just couldn't come to a solution, so I started from scratch again.
I have no idea why it works now, as far as I know I didn't change anything - the compilation options are the same, the configuration file is the same, all affected files and dirs are still owned by the same users... Aargh.

Thanks anyway.
 
Old 06-16-2005, 11:00 AM   #7
Martin Strand
LQ Newbie
 
Registered: Apr 2005
Posts: 16

Original Poster
Rep: Reputation: 0
btw, I don't see why I wouldn't be able to test with telnet, it works just fine:
Code:
# telnet localhost 21
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 ProFTPD 1.3.0rc1 Server (ProFTPD) [127.0.0.1]
USER upload
331 Anonymous login ok, send your complete email address as your password.
PASS user@domain.ext
230 Anonymous access granted, restrictions apply.
NOOP
200 NOOP command successful
QUIT
221 Goodbye.
Connection closed by foreign host.
 
Old 06-16-2005, 01:38 PM   #8
tangle
Senior Member
 
Registered: Apr 2002
Location: Arbovale, WV
Distribution: Slackware
Posts: 1,756

Rep: Reputation: 71
I found this with a Google search. I am not sure if you did not compile it with the shadow option.

"received: PASS (hidden)"
"ProFTPD terminating (signal 11)"
This usually means that shadow passwd file support is required but was not compiled in. Try starting the build over at Step 2, adding either --enable-autoshadow or --enable-shadow to the configure command line.
 
Old 07-11-2005, 10:59 PM   #9
cedarcreeksoftware
LQ Newbie
 
Registered: Jul 2005
Posts: 1

Rep: Reputation: 0
I was having the same problem - with 1.3.0rc1 . I installed it and it worked fine for a couple of days. Then it seemed to randomly give the 'Can't login' message. I tried restarting. Created a new account with a known password. Nothing worked. I installed 1.2.10 and it appears to be working again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
root login in proftpd swmok Linux - Software 2 06-24-2004 06:48 AM
can't login proftpd pipio Linux - General 0 04-19-2004 01:55 PM
Why my proftpd sometimes can't login? itebooks Linux - Software 0 03-29-2004 10:48 PM
proftpd can't login nocturnal Linux - Software 3 12-15-2003 06:33 PM
Proftpd Anonymous login badsvt351 Linux - Networking 2 02-15-2002 06:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration