LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 03-18-2007, 05:28 AM   #16
bbk
Member
 
Registered: Jan 2005
Location: Budapest/Hungary
Distribution: knoppix-hdd/debian
Posts: 56

Rep: Reputation: 15
resolution


...at me, the same problem occured in a freshly installed linux. The solution was to configure the /etc/hosts.deny because it had by default an
ALL: PARANOID
line in it which prevented me to log in from my notebook (which actually was not having a reverse lookup-enabled domain name - ip address pair).

Anyway, this was the simple problem with it.

For a workaround, when you can't get into your system from a previous DHCP enabled machine try logging onto another server having a fixed IP-DNS pair and try logging onto your server from there possible with much higher success ratio and you can fine tune your /etc/hosts.deny file from there...

BBK
 
Old 09-18-2007, 06:13 AM   #17
karunakarpn
LQ Newbie
 
Registered: Sep 2007
Posts: 2

Rep: Reputation: 0
solution for ssh_exchange_identification problem

I solved this problem. This occured because of changing permissions in /var/ folder.This may be one reseason for you.

so now change permissions to
chmod -R 755 /var/

Now i got resolved this problem.
-Thanks
 
Old 09-18-2007, 08:29 AM   #18
soroccoheaven
Member
 
Registered: Jul 2007
Distribution: mandrake Mandriva Redhat CentOS Slackware
Posts: 221

Rep: Reputation: 30
sorry wrong posting.

Last edited by soroccoheaven; 09-18-2007 at 08:30 AM.
 
Old 09-26-2007, 05:34 PM   #19
Kostanos
LQ Newbie
 
Registered: Sep 2007
Posts: 1

Rep: Reputation: 0
Wink

Be careful the /var can has /var/www or other folders that probably will have other permissions.
For get ssh working in my case I just did:
chmod 775 /var/run/sshd
chown root:root /var/run/sshd
/etc/init.d/ssh restart

In my Debian Etch.
 
Old 09-27-2007, 12:38 AM   #20
avijitp
Member
 
Registered: May 2005
Location: India
Distribution: FC11, Debian/Ubuntu, RHEL, Solaris, AIX, HP-UX
Posts: 161

Rep: Reputation: 32
ssh login takes time

Some of my RHEL servers tends to respond very slow as we connect through ssh and take longer time to give login prompt. When I get authenticated and log in, it works as usual. Is there any reason for this ?
 
Old 01-16-2008, 03:58 AM   #21
pds
LQ Newbie
 
Registered: Jan 2008
Posts: 1

Rep: Reputation: 0
Hi!

I had the same problem, then I foun that my /etc/inetd.conf had the following line:

ssh stream tcp nowait root /usr/sbin/tcpd /usr/bin/ssh

I commented the the line, restarted inetd and then it got ok.
 
Old 05-21-2008, 11:20 AM   #22
kadhiravan.r
Member
 
Registered: Nov 2004
Location: india/tamil nadu/chennai
Distribution: Linux 8.0
Posts: 37

Rep: Reputation: 15
Are you able to login to the server locally using ssh.?
 
Old 06-08-2008, 01:43 AM   #23
velocemente
LQ Newbie
 
Registered: Jun 2008
Posts: 1

Rep: Reputation: 0
ALL: PARANOID in /etc/hosts.deny

look and see if ALL: PARANOID in /etc/hosts.deny is uncommented.
 
Old 06-24-2008, 10:21 AM   #24
fraser
LQ Newbie
 
Registered: Jun 2008
Posts: 1

Rep: Reputation: 0
hosts.allow

My configuration had
ALL : PARANOID : deny
in hosts.allow . Removing this line fixed the problem
 
Old 06-25-2008, 02:46 AM   #25
nolinuxnollife
Registered User
 
Registered: Jan 2005
Location: india
Distribution: RedHat and Madrake
Posts: 55
Blog Entries: 1

Rep: Reputation: 15
1)chek the firewall on the client machine

chek this link

http://lists.debian.org/debian-user/.../msg02345.html
 
Old 11-11-2008, 11:34 AM   #26
cwilsonbell
LQ Newbie
 
Registered: Nov 2008
Posts: 1

Rep: Reputation: 0
Wink Can't SSH to remote machine...

If you can log into the server via console. Try editing the /etc/hosts.allow file and adding:

ALL: 10.

or try adding:

ALL: <your subnet>

as the last line in the file.
 
Old 07-09-2009, 04:39 AM   #27
deepumnit
Member
 
Registered: Dec 2006
Location: NOIDA, India
Distribution: Debian, SUSE, Fedora
Posts: 334
Blog Entries: 1

Rep: Reputation: 31
Cannot set up an ssh tunnel from my localhost to a remote machine.

Hi all:

I am trying to set up an ssh tunnel from my machine (in India) to a server (in US). How do I do it? The problem is: I have to first create a tunnel to Server-1 and then another from Server-1 to Server-2. The point here is: I have to establish a tunnel from my machine to Server-2. Can you please help me establish one?
 
Old 10-26-2009, 08:58 AM   #28
karsteb
LQ Newbie
 
Registered: Nov 2005
Posts: 4

Rep: Reputation: 0
Hi avijitp.

The reason it takes a long time to get the login prompt is usually that the host cannot resolve the DNS name of the client, so it waits until to reslove attempt times out and then proceeds. Solve this by making sure the client is resolvable by the DNS that the server connects to, or just manually add the client to the /etc/hosts file - it usually fixes things.

Guess the sshd tryes to resolve the name of the clients for logging purposes or something...

- Karsten
 
Old 10-26-2009, 09:01 AM   #29
avijitp
Member
 
Registered: May 2005
Location: India
Distribution: FC11, Debian/Ubuntu, RHEL, Solaris, AIX, HP-UX
Posts: 161

Rep: Reputation: 32
I too had that idea and to test that I have also added the corresponding entry in the /etc/hosts file and it did not help. I tried and verbose option and it waits unusually long at the authorization phase.
 
Old 11-02-2009, 01:35 PM   #30
ECRocker
Member
 
Registered: May 2007
Distribution: RHEL 5, Ubuntu 9.10, Fedora 12
Posts: 85

Rep: Reputation: 17
Quote:
Originally Posted by bastard23 View Post
What's in the logs on the server? It should give a reason.
Check /etc/hosts.allow and /etc/hosts.deny.
THANK YOU. Switching subnets and networks in the office and for days couldn't figure out why certain servers were pingable but just dropping ssh packets.

Code:
sshd: 10.0.1.
 
  


Reply

Tags
resolve, ssh, sshd, sshexchangeidentification


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh_exchange_identification: Connection closed by remote host piter23 Linux - Software 17 09-11-2013 09:59 AM
rndc: connection to remote host closed. james.farrow Fedora 2 06-16-2004 11:40 AM
ssh_exchange_identification: Connection closed by remote host liguorir Linux - Software 3 09-18-2003 11:42 AM
ssh_exchange_identification: Connection closed by remote host ctav01 Linux - Networking 1 08-22-2003 07:14 PM
Ftp Connection closed by remote host 360 Linux - Networking 16 05-29-2002 04:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration