LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 09-05-2003, 02:23 AM   #1
Fabian030
Member
 
Registered: Aug 2003
Location: Berlin, Germany
Distribution: SuSE 9, WinXP/2000
Posts: 35

Rep: Reputation: 15
can't reach proxy server


hi,
i've got a network of several windows 2000/XP PCs
all 192.168.2.xx
and a linux box
192.168.2.77
they all see each other

from the windows PCs i can access the internet thru a proxy
192.168.5.1
i can ping it from all windows PCs and it'll answer

but if i try to ping 192.168.5.1 with the linux box it says
"network not reachable"

the proxy is a SuSE 8.0
the linux box (192.168.2.77) is SuSE 8.0, too
 
Old 09-05-2003, 02:39 AM   #2
Fabian030
Member
 
Registered: Aug 2003
Location: Berlin, Germany
Distribution: SuSE 9, WinXP/2000
Posts: 35

Original Poster
Rep: Reputation: 15
ahhh
what do i write into the
resolv.conf
??
i coudn't find, what and HOW to write in there ...


and what the hell' wrong with "network unreachable"?!
i don't get it ...
 
Old 09-05-2003, 03:41 AM   #3
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Have you entered a gateway on the linux box as 192.168.5.1 is on a different subnet from 192.168.2.X

resolv.conf won't affect pinging (unless you're pinging by name) but anyway, put your dns servers in there

nameserver xxx.xxx.xxx.xxx
nameserver xxx.xxx.xxx.xxx

Last edited by Looking_Lost; 09-05-2003 at 03:42 AM.
 
Old 09-05-2003, 03:49 AM   #4
Fabian030
Member
 
Registered: Aug 2003
Location: Berlin, Germany
Distribution: SuSE 9, WinXP/2000
Posts: 35

Original Poster
Rep: Reputation: 15
ok
i wrote the resolv.conf

but where can i set the gateway? i've set it somewhere ... in system/configuration/LAN for the ethernet eth0 under "routing" ... but it doesn't work
 
Old 09-05-2003, 03:57 AM   #5
ugenn
Member
 
Registered: Apr 2002
Posts: 549

Rep: Reputation: 30
do you have multiple IPs assigned to you or are u sharing a single IP. u need to configure NAT/masquerade if you're sharing?
 
Old 09-05-2003, 04:02 AM   #6
Fabian030
Member
 
Registered: Aug 2003
Location: Berlin, Germany
Distribution: SuSE 9, WinXP/2000
Posts: 35

Original Poster
Rep: Reputation: 15
there is only one IP assigend to the linux box
just 192.168.2.77

if i change the IP to 192.168.5.77 (e.g.) it works
i can reach the proxy and i'm able to use the internet
but then i can't reach anything at 192.168.2.XX

:S

however, what's that NAT/masquerade? what do i do there?
 
Old 09-05-2003, 04:10 AM   #7
ugenn
Member
 
Registered: Apr 2002
Posts: 549

Rep: Reputation: 30
do you have multiple IPs assigned to you or are u sharing a single IP. u need to configure NAT/masquerade if you're sharing?
 
Old 09-05-2003, 04:16 AM   #8
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
This is the setup you have


Code:
                                    internet
                                       |
                                       eth1
                                      Suse
                                        eth0
                                       |
                          ------------------------
                         |               |              |
                      windows    windows   Suse
if so set the gateway on The Suse that can't reach to the IP address of what would be eth0 in this work of art.

I don't know the specifics of Suse so

route add default gw Ip_address_of_eth0_on_the_proxy

If it isn't your setup, you may use my wonderful diagram wherever you please as long as you display a copyright notice :


edit: Wait a minute that doesn't seem right. What's the gateway setting for the windowx boxes?

And of course as above you can use NAT instead of a proxy

Last edited by Looking_Lost; 09-05-2003 at 04:20 AM.
 
Old 09-05-2003, 04:33 AM   #9
Fabian030
Member
 
Registered: Aug 2003
Location: Berlin, Germany
Distribution: SuSE 9, WinXP/2000
Posts: 35

Original Poster
Rep: Reputation: 15
it's somehow like this

internet
| |-192.168.3.xx
proxy (192.168.5.1 - SuSE 8) ----------------|-192.168.4.xx
|
-----------------------------------------------
| | |
192.168.2.XX suse (192.168.2.77) other .2.XX
(windows) (windows)

gateway for windows: 192.168.5.1 (they can reach the proxy)

it's a companies network. i can't replace the proxy or configure it. i just can manage my linux box and the windows pcs ... in 2.XX

what ever NAT is ... the Help-file isn't very helpful
 
Old 09-05-2003, 04:34 AM   #10
Fabian030
Member
 
Registered: Aug 2003
Location: Berlin, Germany
Distribution: SuSE 9, WinXP/2000
Posts: 35

Original Poster
Rep: Reputation: 15
fuck
how do u keep the format?
:$
 
Old 09-05-2003, 04:39 AM   #11
ugenn
Member
 
Registered: Apr 2002
Posts: 549

Rep: Reputation: 30
did you register multiple IPs with your ISP or just 1? if it is just 1, you need to use NAT (Network Address Translation, a way of sharing a single IP among multiple machines).

But it appears your immediate problem is (as an earlier poster mentioned) with the router/gateway config. You mentioned that you accessed the net thru a proxy (192.168.5.1). Since your net conenction is ok on your win boxes, run ipconfig on either one of them and note the gateway IP. And set this on your linux box using the route command or thru the GUI menu if you're using KDE/Gnome.
 
Old 09-05-2003, 04:47 AM   #12
Fabian030
Member
 
Registered: Aug 2003
Location: Berlin, Germany
Distribution: SuSE 9, WinXP/2000
Posts: 35

Original Poster
Rep: Reputation: 15
the gateway IP is the proxy
192.168.5.1
it's already set on the linux box ...
it's KDE here

there sould be only on IP we get from our ISP ... since they all get out with the one the proxy has as the outgoing IP
don't ask me, it's a dynamic IP we get from our ISP
 
Old 09-05-2003, 04:55 AM   #13
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
This is going to sound a real pain but the simplest solution would be just to change the IP's to the range of 192.168.5.X on all the machines that connect to 192.168.5.1 It's more consistent too, that is unless you have too many computers to make it practical. I remember reading briefly somewhere that it sometimes isn't always necessary to set a gateway as a form of route discovery can be done by the client pc's. Perhaps the windows one's are implementing this automatically, I hate being so vague so I'll have to look it up again myself.

That would be the easisest solution and solve your problem, as you say you have control over the windows and suse, and you probably won't have to reboot windows if they're 2000 or XP
 
Old 09-05-2003, 05:02 AM   #14
Fabian030
Member
 
Registered: Aug 2003
Location: Berlin, Germany
Distribution: SuSE 9, WinXP/2000
Posts: 35

Original Poster
Rep: Reputation: 15
certainly
that would be a great way
but the admin of the company wants my PCs in 2.XX ... company-structure
don't ask me. i would prefer this way, too ...
but there are 1.XX, 2.XX, 3.XX and 4.XX ... even sometimes somewhere 5.XX PCs ... don't ask me, why. they are not online right now, seems to be a sub-net for notebooks or something.
ahh, well, there are about 100 PCs in 2.XX
 
Old 09-05-2003, 05:03 AM   #15
ugenn
Member
 
Registered: Apr 2002
Posts: 549

Rep: Reputation: 30
what class is your network in? can u show us the netmask set on both the linux and win boxes? the gw needs to be on the same subnet as the other machines. i'm just taking a guess, but ur win boxes are probably configured to use a larger netmask hence they can see the gw.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
workstation cannot reach server rosey_krh Linux - Networking 5 04-21-2005 04:46 PM
Can not reach server from LAN after adding router Jedyte Linux - Networking 8 09-01-2004 10:48 AM
dns config server could be reach butchick Linux - Newbie 4 04-16-2004 11:50 PM
can't reach new server wedgeworth Linux - Software 2 03-18-2004 02:39 PM
Reach web page from Apache Red Hat Server zeljka Red Hat 1 01-06-2004 12:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration