LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-05-2003, 03:30 AM   #1
GaijinPunch
Member
 
Registered: Aug 2003
Location: Tokyo, Japan
Distribution: Gentoo
Posts: 130

Rep: Reputation: 22
can't mount SMB at boot (no route to host)


As the title says. I've got two machines. One will mount a samba share from the samba server at boot, the other won't. Both have the proper syntax in /etc/fstab to mount the drive.

Both are done made w/ the same build (Redhat 8). The only difference is hardware.

The only descrepency I found was a soft link:
/etc/rc2.d/K35smb -> /etc/init.d/smb
That was on the working machine, but not the other.

I copied the file to the non-working machine, and linked it. Still no dice.

Any ideas?
 
Old 08-05-2003, 04:05 AM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 47
on your server, as root

# chkconfig --level 2345 smb on

This will make samba start at runlevels 2 through 5

You can also start samba from your bash prompt

# service smb start
 
Old 08-05-2003, 06:08 PM   #3
GaijinPunch
Member
 
Registered: Aug 2003
Location: Tokyo, Japan
Distribution: Gentoo
Posts: 130

Original Poster
Rep: Reputation: 22
Thanks -- I've run chkconfig, but can't be rebooting machines at the moment. I know how to mount stuff from the terminal, but really need it to happen at boot.

THanks for the input!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
smb mount folders disappear on mount & konqueror smb fails: network unreachable tisource Linux - Networking 1 10-17-2007 12:30 AM
no route to host vito_huang Linux - Newbie 6 06-14-2005 09:10 AM
mount smb shares at boot gvaught Debian 12 06-13-2005 11:34 AM
route smb protocol? hotrodowner Linux - Networking 3 01-14-2003 08:57 PM
No Route To Host Que Linux - General 10 08-19-2002 08:22 AM


All times are GMT -5. The time now is 05:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration