LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-20-2004, 04:28 PM   #1
Stevetgn
Member
 
Registered: Jun 2003
Distribution: SuSE10, Mepis,
Posts: 230

Rep: Reputation: 30
Can't log on to samba server from winXP


I can't log on to the samba server I've just created from within WinXP. The Linux shared home directories are showing in XP's "My Network Places", I click on them and a "logon" box appears so I type in my Linux user name (steve) and type in my password but it won't log me in.

Total newbie guys, can anyone help?

Thanks in advance

Steve
 
Old 05-20-2004, 04:41 PM   #2
muah
Member
 
Registered: Aug 2003
Location: Europe
Distribution: Slackware (current)
Posts: 228

Rep: Reputation: 33
Do you have user steve added to smbpasswd (smbpasswd -a steve)?
 
Old 05-20-2004, 05:02 PM   #3
Stevetgn
Member
 
Registered: Jun 2003
Distribution: SuSE10, Mepis,
Posts: 230

Original Poster
Rep: Reputation: 30
No how do I set that up with SuSE 9.1?
 
Old 05-20-2004, 05:03 PM   #4
Stevetgn
Member
 
Registered: Jun 2003
Distribution: SuSE10, Mepis,
Posts: 230

Original Poster
Rep: Reputation: 30
I though you just used your normal linux logon user and password
 
Old 05-20-2004, 06:08 PM   #5
sitmex
Member
 
Registered: Mar 2004
Location: Guadalajara, Mexico
Distribution: Fedora Core 3
Posts: 30

Rep: Reputation: 15
Got the same problem, but I already add the user in the samba user...
Any hints?
 
Old 05-20-2004, 06:39 PM   #6
Exio
Member
 
Registered: Dec 2003
Location: Heath and reach
Distribution: Slackware
Posts: 54

Rep: Reputation: 15
i had this problem and many many other with samba, try this.

as root
#smbpasswd -a <ur xp login name>

when it prompts u for pw, wnter ur xp login password, this should alow u access to them without having a login box appear every time u reboot.
 
Old 05-20-2004, 06:42 PM   #7
Exio
Member
 
Registered: Dec 2003
Location: Heath and reach
Distribution: Slackware
Posts: 54

Rep: Reputation: 15
sorry lads, in ur smb.conf, the line

security =

put ur log in name here eg.

security = exio


remember to reboot ur system once u have made these changes, or reboot samba.
 
Old 05-21-2004, 04:21 AM   #8
muah
Member
 
Registered: Aug 2003
Location: Europe
Distribution: Slackware (current)
Posts: 228

Rep: Reputation: 33
Quote:
Originally posted by Exio
sorry lads, in ur smb.conf, the line

security =

put ur log in name here eg.

security = exio
This is completely wrong. Set security to 'user' (then it will ask u for username/pw) or 'share' (it will let u to join server without need to enter any username/password but u will have to set 'guest account' as well)


Quote:
Originally posted by Stevetgn
No how do I set that up with SuSE 9.1?
As i mentioned before use command 'smbpasswd -a steve'. Plz note that 'steve' needs to has a linux account before u can add him to smbpasswd. When u execute this command it will ask u for new password for steve (u will use this password later when connecting from windows to samba)
 
Old 05-21-2004, 04:12 PM   #9
Exio
Member
 
Registered: Dec 2003
Location: Heath and reach
Distribution: Slackware
Posts: 54

Rep: Reputation: 15
Yup SORRY, i was geeting confised......
 
Old 05-22-2004, 03:02 PM   #10
Stevetgn
Member
 
Registered: Jun 2003
Distribution: SuSE10, Mepis,
Posts: 230

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by Exio
Yup SORRY, i was geeting confised......
I still am confused.

Newbie english please
 
Old 06-21-2004, 06:37 PM   #11
aussie_steve
LQ Newbie
 
Registered: Jun 2004
Posts: 1

Rep: Reputation: 0
I don't think the problem is with the samba server but rather with XP. By default XP will not connect to smb shares because of a local policy. Through Local Policy management look for a policy in networking that says something like "connect to smb shares using unencrypted passwords" or something like that. I had the same problem and this resolved the issue. I'll try and find the article that describes the fix.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba printing issues with Minolta PagePro 1250W on Mandrake 9.2 with WinXP server bhtooefr Linux - Networking 3 08-04-2004 12:51 PM
Samba 3 Printer Server w/ WinXP jqcaducifer Linux - Networking 4 04-19-2004 01:32 PM
Problems connecting winxp to RH9 samba server NRHBasher Linux - Newbie 2 03-12-2004 08:11 PM
trying to log into samba file server adamantium Linux - Networking 2 11-26-2003 11:58 AM
Win 95: Can't log on to Samba server. DiBosco Linux - Networking 4 12-14-2001 03:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration