LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-02-2004, 12:25 PM   #1
dummoi
Member
 
Registered: Mar 2004
Location: Belgium
Distribution: Redhat9
Posts: 31

Rep: Reputation: 15
can't go on internet since kernel 2.6


OK this is the problem
I needed kernel2.6 for some driver. I updated to it. and I can't go on the internet anymore. I found out I needed ne2k_pci module and I installed it. But it still won't work.

When I do "modprobe ne2k_pci" I get the following:
WARNING: Error inserting 8390
(/lib/modules/2.6.7/kernel/drivers/net/8390.ko): Invalid module format
FATAL: Error inserting ne2k_pci (/lib/modules/2.6.7/kernel/drivers/net/ne2k-pci.ko): Invalid module format

actually I don't know if I can do modprobe :-s.
What could be the problem?

Thanx
 
Old 08-02-2004, 01:20 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 67
What version of modutils are you running?
/sbin/modprobe -V

Perhaps you only have a version compatible with 2.4 kernels. Newer versions are backwards compatible.
 
Old 08-02-2004, 02:31 PM   #3
dummoi
Member
 
Registered: Mar 2004
Location: Belgium
Distribution: Redhat9
Posts: 31

Original Poster
Rep: Reputation: 15
I updated modprobe from version 0.9.14 to 3.0 but it still doesn't work
 
Old 08-03-2004, 03:17 PM   #4
r0b0
Member
 
Registered: Aug 2004
Location: Europe
Posts: 608

Rep: Reputation: 50
I think the module itself might be wrong. Where did you get it from?
 
Old 08-04-2004, 12:36 AM   #5
dummoi
Member
 
Registered: Mar 2004
Location: Belgium
Distribution: Redhat9
Posts: 31

Original Poster
Rep: Reputation: 15
I downloaded the kernel sources from www.kernel.org. And installed them. I thought the module was included.
 
Old 08-04-2004, 01:19 PM   #6
dummoi
Member
 
Registered: Mar 2004
Location: Belgium
Distribution: Redhat9
Posts: 31

Original Poster
Rep: Reputation: 15
OK, I found it.
When I was configuring the kernel I (stupid as I was) selected for processor family 368 in stead of 468.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiled 2.6.9 Kernel now have no internet .. Need Help cereal83 Slackware 11 10-27-2004 09:27 PM
New kernel = no internet ??? captain_bogus Linux - Networking 3 06-10-2004 10:48 AM
internet problem and kernel help A5thZeke Linux - General 3 05-14-2004 09:13 AM
no internet after compiling 2.6 kernel pele_smk Slackware 3 01-05-2004 11:37 AM
new kernel and internet tsitras Debian 9 11-14-2003 06:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration