Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 01-29-2004, 11:06 AM   #1
Registered: Sep 2003
Posts: 71

Rep: Reputation: 15
Question Can't get two Linux machines to communicate

Hi everyone-

I have two computers each running RedHat 9.0. I'm trying to
set up a 100 BaseT ethernet network between the two.

I am able to ping between the two hosts just fine. But, when
I try to telnet from one to the other, I get "connection refused"

Permit me to supply some status information:

Here's my ifconfig dump (since the machines are so similar,
the two machines dump almost identical stuff. The exception is
that one machine has a modem, which I'm using right now, and
the other doesn't):

eth0 Link encap:Ethernet HWaddr 00:02:E3:05:B5:8B
inet addr: Bcast: Mask:
RX packets:26 errors:0 dropped:0 overruns:0 frame:0
TX packets:34 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:2098 (2.0 Kb) TX bytes:2208 (2.1 Kb)
Interrupt:5 Base address:0x2000

lo Link encap:Local Loopback
inet addr: Mask:
RX packets:72 errors:0 dropped:0 overruns:0 frame:0
TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5000 (4.8 Kb) TX bytes:5000 (4.8 Kb)

ppp0 Link encap:Point-to-Point Protocol
inet addr: P-t-P: Mask:
RX packets:768 errors:0 dropped:0 overruns:0 frame:0
TX packets:899 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:342001 (333.9 Kb) TX bytes:119999 (117.1 Kb)

The other machine has an IP address of (

The /sbin/route dump looks like this:

[pjz@jupiter network-scripts]$ /sbin/route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface * UH 0 0 0 ppp0 * U 0 0 0 eth0 * U 0 0 0 eth0 * U 0 0 0 lo
default UG 0 0 0 ppp0

when I type netstat, I get no active Internet connections

I've gone into the various files of /etc/xinet.d/ and changed "DISABLED = yes"
to "DISABLED = no"

In addition, I've popped open the Service Configuration tool under
System Settings/Server Settings/Services in the main pop-up menu
and activated all the services I want, for example telnet and finger.

After I made all the changes, I rebooted my machine. I tried restarting
the various services and restarting the network from the command line,
too, using "network restart" and "xinetd restart". Lots of stuff seems to
be the way it's supposed to be, and I've done everything the book
says, but I still get this "connection refused" message when I try
to go from one machine to the other.

I've only been a real Linux user for about six months. I'm sure this
is something really simple that I'm just not doing right, and I'm hoping
that someone out there has an answer that begins with, "it's pretty
simple, but not really obvious ...."

I'm happy to provide whatever additional info from my system that
anyone would find helpful.

Thanks, everybody
Old 01-29-2004, 12:32 PM   #2
LQ Newbie
Registered: Jan 2004
Location: Rio de Janeiro - Brasil
Distribution: debian/rh
Posts: 18

Rep: Reputation: 0
do you have any firewall set up? it looks like the port 23 (telnet) is blocked. Use iptables or ipchains command to open it if it's blocked.
Old 01-29-2004, 03:41 PM   #3
Registered: Sep 2003
Posts: 71

Original Poster
Rep: Reputation: 15

Thanks so much. I enabled the services through the firewall
utility under the security level menu item in System Settings.

Everything works great! I have NFS set up too. It all totally works!

Old 01-29-2004, 03:47 PM   #4
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
I would stronly reccomend uninstalling telnet and using ssh instead, it is much more secure:
Old 01-29-2004, 04:35 PM   #5
Registered: Sep 2003
Posts: 71

Original Poster
Rep: Reputation: 15

I will go into the security submenu and deactivate telnet now.
I understand that it sends unencrypted passwords over the net.
That's not a problem right now, since this is only my home network.
However, I may at some point in the future connect to the broader
network, and may not then remember to turn off telnet.

Thanks for the reminder


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Libraries on 'Other' Linux Machines moetman Linux - Software 1 09-14-2005 12:19 AM
Windows iPAQ communicate with Linux PC hk_michael Programming 0 02-03-2005 12:01 AM
How many Linux machines do you have? Crashed_Again General 57 02-28-2004 10:49 AM
Manage multiple linux-machines through one linux-machine howto ? Satriani Linux - Networking 18 06-10-2003 10:54 AM
linux on old machines UseWhatEver Linux - Distributions 7 04-16-2003 02:27 AM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:34 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration