LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-04-2003, 03:46 AM   #1
dfuse
Member
 
Registered: May 2003
Location: Leuven, Belgium
Distribution: Gentoo Linux
Posts: 42

Rep: Reputation: 15
Can't get phpmyadmin to work, php works


If I make a info.php file with <?php phpinfo()?> in it, and put it in /var/www/localhost/cgi-bin, that works, I get alot of information about php and apache. I emerged phpmyadmin and when I try http://localhost/cgi-bin/phpmyadmin/index.php I first got a permission denied error in the error.log from apache. I then changed all permissions of the phpmyadmin dir so everybody can executes it (don't know if that was a correct solution, it was a desperate one), and now I get the following error:
Code:

[Wed Dec 3 22:55:21 2003] [error] (8)Exec format error: exec of /var/www/localhost/cgi-bin/phpmyadmin/index.php failed
[Wed Dec 3 22:55:21 2003] [error] [client 192.168.0.105] Premature end of script headers: /var/www/localhost/cgi-bin/phpmyadmin/index.php


I searched the net and forums, read apache manual but couldn't find a clear explanation for an apache newbie like me.
I found something about adding a directory for the phpmyadmin in the apache.conf file, but that doesn't seem to work, and there's nowhere an example. I'm guessing apache doesn't know that he has to execute the files as php but I really wouldn't know how to configure that (especially since my info.php did work)

Can somebody please help me?
 
Old 12-04-2003, 02:12 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
php scripts shouldn't need to be in a cgi-bin. Try moving the phpMyAdmin folder to your document root directory.
 
Old 12-05-2003, 03:22 AM   #3
dfuse
Member
 
Registered: May 2003
Location: Leuven, Belgium
Distribution: Gentoo Linux
Posts: 42

Original Poster
Rep: Reputation: 15
thanks, somebody else suggested the same too me. I already thought it weird that phpmyadmin was in cgi-bin, but since I use gentoo the emerge of phpmyadmin put it there and I thought it was meant to be there.
Btw, it works now
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Konqueror and phpMyAdmin--opens in Kwrite, won't display PHP hindenbergbaby Linux - Software 20 06-28-2006 12:27 AM
Good PHP tools like phpmyadmin... wwnexc Linux - Software 4 10-09-2005 02:56 PM
mysql/php/phpmyadmin/utf8 kenji1903 Linux - Software 6 09-03-2005 07:36 AM
How do I know that apache, MySql, PHP, phpMyAdmin is Installed AskMe Linux - Newbie 7 02-04-2004 06:27 PM
PHPMyAdmin reports wrong PHP version. Pcghost Programming 2 10-24-2003 03:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration