LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 09-04-2016, 12:17 PM   #1
Marco2G
LQ Newbie
 
Registered: Aug 2016
Posts: 16

Rep: Reputation: Disabled
Can't get LACP to work


Hello

As the title says, I can't get this to work... I have link but cat /proc/net/bonding/bond0 says it's set to round robin... Not LACP...

OS is Ubuntu Server 16.04

Here's my /etc/network/interfaces:

Quote:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

## Host interface internes Netzwerk
auto enp6s0f1
iface enp6s0f1 inet static
address 192.168.2.100
gateway 192.168.2.1
netmask 255.255.255.0
network 192.168.2.0
broadcast 192.168.2.255
dns-nameservers 8.8.8.8 8.8.4.4

auto enp6s0f0
iface enp6s0f0 inet manual

auto enp11s0f0
iface enp11s0f0 inet manual
bond-master bond0

auto enp11s0f1
iface enp11s0f1 inet manual
bond-master bond0

auto enp12s0f0
iface enp12s0f0 inet manual
bond-master bond0

auto enp12s0f1
iface enp12s0f1 inet manual
bond-master bond0

auto bond0
iface bond0 inet static
bond-miimon 100
bond-downdelay 200
bond-updelay 200
bond-mode 4
bond-slaves none
bond-lacp-rate 4
address 192.168.2.101
netmask 255.255.255.0
I also tried setting bond-mode to 802.3ad instead of four. I then did sudo service network-manager restart but no cigar.

Here's my ifconfig output:

Quote:
bond0 Link encap:Ethernet HWaddr 52:8c:0c:f1:53:58
inet addr:192.168.2.101 Bcast:192.168.2.255 Mask:255.255.255.0
UP BROADCAST MASTER MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

enp13s0 Link encap:Ethernet HWaddr 00:1b:21:21:cc:35
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:16 Memory:dc920000-dc940000

enp6s0f0 Link encap:Ethernet HWaddr 00:30:48:d1:ca:52
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9206 errors:0 dropped:141 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:603950 (603.9 KB) TX bytes:0 (0.0 B)
Interrupt:18 Memory:dc420000-dc440000

enp6s0f1 Link encap:Ethernet HWaddr 00:30:48:d1:ca:53
inet addr:192.168.2.100 Bcast:192.168.2.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:12493 errors:0 dropped:141 overruns:0 frame:0
TX packets:2805 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:942717 (942.7 KB) TX bytes:475892 (475.8 KB)
Interrupt:19 Memory:dc460000-dc480000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:632 (632.0 B) TX bytes:632 (632.0 B)

macvtap0 Link encap:Ethernet HWaddr 52:54:00:aa:13:6d
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:500
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Now the funny thing is ifup and ifdown don't work. But when I do ifconfig bond0 down, bond0 will disappear from ifconfig output, yet the IP remains pingable.

Here's the cat /proc/net/bonding/bond0

Quote:
Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)

Bonding Mode: load balancing (round-robin)
MII Status: down
MII Polling Interval (ms): 0
Up Delay (ms): 0
Down Delay (ms): 0

For completion's sake here the sh run of the switch:

Quote:
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname MainSwitch
!
boot-start-marker
boot-end-marker
!

!
!
no aaa new-model
system mtu routing 1500
vtp mode transparent
authentication mac-move permit
ip subnet-zero
!
!
!
!

!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2
name DMZ
!
vlan 3
name Intern
!
!
!
interface Port-channel1
switchport access vlan 2
switchport mode access
!

interface FastEthernet0/13
switchport access vlan 2
switchport mode access
channel-protocol lacp
channel-group 1 mode active
!
interface FastEthernet0/14
switchport access vlan 2
switchport mode access
channel-protocol lacp
channel-group 1 mode active
!
interface FastEthernet0/15
switchport access vlan 2
switchport mode access
channel-protocol lacp
channel-group 1 mode active
!
interface FastEthernet0/16
switchport access vlan 2
switchport mode access
channel-protocol lacp
channel-group 1 mode active
!

interface Vlan1
no ip address
no ip route-cache
!
interface Vlan2
ip address 192.168.2.200 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.2.1
ip http server
ip http secure-server
ip sla enable reaction-alerts
!

end
And:

Quote:
MainSwitch#sh etherchannel 1 summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port


Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SD) LACP Fa0/13(D) Fa0/14(D) Fa0/15(D)
Fa0/16(D)
I have tried cutting sensitive and unimportant info. Hope I went neither short of the goal nor too far .
As you can see, the switch expects the port channel but all corresponding ports are down (from an LACP pov). Perhaps I should note that I haveconnected only two of the four ports at this point but hey, when one goes down in a HA scenario, this is supposed to continue working too, right?

Any help would be greatly appreciated. I'm planning on adding VLAN trunk and corresponding devices on ubuntu for VMs but before I take that next step of complication, I'd like to get the basics licked.

Last edited by Marco2G; 09-04-2016 at 12:18 PM.
 
Old 09-04-2016, 12:48 PM   #2
Marco2G
LQ Newbie
 
Registered: Aug 2016
Posts: 16

Original Poster
Rep: Reputation: Disabled
Okay, now it gets freaky... all four interfaces of the bond have no link (Ubuntu and the switch agree on this) and the IP still pings...
 
Old 09-04-2016, 02:16 PM   #3
Marco2G
LQ Newbie
 
Registered: Aug 2016
Posts: 16

Original Poster
Rep: Reputation: Disabled
Okay, this is getting ridiculous... I noticed that a modprobe config file for bonding I had made previously according to one howto was actually not working. I deleted it and commented out the individual interface configs in /etc/network/interfaces. Now the LACP suddenly came up but with interfaces on stand-alone. So I added the individual configs back in and the cisco switch is now happily seeing aggregated devices...

Only problem? Yeah, don't try to communicate with that IP... it just doesn't work anymore while it has been working in the stand-alone version.

This is getting tiresome...
 
Old 09-04-2016, 02:18 PM   #4
Marco2G
LQ Newbie
 
Registered: Aug 2016
Posts: 16

Original Poster
Rep: Reputation: Disabled
And yet another update:
Restarted networking yet again and now the LACP link is up and pinging.

Jeez, what a torture... I just hope it will be easier to get VLAN working on that bond...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Open vSwitch bonding with LACP and VLAN yenn Linux - Networking 2 03-31-2014 10:00 AM
lacp problem dellpe Linux - Networking 1 03-21-2014 02:30 PM
[SOLVED] LACP on machines and switches required? GreggT Linux - Networking 2 02-26-2012 02:23 PM
Need advice about redundant switches / LACP, stacking or ... pingu Linux - Networking 8 01-15-2012 03:20 PM
lacp timeout, modem hangup mseq1 Linux - Newbie 1 08-06-2004 07:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration