LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-15-2006, 12:18 AM   #1
gaaslight
LQ Newbie
 
Registered: Jun 2006
Location: columbia river gorge
Distribution: Slackware
Posts: 13

Rep: Reputation: Disabled
can't find my network from openSUSE 10.1 or winnt4.0


# Samba config file created using SWAT
# from 127.0.0.1 (127.0.0.1)
# Date: 2006/08/13 08:46:41

[global]
workgroup = TUX-NET
map to guest = Bad User
printcap name = cups
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
logon path = \\%L\profiles\.msprofile
logon drive = P:
logon home = \\%L\%U\.9xprofile
os level = 2
preferred master = No
local master = No
domain master = No
winbind uid = 10000-20000
winbind gid = 10000-20000
hosts allow = 192.168.0.0/255.255.255.0
cups options = raw
include = /etc/samba/dhcp.conf

[homes]
comment = Home Directories
valid users = %S, %D%w%S
read only = No
inherit acls = Yes
browseable = No

[profiles]
comment = Network Profiles Service
path = /home/Music
create mask = 0600
directory mask = 0700
guest ok = yes
case sensitive = no
msdfs proxy = no

[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/

[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes

[printers]
comment = All Printers
path = /var/tmp
create mask = 0600
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin, root
force group = ntadmin
create mask = 0664
directory mask = 0775

TUXBOX:~ # ifconfig
eth0 Link encap:Ethernet HWaddr 00:16:76:06:95:17
inet addr:192.168.2.2 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::216:76ff:fe06:9517/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:11739 errors:0 dropped:0 overruns:0 frame:0
TX packets:9562 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:14846906 (14.1 Mb) TX bytes:958516 (936.0 Kb)
Interrupt:209 Base address:0xc000

eth1 Link encap:Ethernet HWaddr 00:40:05:81:CD:5D
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::240:5ff:fe81:cd5d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:12 dropped:0 overruns:0 frame:0
TX packets:187 errors:14 dropped:0 overruns:0 carrier:42
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:22505 (21.9 Kb)
Interrupt:217 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1245 errors:0 dropped:0 overruns:0 frame:0
TX packets:1245 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:141314 (138.0 Kb) TX bytes:141314 (138.0 Kb)
 
Old 08-15-2006, 02:05 AM   #2
w3bd3vil
Senior Member
 
Registered: Jun 2006
Location: Hyderabad, India
Distribution: Fedora
Posts: 1,191

Rep: Reputation: 49
could you tell us the problem a bit more, I dont seem to understand the exact problem. You have shown the config files, but not the exact problem.
 
Old 08-15-2006, 02:18 AM   #3
gaaslight
LQ Newbie
 
Registered: Jun 2006
Location: columbia river gorge
Distribution: Slackware
Posts: 13

Original Poster
Rep: Reputation: Disabled
I can't see my daughter's winnt computer in my OpenSUSE local network, nor can she see my linux computer in her Network Neighborhood. I was wondering if there was something not set up right in smb.conf.
 
Old 08-24-2006, 12:59 PM   #4
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
I suggest that you check that both machines are set to TUX-NET, and that the windows machine is set up to share at least one drive / folder /directory (the $C or C$ administrative share does not cut it!!!),

then I suggest that (in your [global] settings you add: security = user

then change the os level = 2 to os level = 65 (this is because winXP insists on being the master with an unadjustable setting of 60, and thus you want your samba server to be the boss!!!)

change: preferred master = from No to Yes

change: local master = No to Yes

change: domain master = No to Yes

then you might try # commenting out the winbind uid and gid lines as I don't know what they do!

Let me know how you progress. If necessary I will copy my smb.conf over to you as I have a similar set-up see my sig.

NB: I have to disable my SuseFirewall to be able to grab files from my windows PC's and they are all FAT32 (rather than NTFS) because that way I can write to them.

Hope that this helps
Cheers
Richard
 
Old 08-26-2006, 02:09 PM   #5
gaaslight
LQ Newbie
 
Registered: Jun 2006
Location: columbia river gorge
Distribution: Slackware
Posts: 13

Original Poster
Rep: Reputation: Disabled
I have shared the "C" drive as my daughter's username chiara. I also changed her OS to Windows 98 so she can have USB support. I made the changes to samba that you suggested, although I couldn't chage the winbind uid and gid lines with SWAT. I was wondering how do I create a samba mount point .

Last edited by gaaslight; 08-26-2006 at 02:13 PM.
 
Old 08-26-2006, 02:09 PM   #6
gaaslight
LQ Newbie
 
Registered: Jun 2006
Location: columbia river gorge
Distribution: Slackware
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by minrich
I suggest that you check that both machines are set to TUX-NET, and that the windows machine is set up to share at least one drive / folder /directory (the $C or C$ administrative share does not cut it!!!),

then I suggest that (in your [global] settings you add: security = user

then change the os level = 2 to os level = 65 (this is because winXP insists on being the master with an unadjustable setting of 60, and thus you want your samba server to be the boss!!!)

change: preferred master = from No to Yes

change: local master = No to Yes

change: domain master = No to Yes

then you might try # commenting out the winbind uid and gid lines as I don't know what they do!

Let me know how you progress. If necessary I will copy my smb.conf over to you as I have a similar set-up see my sig.

NB: I have to disable my SuseFirewall to be able to grab files from my windows PC's and they are all FAT32 (rather than NTFS) because that way I can write to them.

Hope that this helps
Cheers
Richard
chris@TUXBOX:/etc/samba> testparm smb.conf
Load smb config files from smb.conf
Processing section "[homes]"
Processing section "[profiles]"
Processing section "[users]"
Processing section "[groups]"
Processing section "[printers]"
Processing section "[print$]"
Processing section "[netlogon]"
Loaded services file OK.
WARNING: passdb expand explicit = yes is deprecated
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
workgroup = MSHOME
map to guest = Bad User
printcap name = cups
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
logon path = \\%L\profiles\.msprofile
logon drive = P:
logon home = \\%L\%U\.9xprofile
os level = 65
preferred master = Yes
domain master = Yes
ldap ssl = no
usershare max shares = 100
idmap uid = 10000-20000
idmap gid = 10000-20000
valid users = chiara, chris, sean, tammy
admin users = chiara
hosts allow = WIN98, TUXBOX
cups options = raw
include = /etc/samba/dhcp.conf

[homes]
comment = Home Directories
valid users = %S, %D%w%S
inherit acls = Yes

[profiles]
comment = Network Profiles Service
path = /home/Music/
force group = users
create mask = 0600
directory mask = 0700
guest ok = Yes
case sensitive = No
msdfs proxy = no

[users]
comment = All users
path = /home/
inherit acls = Yes
veto files = /aquota.user/groups/shares/

[groups]
comment = All groups
path = /home/groups/
inherit acls = Yes

[printers]
comment = All Printers
path = /var/tmp
create mask = 0600
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin, root
force group = ntadmin
create mask = 0664
directory mask = 0775

[netlogon]
comment = Network Logon Service
path = /var/lib/samba/netlogon
write list = root
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SCSI with two drives, winnt4 boots, suse 10 wont Donb Linux - Newbie 4 07-08-2006 09:58 AM
Why my Windows 2K can't find my CD-ROM after installing OpenSuSe 10.0? juaniquillo Linux - Laptop and Netbook 2 01-16-2006 09:00 PM
opensuse 10.0 pccard network udev ? trouble leonardo-vittorio SUSE / openSUSE 1 11-04-2005 03:38 AM
OpenSuSE + Network installation mikedeatworld SUSE / openSUSE 1 11-02-2005 04:54 PM
For Samba server to winnt4.0&2000 kjsubbu Linux - Networking 0 07-16-2003 07:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 09:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration