LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-17-2004, 08:28 PM   #1
hypnotiks
LQ Newbie
 
Registered: Jul 2004
Location: Florida
Posts: 29

Rep: Reputation: 15
Question can't connect to my share on linux from xp pro


hi everybody,

1)i am using suse 9.1 pro
2)i install samba server and configure it
3)i am able to see and browse file s from linux to windows
4)but i can't see anything from xp pro to linux.

i am new to linux please help me, dont know what am doing wrong

i went to the smb.conf file and add a share under home.
am i doing it right? or how do i share a folder in linux.

i try i try to start the service typing this

/etc/init.s/smb start

and it tells me

daemon already running

i dont know if thats to start client or server?

can someone run me real quick through this.


thank you.
 
Old 07-17-2004, 09:33 PM   #2
this213
Member
 
Registered: Dec 2001
Location: ./
Distribution: Fedora, CentOS, RHEL, Gentoo
Posts: 167

Rep: Reputation: 34
Could you post your smb.conf file?
 
Old 07-18-2004, 12:20 AM   #3
hypnotiks
LQ Newbie
 
Registered: Jul 2004
Location: Florida
Posts: 29

Original Poster
Rep: Reputation: 15
did i configure it right?



# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SuSE
# Date: 2004-04-06
[global]
workgroup = netrand101
interfaces = 127.0.0.1 eth0
bind interfaces only = true
printing = cups
printcap name = cups
printer admin = @ntadmin, root, administrator
map to guest = Bad User
security = user
encrypt passwords = yes
server string = Samba Server
netbios name = samba
add machine script =
domain master = false
domain logons = no
local master = no
preferred master = auto
ldap suffix = dc=example,dc=com

[homes]
comment = Home Directories
valid users = %S
browseable = no
read only = No
guest ok = no
printable = no
[winshare]
comment = share on the linux box
path = /home/jeancarlos/desktop
writeable = yes
inherit permissions = yes
browseable = yes
guest ok = yes
printable = yes
[users]
comment = All users
path = /home
writeable = Yes
inherit permissions = Yes
veto files = /aquota.user/groups/shares/
browseable = yes
guest ok = no
printable = no
[groups]
comment = All groups
path = /home/groups
writeable = Yes
inherit permissions = Yes
browseable = yes
guest ok = no
printable = no
[pdf]
comment = PDF creator
path = /var/tmp
printable = yes
print command = /usr/bin/smbprngenpdf -J '%J' -c %c -s %s -u '%u' -z %z
create mask = 0600
browseable = yes
guest ok = no
[printers]
comment = All Printers
path = /var/tmp
printable = yes
create mask = 0600
browseable = no
guest ok = no
[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775
browseable = yes
guest ok = no
printable = no
 
Old 07-18-2004, 01:21 AM   #4
this213
Member
 
Registered: Dec 2001
Location: ./
Distribution: Fedora, CentOS, RHEL, Gentoo
Posts: 167

Rep: Reputation: 34
Are you trying to use the linux box as just a client? I've usually had much better success when setting it as domain controller.

Either way, adding a few things in your [global] directive should help you:
Code:
log file = /var/log/samba/%m.log
os level = 33
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
remote announce = 192.168.1.255 # This causes the samba server to announce itself to the subnet
hosts allow = 192.168.1.1 192.168.1.2 # Change these to your real client IP's

### This maps unix users to samba - uncomment it if you want this
# unix password sync = Yes
# passwd program = /usr/bin/passwd %u
# passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
If you still can't see your linux system from XP, try changing the [homes] browseable = yes

if you still can't see your linux box, post again or email me
 
Old 07-18-2004, 02:40 AM   #5
hypnotiks
LQ Newbie
 
Registered: Jul 2004
Location: Florida
Posts: 29

Original Poster
Rep: Reputation: 15
well i am using suse 9.1 pro as a samba server and my xp pro as a client.
 
Old 07-18-2004, 02:51 AM   #6
hypnotiks
LQ Newbie
 
Registered: Jul 2004
Location: Florida
Posts: 29

Original Poster
Rep: Reputation: 15
hey thanks
i change the
home
browseable to yes and now i am able to see my linux server.
 
Old 07-18-2004, 03:57 AM   #7
this213
Member
 
Registered: Dec 2001
Location: ./
Distribution: Fedora, CentOS, RHEL, Gentoo
Posts: 167

Rep: Reputation: 34
Glad I could help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to connect to windows share? rerun07 AIX 22 06-17-2005 04:53 PM
How to connect to a Windows share? Ook Slackware 9 04-08-2005 12:24 PM
Authenticating through Windows active directory to connect to a Linux share ganninu Linux - General 1 04-07-2005 05:39 PM
Just got Suse Linux pro 9.1...need to connect to router warnesey333 Linux - Networking 18 10-15-2004 04:11 PM
Connect to Windows Share plexi100 Linux - Newbie 6 11-12-2003 10:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration