LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-28-2004, 04:55 PM   #1
apache363
Member
 
Registered: Jan 2004
Distribution: OS X; FreeBSD; Debian
Posts: 172

Rep: Reputation: 30
Can't access website externally with Linksys BEFW11S4


I'm having trouble accessing my website from outside my network. I've set up my Linksys BEFW11S4 router to use port forwarding on port 80 and others, and to forward them to my Debian server's internal IP address. Any help would be appreciated. I'm using Apache 1.3.29, Debian 3.0r1, and my connection is dynamic (PPPoE) but almost never-crashing, and I'm sure I have the right IP.
 
Old 04-28-2004, 05:03 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 67
Have you asked your ISP if they block port 80?

It may be worth trying it on another port to test.
 
Old 04-28-2004, 05:06 PM   #3
Jeff205
LQ Newbie
 
Registered: Feb 2004
Posts: 4

Rep: Reputation: 0
Have you set up your Linksys router so the IP address of your "website" is the DMZ?

On my Linksys router, you need to select the "Advanced" tab in setup.
 
Old 04-29-2004, 03:59 PM   #4
Freeman-Jo
Member
 
Registered: Apr 2004
Location: Internet
Distribution: Gentoo
Posts: 30

Rep: Reputation: 15
when u mention you have pppoe and said you have the right ip. which ip did you put in the browser when you try to connect from outside?
 
Old 04-29-2004, 05:30 PM   #5
MS3FGX
LQ Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 360Reputation: 360Reputation: 360Reputation: 360
You really shouldn't put anything in the DMZ unless there is absolutely no other choice, and that very rarely occurs.
 
Old 04-29-2004, 07:18 PM   #6
apache363
Member
 
Registered: Jan 2004
Distribution: OS X; FreeBSD; Debian
Posts: 172

Original Poster
Rep: Reputation: 30
David_ross: I called Verizon Online, and eventually a tech support "engineer" was able to tell me that they don't block any ports whatsoever.

Jeff205: (please see MS3FGX)

Freeman-Jo: I put my external IP address into my browser. I know that the IP is correct because I can access my Webmin with the same IP. The port is 10000 though, instead of 80, and Webmin uses SSL. (see footnote)

MS3FGX: I agree entirely. That's why I didn't want to have that be a permanent situation and don't consider the DMZ host to be a viable option.

Footnote: After updating the firmware to 1.45 from 1.44.2z, I was able to access Webmin, which I had not been able to do before. However, I still cannot access my webpage.
 
Old 04-29-2004, 09:35 PM   #7
MS3FGX
LQ Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 360Reputation: 360Reputation: 360Reputation: 360
After checking, it turns out I have the same model router as you, so I can give you some tips that I used.

I originally couldn't get anything to get past this router, I made sure the ports were correct, and the IPs correct but nothing.

Eventually, after experimenting with the settings for awhile, I found you have to disable SPI to get it to let most things through. If you have this enabled, disable it and (at least from my experience) things might just start working.

I also enabled all the "Pass Through" options as well, but this doesn't seem to be as important as the SPI setting.
 
Old 04-29-2004, 09:57 PM   #8
apache363
Member
 
Registered: Jan 2004
Distribution: OS X; FreeBSD; Debian
Posts: 172

Original Poster
Rep: Reputation: 30
I can't seem to find an "SPI" setting in my router config pages. What is SPI?
Also, I have version 2 of the router, if that differs from yours.
 
Old 04-29-2004, 10:09 PM   #9
MS3FGX
LQ Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 360Reputation: 360Reputation: 360Reputation: 360
Hmm, possibly, I have the original one.

On mine it is under "Filters".
 
Old 04-29-2004, 10:31 PM   #10
apache363
Member
 
Registered: Jan 2004
Distribution: OS X; FreeBSD; Debian
Posts: 172

Original Poster
Rep: Reputation: 30
I looked in the Filters page, and my router doesn't have that option.
After the IP filters,
  • Private MAC Filter (Button which says "Edit MAC Filter Setting")
  • Block WAN Request (Disabled)
  • Multicast Pass Through (Enabled)
  • IPSec Pass Through (Enabled)
  • PPTP Pass Through (Enabled)
  • Remote Management (Disabled)
  • Remote Upgrade (Disabled)
  • MTU (Enabled) (1492)
After the options, in parantheses are my choices for each (except for Private MAC Filter).
 
Old 04-29-2004, 10:39 PM   #11
odious1
Member
 
Registered: Jun 2003
Location: Virginia, USA
Distribution: Slackware
Posts: 252

Rep: Reputation: 30
You don't have a firewall rule on your local iface that would block 80 do you? You said you are having trouble with internet access, does that mean internal access is ok?

Tom
 
Old 04-29-2004, 11:01 PM   #12
apache363
Member
 
Registered: Jan 2004
Distribution: OS X; FreeBSD; Debian
Posts: 172

Original Poster
Rep: Reputation: 30
Yes, internal access works beautifully. But as soon as I attempt from a computer outside my own network, I can't get my website.
I'm pretty sure I don't have anything on the local iface blocking port 80.
 
Old 04-30-2004, 12:29 AM   #13
odious1
Member
 
Registered: Jun 2003
Location: Virginia, USA
Distribution: Slackware
Posts: 252

Rep: Reputation: 30
I have the same router and firmware as you. Just for kicks ang giggles I set up fowarding on port 80 to one of my local machines here at home. I used the plug and play tcp and udp. It worked fine. All your other settings look like mine do but there are of course others.

You may want to consider resetting router to defaults and see if that possibly clears something; mine was at default until I made the foward change.

Good luck
Tom
 
Old 04-30-2004, 07:38 PM   #14
Jeff205
LQ Newbie
 
Registered: Feb 2004
Posts: 4

Rep: Reputation: 0
Okay, thanks for the suggestion to NOT put my machine on the DMZ. I removed it, tested my web from the outside world, and it failed.

So, to fix the issue without DMZ, I went back into "Advanced", then "Forwarding".

For Ext. Port I entered 80 to 80

For Protocol I checked TCP

Under IP address, I entered the internal IP address of my machine.

Then I checked "Enable".

Applied the changes, and tested.

I am able to access my site from my public address.
 
Old 04-30-2004, 09:53 PM   #15
apache363
Member
 
Registered: Jan 2004
Distribution: OS X; FreeBSD; Debian
Posts: 172

Original Poster
Rep: Reputation: 30
I'm sorry to say, but neither of those methods worked!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Static IP trouble with linksys BEFW11S4 dizzutch Linux - Networking 8 01-17-2005 02:18 PM
Installation of Linksys BEFW11S4 Router deathboy Linux - Hardware 1 05-01-2004 07:37 PM
Unable to get hostname by linksys BEFW11S4 router akhil1 Linux - Networking 3 04-08-2004 01:57 AM
Redhat 9 No Ping to Win98 via Linksys BEFW11S4 rianjb Linux - Networking 1 11-09-2003 12:58 PM
Linksys BEFW11S4 without DSL possible (?) the_g Linux - Networking 0 06-02-2003 03:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration