LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-01-2015, 04:52 PM   #1
Mr.Drax
LQ Newbie
 
Registered: Dec 2014
Posts: 27

Rep: Reputation: Disabled
Question Can't access local network <eth0> when connect to pppoe <ppp0>


hi dearss!!!
i have question:

Before connect to pppoe. Connect with eth0
Code:
eth0      Link encap:Ethernet  HWaddr 00:11:11:11:11:11  
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::211:11ff:fe11:1111/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1693 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1893 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1159036 (1.1 MiB)  TX bytes:233974 (228.4 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
After connect to pppoe. eth0 disconnect automatically. A new interface named ppp0 is listed now!!!
Code:
eth0      Link encap:Ethernet  HWaddr 00:13:a9:0e:6b:f0  
          inet6 addr: fe80::213:a9ff:fe0e:6bf0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1723 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1930 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1161910 (1.1 MiB)  TX bytes:236404 (230.8 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:48.158.100.219  P-t-P:192.168.111.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:1102 (1.0 KiB)  TX bytes:502 (502.0 B)
how can i connect to ppp0 and do not lost this lines on eth0:
Code:
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
 
Old 02-02-2015, 09:59 AM   #2
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Check your /etc/ppp directory for scripts which might be the cause of the problem.
 
Old 02-02-2015, 11:59 AM   #3
Mr.Drax
LQ Newbie
 
Registered: Dec 2014
Posts: 27

Original Poster
Rep: Reputation: Disabled
Question

Quote:
Originally Posted by veerain View Post
Check your /etc/ppp directory for scripts which might be the cause of the problem.
dear veerain i need more accurate look my interfaces:

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
pre-up ifconfig eth0 hw ether 00:11:11:11:11:11
#pre-up iface eth0 inet dhcp

# The primary network interface
auto eth0
allow-hotplug eth0
iface eth0 inet dhcp
and my NetworkManager.conf:
Code:
[main]
plugins=ifupdown,keyfile
dns=dnsmasq

[ifupdown]
managed=false
#no-auto-default=B2:AA:0E:56:ED:F7,20:20:20:20:20:20,00:00:00:00:00:02,

#[ifupdown]
#managed=true
 
Old 02-02-2015, 12:15 PM   #4
Mr.Drax
LQ Newbie
 
Registered: Dec 2014
Posts: 27

Original Poster
Rep: Reputation: Disabled
any idea please?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Using 2 PPPOE accounts same ISP connect through same interface eth0 monstruo Linux - Newbie 22 12-24-2010 09:05 AM
Ubuntu 10.04 Network Manager PPPoE change mac before connect Goganchic Linux - Desktop 6 07-20-2010 09:46 AM
Selecting between two network interfaces, eth0 and ppp0. pavankc Linux - Newbie 1 11-25-2008 09:45 AM
pppoe dialed twice - I got ppp0 and ppp1 carboncopy Linux - Networking 1 10-23-2005 01:15 AM
Is it possible to use eth0 for both local and public network? DrunkGod Linux - Networking 7 03-08-2004 10:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration