LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 01-14-2004, 05:06 PM   #1
gevers1
LQ Newbie
 
Registered: Jan 2004
Location: Netherlands
Distribution: fedora
Posts: 17

Rep: Reputation: 0
Question Cable Modem - Problems configuring to connect to internet


Hi all,

I installed Fedora Core 1 on my PC, dual boot with Windows98. I've had some experience with Red Hat linux before, and I am really impressed with Fedora so far - it has re-awakened my interest in computing!

My rationale is that if i can get just the internet working, i'll probably never use Windows again but there is a spanner in the works ...

I connect to the internet through a Cable Modem. I can connect fine using Windows, but cannot through Fedora.

I have followed the earlier discussions ("Cannot connect to the internet" and "Internet Not Working") and have tried all the suggestions, but I am really stuck and just cannot get anything working.

I first downloaded and installed l2tpd-0.69.tar as suggested by my Cable provider.

Below is the output I get when running l2tpd. I have also included output from all the files suggested by the discussion threads mentioned above.

I am completely confused as to what values i am supposed to use and where they have to go.

In the output below, hamlet is the name of the linux partition, othello is the windows partition.

one question before we start - how do i determine the IP address of my machine (ethernet card?)

Thanks in advance, hopefully i have included all the info you'll require. I look forward to the time 'll be able to contribute to this forum when I get up to speed (and connected!)

Seb Gevers

+++++++++++++++++++ start of output

++++ this is the error message i get when starting lt2pd -D

[root@hamlet non-working]# l2tpd -D
This binary does not support kernel L2TP.
l2tpd version 0.69 started on hamlet PID:5570
Written by Mark Spencer, Copyright (C) 1998, Adtran, Inc.
Forked by Scott Balmos and David Stipp, (C) 2001
Inhereted by Jeff McAdams, (C) 2002
Linux version 2.4.22-1.2115.nptl on a i686, port 1701
ourtid = 1022, entropy_buf = 3fe
l2tp_call:Connecting to host 172.16.92.101, port 1701
control_xmit: Maximum retries exceeded for tunnel 1022. Closing.
call_close : Connection 0 closed to 172.16.92.101, port 1701 (Timeout)
control_xmit: Unable to deliver closing message for tunnel 1022. Destroying anyway.


++++ /etc/resolve.conf
; generated by /sbin/dhclient-script
nameserver 194.134.5.5 ** this is the primary DNS provided by cable provider **
nameserver 194.134.5.55 ** this is the secondary DNS provided by cable provider **

++++ route output
[root@hamlet l2tp]# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.255.253.1 10.56.249.41 255.255.255.255 UGH 0 0 0 eth0
10.56.240.0 * 255.255.240.0 U 0 0 0 eth0
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo

++++ ifconfig
[root@hamlet non-working]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:0B:2B:04:C0:11
inet addr:10.56.252.122 Bcast:10.56.255.255 Mask:255.255.240.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3229 errors:0 dropped:0 overruns:0 frame:0
TX packets:251 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:196732 (192.1 Kb) TX bytes:26873 (26.2 Kb)
Interrupt:10 Base address:0xbc00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:181 errors:0 dropped:0 overruns:0 frame:0
TX packets:181 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12406 (12.1 Kb) TX bytes:12406 (12.1 Kb)

++++ /etc/rc.conf
eth0="dhcp"


++++ /sbin/ifup eth0
[root@hamlet l2tp]# /sbin/ifup eth0

Determining IP information for eth0... done.

++++ /etc/dhclient-eth0.conf
send host-name "10.1.127.10"; # temporary RHL ifup addition **** Where does it get this from??? ****


++++ /etc/sysconfig/network-config/ifcfg-eth0
# Realtek|RTL-8139/8139C/8139C+
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:0B:2B:04:C0:11
ONBOOT=yes
TYPE=Ethernet
DHCP_HOSTNAME=10.1.127.10 **** Where does it get this from??? ****
USERCTL=no
PEERDNS=yes

+++++ output from Windows ipconfig /all

Windows 98 IP Configuration

Host Name . . . . . . . . . : OTHELLO
DNS Servers . . . . . . . . : 194.134.5.5
194.134.5.55
195.96.96.97
Node Type . . . . . . . . . : Broadcast
NetBIOS Scope ID. . . . . . :
IP Routing Enabled. . . . . : No
WINS Proxy Enabled. . . . . : No
NetBIOS Resolution Uses DNS : No

0 Ethernet adapter :

Description . . . . . . . . : NTS PPPoE Adapter
Physical Address. . . . . . : 44-45-53-54-77-77
DHCP Enabled. . . . . . . . : Yes
IP Address. . . . . . . . . : 0.0.0.0
Subnet Mask . . . . . . . . : 0.0.0.0
Default Gateway . . . . . . :
DHCP Server . . . . . . . . : 255.255.255.255
Primary WINS Server . . . . :
Secondary WINS Server . . . :
Lease Obtained. . . . . . . :
Lease Expires . . . . . . . :

1 Ethernet adapter :

Description . . . . . . . . : NTS VPN Adapter (L)
Physical Address. . . . . . : 44-45-53-54-77-76
DHCP Enabled. . . . . . . . : Yes
IP Address. . . . . . . . . : 83.117.21.61
Subnet Mask . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . : 83.117.21.61
DHCP Server . . . . . . . . : 255.255.255.255
Primary WINS Server . . . . :
Secondary WINS Server . . . :
Lease Obtained. . . . . . . : 01 01 80 00:00:00
Lease Expires . . . . . . . : 01 01 80 00:00:00

2 Ethernet adapter :

Description . . . . . . . . : Realtek RTL8139/810x Family Fast Ethernet NIC
Physical Address. . . . . . : 00-0B-2B-04-C0-11
DHCP Enabled. . . . . . . . : Yes
IP Address. . . . . . . . . : 10.56.249.41 *** is this the IP address of the card? ***
Subnet Mask . . . . . . . . : 255.255.240.0
Default Gateway . . . . . . : 10.56.240.1
DHCP Server . . . . . . . . : 10.1.127.10
Primary WINS Server . . . . :
Secondary WINS Server . . . :
Lease Obtained. . . . . . . : 01 14 04 20:16:39
Lease Expires . . . . . . . : 01 15 04 20:16:39


 
Old 01-14-2004, 05:21 PM   #2
gevers1
LQ Newbie
 
Registered: Jan 2004
Location: Netherlands
Distribution: fedora
Posts: 17

Original Poster
Rep: Reputation: 0
I should just add that my cable company provided the following to put into the l2tp.conf file

[lac eurodocsis] <--- type of modem i have -->
lns = 172.16.92.101
autodial = yes

which is where it gets that address from when it tries to connect using l2tp:

l2tp_call:Connecting to host 172.16.92.101, port 1701

/Seb
 
Old 01-15-2004, 03:20 AM   #3
Mr.Moony
LQ Newbie
 
Registered: Oct 2003
Location: Swansvile
Distribution: Redhat 9
Posts: 9

Rep: Reputation: 0
Something is not right about this :

IP Address. . . . . . . . . : 83.117.21.61
Default Gateway . . . . . . : 83.117.21.61
DHCP Server . . . . . . . . : 255.255.255.255

The DHCP is set as a broadcast address. The default gateway is the same as the IP address. The defaults gateway should either be 83.117.21.1 or 83.117.21.254 . Where did those 3 details come from?
 
Old 01-15-2004, 05:16 AM   #4
gevers1
LQ Newbie
 
Registered: Jan 2004
Location: Netherlands
Distribution: fedora
Posts: 17

Original Poster
Rep: Reputation: 0
Thanks for your reply. A lot of things dont make sense to me so ...

I got those values by connecting to the internet from my windows98 machine, then running

ipconfig /all

to see if that would give me any clues.


From memory (and i am at work right now so i cannot check this) i think those values also appear even when I am not connected to the internet, so where it gets those values from I really do not know.

I believe that the IP address is allocated automatically when you connect to the ISP, so are these

IP Address. . . . . . . . . : 83.117.21.61
Subnet Mask . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . : 83.117.21.61

IP address hardwired somewhere? It is refered to in a section called

NTS VPN Adapter (L)

in ipconfig /all


/Seb
 
Old 01-15-2004, 05:31 AM   #5
Mr.Moony
LQ Newbie
 
Registered: Oct 2003
Location: Swansvile
Distribution: Redhat 9
Posts: 9

Rep: Reputation: 0
The IP address, Default gateway and others will be provided by the DHCP of your ISP. Im almost certain your IP address would not be the same as the default gateway.

On the windows 98 Machine do the following

Start > Run > Winipcfg

Select your enet adapter from the top and Look at the information provided in there. Make sure this matches what you have on linux.
 
Old 01-15-2004, 06:10 AM   #6
gevers1
LQ Newbie
 
Registered: Jan 2004
Location: Netherlands
Distribution: fedora
Posts: 17

Original Poster
Rep: Reputation: 0
Thanks, i will try that. Likesay, I am at work just now, i will check tonight and post a reply somepoint this evening.

/Seb
 
Old 01-15-2004, 09:12 AM   #7
gevers1
LQ Newbie
 
Registered: Jan 2004
Location: Netherlands
Distribution: fedora
Posts: 17

Original Poster
Rep: Reputation: 0
just while i am here, what do i do if the numbers are *not* the same? Where/how do i change it, and will that stop my windows98 internet connection from working?

With regard to the other files i posted, does everything else look ok?

This message

[root@hamlet]# l2tpd -D
This binary does not support kernel L2TP.

worries me ...

/seb
 
Old 01-15-2004, 09:46 AM   #8
Athlon_Jedi
Member
 
Registered: Apr 2003
Location: El Dorado Springs, MO
Distribution: Slackware 9
Posts: 84

Rep: Reputation: 15
The fact that your gateway address * SHOULD NOT BE THE SAME * as your accual ip is correct.

it seems to me as if you may have configured your gateway address manualy somehow.

try running netconfig eth0 as root and set everything as dhcp(as a note when you do this you should not be able to enter any addresses as it is done via the dhcp server)

also look at /etc/hosts.conf and see what it looks like. as an example it should be something similar to this:

127.0.0.1 "localhost"
68.59.differant.number "your machines host name here"

if everything looks ok here, look at /etc/resolv.conf and check to see if your isp's dns server is listed and if not add it.

then in a console type ifdown eth0 to stop the network , then ifup eth0 to restart it and then do:

ifconfig -a to check your configuration.

you should now have a dhcp assigned ip complete with default gateway and the like and be ready to go.

the fact that you have an inet address that starts with 10 indicates that the dhcp daemon is assigning you an internal aka private ip address that if you were running your own network and is not accessable from the outside world . which is the most likely cause.

Last edited by Athlon_Jedi; 01-15-2004 at 09:52 AM.
 
Old 01-15-2004, 10:02 AM   #9
gevers1
LQ Newbie
 
Registered: Jan 2004
Location: Netherlands
Distribution: fedora
Posts: 17

Original Poster
Rep: Reputation: 0
thanks Athlon-jedi.

>> it seems to me as if you may have configured your gateway address manualy somehow

yes, there was step in the installation instructions i got which

++++ start
(translated from dutch)

check route. Note the gateway adres of the default route. this adres shall start with 10 and end in 254. This number will be called $GATEWAY in this document. Note which ethernet kaart is used. This card is refered to as $DEV in this document


route add 10.255.253.1 gateway $GATEWAY $DEV

check with ifconfig if ppp0 appears (**NOTE, I dont have this,. i use eth0***)

route add default ppp0 (*** so i did route add default eth0 ***).

while i am here, this is the l2tpd.conf example file that came with the installation files as recommended by my cable provider:


# Global section (by default, we start in global mode)
global

# Load handlers
load-handler "sync-pppd.so"
load-handler "cmd.so"

# Bind address
listen-port 1701

# Configure the sync-pppd handler. You MUST have a "section sync-pppd" line
# even if you don't set any options.
section sync-pppd
lns-pppd-opts "require-pap 10.0.0.1:10.0.0.2 lcp-echo-interval 30 lcp-echo-failure 6"
lac-pppd-opts "user example name example noipdefault ipcp-accept-local ipcp-accept-remote lcp-echo-interval 30
lcp-echo-failure 6"

# Peer section
section peer
peer 10.255.253.1
secret $PASSWORD
port 1701
lac-handler sync-pppd
lns-handler sync-pppd
hide-avps yes

section peer
peer 192.168.2.9
# No secret - no authentication
port 1701
lac-handler sync-pppd
lns-handler sync-pppd
hide-avps no

# Configure the cmd handler. You MUST have a "section cmd" line
# even if you don't set any options.
section cmd


++++ end

There seems to be so much to change, it's so confusing. thanks for your reply.

/Seb
 
Old 01-15-2004, 04:54 PM   #10
gevers1
LQ Newbie
 
Registered: Jan 2004
Location: Netherlands
Distribution: fedora
Posts: 17

Original Poster
Rep: Reputation: 0
ok, ran winipcfg. Output as below

[NTS VPN Adapter (L)]
Adapter ADdress 44-45-54-54-77-76
IP Autoconfiguration Address 81.68.70.63
Subnet Mask 255.255.255.0
Default Gateway 81.68.70.63



[Realtek RTL8139/810x Family Fast Ethernet]
Adapter ADdress 00-0B-2B-04-C0-11
IP Address 10.56.249.41
Subnet Mask 255.255.240.0
Default Gateway 10.56.240.1


One other suggestion - another post on this forum suggests that I need to install drivers for my card - is this something to persue?

thanks.

seb
 
Old 01-16-2004, 03:24 AM   #11
gevers1
LQ Newbie
 
Registered: Jan 2004
Location: Netherlands
Distribution: fedora
Posts: 17

Original Poster
Rep: Reputation: 0
This is just getting worse. I am more confused than ever. Re-reading the isntructions i got from my ISP, it starts going on about ppp0 (see the l2tpd.conf file i posted down below).

Am i supposed to do this too? what is ppp0 anyway? I thought i just needed eth0

And what does all this mean ...????

l2tp_call:Connecting to host 172.16.92.101, port 1701
control_xmit: Maximum retries exceeded for tunnel 1022. Closing.
call_close : Connection 0 closed to 172.16.92.101, port 1701 (Timeout)
control_xmit: Unable to deliver closing message for tunnel 1022. Destroying anyway.


what is it actually doing?

and what is the relationship between all l2tpd.conf and resolv.conf and host and hosts and /etc/ppp/options ....???

I've spent nearly a week on this getting nowhere and am begining to lose heart - i am desperate to get this working and ditch windows once and for all.




thanks

/Seb
 
Old 01-16-2004, 03:48 PM   #12
Athlon_Jedi
Member
 
Registered: Apr 2003
Location: El Dorado Springs, MO
Distribution: Slackware 9
Posts: 84

Rep: Reputation: 15
no ppp0

in my experiance unless your isp uses pppoe or similar you dont need ppp0 at all, its mainly used for dialup or dsl
 
Old 01-17-2004, 12:37 PM   #13
MeLassen
Member
 
Registered: Sep 2001
Location: The Netherlands
Distribution: Ubuntu 4.10
Posts: 45

Rep: Reputation: 15
I am also working on l2tp for my internet connection under fedora. I got stuck earlier in the process. My system does not compile l2tp correctly. I get a lot of errors after the 'make' command. Can you explain me how you did it?

MeLassen
 
Old 01-17-2004, 01:44 PM   #14
gevers1
LQ Newbie
 
Registered: Jan 2004
Location: Netherlands
Distribution: fedora
Posts: 17

Original Poster
Rep: Reputation: 0
i've finally managed to connect!

i actually did not compile l2tp, i got it from the download site of my cable provider (i'll post the link later, i cannot get konqueror to display the link properly). I then put it into /etc/l2tp.

Likesay, i got connected at last (after 5 days of trying). I'll put the steps i took into a message and post here - i need to translate a lot of it into english first of all.

The only problem i have now are that

(a) occasionaly the link is broken
(b) mozilla keeps freezing on me ...

other than that, it's format C: here we come!

/Seb
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't connect to the internet using cable modem and SUSE 9.1. Hrothgar15 Linux - Newbie 4 08-17-2005 03:06 AM
Can't connect to the internet with cable modem and SUSE 9.1 Hrothgar15 Linux - Networking 12 08-16-2005 12:23 AM
How to connect to the internet with cable modem and SUSE 9.1? Hrothgar15 Linux - Newbie 1 08-13-2005 10:09 PM
Can't connect to internet via cable modem jaydoubleyou Linux - Newbie 2 09-16-2003 10:02 AM
Cannot connect to internet with cable modem debPandra Linux - Distributions 5 07-03-2002 11:37 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration