-   Linux - Networking (
-   -   Cable Modem - How-to DHCP ? (

iraysyvalo 07-07-2003 10:59 AM

Cable Modem - How-to DHCP ?
:( Hi out there.

I need a quick fix or a good doc on how to setup an internet link via the SB4200E cable-modem and DHCP.

I managed to get the network interface eth0 up and running (ifconfig says it's OK) BUT I can't have DHCP working.

Thanks in advance.

angelrod 07-07-2003 11:02 AM

netconfig -d eth0

iraysyvalo 07-07-2003 11:23 AM

I'm on Debian Woody
netconfig is unfortunaly a command not found ! :(

I really need this link as I'v got pb with glic2.3.2, still no X running, and it's a real pain rebooting into W..suCks doing search on the Net and getting back to Woody again.


angelrod 07-07-2003 11:56 AM

I think in debian is:

dhcpcd -t 10 -d eth0

or try 'linuxconf'


One must work to set dhcp to your nic

iraysyvalo 07-07-2003 01:38 PM

Actually, I already checked the following and installed it but it didn't change anything.

Before that, I checked the mini-HOWTO you mention but the link they provide for Debian is broken :(

But I gonna try what you just said. See you after a few reboots ;)

iraysyvalo 07-07-2003 02:52 PM

The dhcpd service seems running .... (could stop/start it)

But then again, I can't ping a host on the Net.

Seems the pb come from the dhcpd.conf file because it uses bogus fields. How should I config it ?

angelrod 07-07-2003 05:02 PM

First, were you able to get an IP by DHCP??

iraysyvalo 07-08-2003 01:47 PM

Still lost with that DHCP pb.

There's no inet addr value at all for eth0 in the ifconfig output !!!

iraysyvalo 07-08-2003 01:51 PM

State of the pb NOW !
ifconfig says lo & eth0 are there. Unfortunately, eth0 didn't get any IP address at all.

I think the pb come from my conf files. But I don't know which ones !

As for now, I checked /etc/network/interfaces. It's written as follows :
auto lo eth0

iface lo inet loopback

iface eth0 inet dhcp
hostname myfakehost

/etc/resolv.conf is as follows :
nameserver xxx.xxx1
nameserver xxx.xxx2

During install, I set the box as Maybe I should remove that setting but in which conf file are they set?

I also have the FAI's DHCP server IP address. Where can I tell it to my dhcp client ??

Now, any other file I should check ??

Thnks for all the help guys!

angelrod 07-08-2003 02:47 PM

I've never used Debian, but in Red Hat you can set your hostname by editing /etc/sysconfig/network

Anyway I don't think that's the problem.... Is there any way that you could get the values you need (IP, gateway, DNS's, etc)? If you have a dual boot with windoze or maybe setting up your cable modem at other PC?

This is just to try entering the settings manually to see if it works...

iraysyvalo 07-08-2003 02:57 PM

Thnx for ur help, Angelrod.

Ok, I have all the needed info for the connection (from W...suCks). Apparently, I never changed IP from the beginning.

I've already tried ifconfig eth0 but couldn't ping externally! What else should I do to get it working if we suppose that the IP won't change any time soon?

hakcenter 07-08-2003 02:59 PM

edit the /etc/sysconfig/network-scripts/ifcfg-eth0 to your liking, then reboot the linux machine.

iraysyvalo 07-08-2003 03:05 PM

Thx hakcenter.

Does ur hack work for the static IP case or the DHCP one ?

iraysyvalo 07-09-2003 06:16 AM

Hi, guys !!!!

Still not working. The file you mention, hakcenter, isn't anywhere to be found on Woody.

Who knows all the files that dhcp-client needs in order to work ????

iraysyvalo 07-09-2003 02:34 PM

Really getting worse !
Isn't there ANY knowledgeable person on this website ???

Given the number of times this DHCP problem comes back here, still nobody with the solution ???

All times are GMT -5. The time now is 07:31 PM.