LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 01-27-2016, 02:26 PM   #1
scheidel21
Senior Member
 
Registered: Feb 2003
Location: CT
Distribution: Debian 6+, CentOS 5+
Posts: 1,323

Rep: Reputation: 100Reputation: 100
Angry Bridged VLAN TAP adapter no propagating on bridge interface


So I've been having an issue getting VLANs to work in Debian 8. Anyways I've isolated it to what I believe the issue to be. That issue is that the TAP adapter I've tagged (which is part of a bridge) is seeing all the bridged traffic but it is not sending out to the bridge.

I have verified this is two ways, the first was trying to get a dhcp address, and I monitored the VLAN tap interface and the bridge. I could see the DHCP request going out on the TAP interface but I did not see the same traffic in any manner on the bridge.

The second I set a static IP in the VLAN subnet on the tap adapter and tried to ping a valid IP in the subnet. I could see all the ARP requests when monitoring the TAP device, but I did not see any of the ARP requests in the packet captures for the bridge interface.

So why isn't the VLAN'd tap interface propagating traffic over the bridge, the untagged, bridged tap adapter is doing just fine working with the native vlan.
 
Old 01-28-2016, 12:34 PM   #2
scheidel21
Senior Member
 
Registered: Feb 2003
Location: CT
Distribution: Debian 6+, CentOS 5+
Posts: 1,323

Original Poster
Rep: Reputation: 100Reputation: 100
So I haven't gotten an answer to this, however, I did find that if I VLAN the primary adapter I have no issue with VLAN tagging working.
 
  


Reply

Tags
bridge, debian, tap, vlan


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] VLAN interfaces, TAP adapter, and bridges oh my! scheidel21 Linux - Networking 2 01-28-2016 02:07 PM
[SOLVED] KVM Qemu instance bridged tap interface disconnects, cutting me off from the guest rylan76 Linux - Virtualization and Cloud 1 11-07-2012 06:35 AM
Bridge a VLAN with the WAN interface Jeroen1000 Linux - Networking 5 02-17-2011 10:27 AM
Bridge between ethernet interface and tap interface jayadhanesh Linux - Networking 3 04-12-2009 11:32 PM
Performance issue with VLAN + Bridge + TAP AFI Linux - Networking 3 08-14-2008 08:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration