LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-08-2015, 09:34 AM   #1
lucmove
Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Debian Stretch
Posts: 964

Rep: Reputation: 81
BlackBerry has no inet address anymore


When I had Ubuntu then Debian Wheezy, I used to be able to connect my BlackBerry Playbook over USB. For that, I needed to run 'ifconfig -a' then look for usb0 and I had to take note of the inet addr on the ifconfig output.

Now I use Debian Jessie and usb0 is shows up, but the inet addr is missing. What can I do to have it again?
 
Old 06-14-2015, 06:29 AM   #2
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,881

Rep: Reputation: 663Reputation: 663Reputation: 663Reputation: 663Reputation: 663Reputation: 663
I'm not familiar with Blackberry devices or networking via USB, but I wonder if perhaps the necessary kernel module support is required. Maybe the 'cdc_ether' driver needs to be loaded first? That module will also cause 'usbnet' module to be loaded as well. Just a thought.
 
Old 06-14-2015, 06:36 AM   #3
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,881

Rep: Reputation: 663Reputation: 663Reputation: 663Reputation: 663Reputation: 663Reputation: 663
The other thought I had was to observe the dmesg output when the Blackberry device is attached. With the move to systemd, you may find that the device interface has changed (due to systemd-udevd), and the dmesg output should report the network interface naming, as should 'ifconfig'.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ifconfig command not showing inet address barsaiyan Linux - Newbie 1 06-04-2012 04:27 PM
eth0 inet address not assigned at startup?? abolishtheun Slackware 2 04-30-2009 08:38 AM
eth0 no longer works; does not have inet address (Ubuntu 8.10) BigNate37 Linux - Networking 2 02-14-2009 07:25 PM
Java code to get inet address in linux qiye Programming 1 09-15-2004 02:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration