LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Bittorrent connection refused. (https://www.linuxquestions.org/questions/linux-networking-3/bittorrent-connection-refused-930417/)

flyinggeorge 02-20-2012 11:06 PM

Bittorrent connection refused.
 
I think this is the correct sub-forum. If not, I am sorry; please move this thread.

I run Slackware 13.37 and I have not been able to use bittorrent. Every time I use bittorrent or another torrent client I get told "connection to tracker refused" in bittorrent it is error no 111. I thought this was a firewall issue with port 6881 blocked. But nmap returns:

Code:

bash-4.1# nmap 192.168.1.102

Starting Nmap 5.51 ( http://nmap.org ) at 2012-02-20 23:59 EST
Nmap scan report for 192.168.1.102
Host is up (0.000011s latency).
Not shown: 995 closed ports
PORT    STATE SERVICE
22/tcp  open  ssh
37/tcp  open  time
113/tcp  open  auth
6000/tcp open  X11
6881/tcp open  bittorrent-tracker

Nmap done: 1 IP address (1 host up) scanned in 0.69 seconds

I'm not sure what else would be causing this problem. Any help is greatly appreciated. Thanks in advance.

liberalchrist 02-21-2012 10:30 AM

I'm not sure what the problem could be, but it might help troubleshoot if you try a couple of different torrents. I have seen torrents that only have one tracker. If it is a private tracker associated with that torrent, you might have to be a member.

flyinggeorge 02-21-2012 11:01 AM

I have tried about 5 or 6 torrents, all of them from thepiratebay. I will give a few more a try and get back to you. I'm pretty stumped on this one also. It's not blocked in the router (the port) other computers on this network have no issues with torrent clients. But here goes nothing!

Maybe it was the torrents I was trying to download. I'm getting a different error. I'm going to try a bunch more torrents and see if I can succeed with any of them. Anyway one of the other torrents I was trying to download gave me this error:

Tracker announce still not complete 180 seconds after starting it

And another torrent gave me: Problem connecting to tracker - <urlopen error unknown url type: udp>

Maybe I am just having poor luck.

Must have been my luck. One torrent is downloading now. Thanks for you help, liberalchrist!

liberalchrist 02-21-2012 01:53 PM

Glad to help. Glad you got started.


All times are GMT -5. The time now is 12:57 PM.