-   Linux - Networking (
-   -   BIND jnl files (

DanW85 07-13-2010 03:12 AM

BIND jnl files

I'm having an issue with BIND not updating the list of static IP addresses.
I have a Windows Server 2008 machine, who gets an IP address absolutely fine if I use DHCP. It registers in the DNS correctly.
When I switch to a static IP and update the zone config with the correct IP.

I'm using webmin currently, but no doubt there is a better way to administer BIND.
I'm updating it in:
BIND DNS server -> Existing DNS zones (selected correct zone) -> Address

Then changed the corresponding record to the correct IP.

I've also tried going to editing the records file. And that doesn't change anything either.

Narrowing it down, every time I give the machine a new DHCP address, it correctly updates to the clients fairly quickly, so I presume I'm doing something wrong with webmin.

jon5000 07-15-2010 06:09 AM


I've never used webmin, but on the command line I'd do something like

rndc freeze zone IN
edit the zone file
rndc thaw zone IN

If rndc gives a 'freeze failed, not found' message, you're probably using views and would need to add the view name at the end of the command.


tva 07-15-2010 06:42 AM

Have you remembered to use "Apply zone" in upper right corner after doing those changes?

DanW85 07-19-2010 05:16 AM

Sorry it took so long to respond been out the office.

@tva, yeah I tried that and it didn't seem to work at all. Tried applying it in every place with no luck.

@jon5000, no luck with rndc either, I didn't set it up but it looks like it's not set-up correctly, "rndc: 'freeze' failed: unknown command". I've checked and we're using BIND9 so that command should be available.

I've tried
rndc freeze WBC in
rndc freeze WBC in internal

I'm not expecting the second one to work as we don't have any views at the moment.

tva 07-20-2010 01:50 AM

does "service named reload" work?

DanW85 07-20-2010 04:51 AM


All times are GMT -5. The time now is 12:25 PM.