-   Linux - Networking (
-   -   b43-fwcutter-no connection with WEP encrypted network while WPA network works (

blorpton 12-16-2009 04:04 PM

b43-fwcutter-no connection with WEP encrypted network while WPA network works

There is a strange thing going out there in my box, I've tested b43-fwcutter on wpa-psk encrypted network, and there was no problem connecting (my card is broadcom 4318), recently I was trying to connect to WEP encrypted network without success. Network connection tested on other laptops(vista, xp machines)so there is no possibility that the key isn't valid.
Any suggestions? Maybe you have/had similar problem.



Larry Webb 12-16-2009 07:38 PM

Which distro are you using?

I had a problem with a broadcom 4306 card and ended up using ndiswrapper and a XP driver. The problem is the later distros have native drivers and you need to black list them.


blorpton 12-17-2009 12:47 PM


the distro is ubuntu 9.10, had the same problem on debian basicly, you suggest blacklisting native drivers from kernel, hmmmm, but the driver overall works, with wpa, wpa2 it does, but with wep encryption just connects forever resulting lack of connection....

ndiswrapper, on the other hand, worked for me, funny because i never had to download any other drivers than ndiswrapper itself. after compiling the source and modprobing it was working no bother with my 4318 card. This time for some another strange reason, I am unable to compile it, 'make' ends with several errors unable to continue(yes i do have build-essential and header files installed).

cheers for replay;]

Larry Webb 12-18-2009 06:28 AM

First I am not familiar with ubuntu. I was surprised though from posts I have seen the later broadcom cards seem to work with native drivers. In my experience if you have any errors you will need to take care of them first.


Wifi-Fanatux 12-18-2009 06:03 PM

Not sure if you are using a network manager, but you need to make sure you are using the correct WEP format either passcode or hexidecimal. Try both formats if you are unsure.

blorpton 12-20-2009 04:57 AM

I've tried it all I'm afraid without a manager just connects forever trying to obtain ip address...
as I said before it works with all wpa flavours though.
Anyway, thanx for your posts guys;]

blorpton 01-25-2010 02:06 AM


guess like this was my mistake...thing is livebox router, there is a wee button underneath the router, the 'reg' button. while trying to connect i had to press it to register a new connection. ever since i did, it works flawlessly.....thank you very much all for your interest in my post....

All times are GMT -5. The time now is 04:10 PM.