LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-02-2005, 09:29 AM   #16
stefan_nicolau
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Debian Etch/Sid, Ubuntu
Posts: 529

Rep: Reputation: 32

Quote:
Well, i'm fairly certain that adding entries into fstab won't work (looking over my system, i think the reason is that my wireless network card doesn't startup until after everything else, so fstab cannot connect properly).
Yes, of course... Why have you not mentioned the wireless card before?
Quote:
As for creating this link, how do I do it? I am using Mandrake 10.2 with Gnome desktop. Having searched for gskuexec on the internet, and typing it in command terminal, I have found nothing on it. If you could please guide me through the process of creating this link it would be much appreciated.
I use kde... Try creating a desktop shortcut and looking at the options, or look through the menus for something named 'Run as different user'.
 
Old 07-02-2005, 10:16 AM   #17
FlamingBee
Member
 
Registered: Mar 2005
Distribution: Mandrake 10.2
Posts: 35

Original Poster
Rep: Reputation: 15
Well, the easiest way I have found to create a desktop shortcut is to right-click on the desktop and then go "create launcher". But looking through the options, I don't see how to do what i need to do. Here's a screenshot:

http://i14.photobucket.com/albums/a3...Screenshot.png

Do you know what I need to do?
 
Old 07-02-2005, 10:37 AM   #18
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
I just glanced through this thread, and may have missed you getting the shares automounted via fstab, but I don't think I saw anyone actually show you a working fstab entry. So, for what it's worth, here's one from my fstab
Code:
//tss-1/C               /mnt/tss-1/c            smbfs   workgroup=TSS,uid=peter,gid=tss,credentials=/home/peter/.smbmountpasswd 0 0
Our XP shares are, as you can see, set up on a work group rather than a domain.

Oh, the .smbpassword file is quite simple:
Code:
$ cat .smbmountpasswd
username=Administrator
password=Ds231mthspte
Hope this helps.

Last edited by PTrenholme; 07-02-2005 at 10:40 AM.
 
Old 07-02-2005, 10:42 AM   #19
Michael Johnson
Member
 
Registered: Jul 2005
Location: Wagga Wagga, Australia
Posts: 262

Rep: Reputation: 30
When you use the uid=user and gid=group, are you using numbers for the users and groups and not their name.
uid=1000,gid=100 (as an example)
 
Old 07-02-2005, 11:30 AM   #20
stefan_nicolau
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Debian Etch/Sid, Ubuntu
Posts: 529

Rep: Reputation: 32
Quote:
Do you know what I need to do?
Have you looked under the advanced tab?
 
Old 07-02-2005, 03:51 PM   #21
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
Quote:
Originally posted by PTrenholme
I just glanced through this thread, and may have missed you getting the shares automounted via fstab, but I don't think I saw anyone actually show you a working fstab entry.
The one I posted works, thankyouverymuch, I changed the domain(active directory) and password for obvious security reasons, but otherwise that fstab entry WORKS. I use multiple mappings with that exact syntax and it works absolutely flawlessly.
 
Old 07-03-2005, 05:12 PM   #22
FlamingBee
Member
 
Registered: Mar 2005
Distribution: Mandrake 10.2
Posts: 35

Original Poster
Rep: Reputation: 15
First of all, thanks for the responses. Second of all, I'm fairly certain now that adding entries into fstab won't work because the wireless network card start up AFTER the samba network shares have (attempted to) be mounted. This leaves me with only the option to create a script to mount the shares. As a note, I was using the names (rather than numbers) for "gid" and "uid". Oh and stefan_nicolau, in the "advanced" tab there is only stuff on extra languages and language packs (which doesn't really help me ) I was hearing from someone about something called "shell scripts" - would these do the trick?
 
Old 07-03-2005, 07:12 PM   #23
Michael Johnson
Member
 
Registered: Jul 2005
Location: Wagga Wagga, Australia
Posts: 262

Rep: Reputation: 30
There is a /etc/rc.local script. This is the last script to execute on startup. If you add the mount commands in there it should all work.
 
Old 07-03-2005, 07:28 PM   #24
stefan_nicolau
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Debian Etch/Sid, Ubuntu
Posts: 529

Rep: Reputation: 32
When you create the gnome shortcut, use the following command:
Code:
gksu mount /phobos
(this requires an fstab entry)
 
Old 07-05-2005, 03:23 PM   #25
FlamingBee
Member
 
Registered: Mar 2005
Distribution: Mandrake 10.2
Posts: 35

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Michael Johnson
There is a /etc/rc.local script. This is the last script to execute on startup. If you add the mount commands in there it should all work.
Yep, already tried that a while back. I tried putting:

mount -t smbfs //omoikane/phobos /phobos in it, and that doesn't do anything.
mount -t cifs //192.168.0.010/phobos /phobos in it, and that doesn't do anything.
//omoikane/phobos /phobos smbfs auto,user 0 0

None of these commands have worked. The first two commands definately work when they are entered as root in the console. Which of those commands SHOULD, theoretically, work?
 
Old 07-06-2005, 08:18 PM   #26
Michael Johnson
Member
 
Registered: Jul 2005
Location: Wagga Wagga, Australia
Posts: 262

Rep: Reputation: 30
The first two commands are the affectively same. The first needs to be able to translate the name to an IP address, which it does because it is working. If you are using a DHCP server to alocate IP addresses the first is preferred as it will follow the allocations. The second is better if you are useing fixed IP addresses as there a time saving in not looking up the address.
I noticed your /etc/fstab line reads
//omoikane/phobos /phobos smbfs auto,user 0 0
This should mount it automatcally. Have using noauto instead of auto and then adding the commands to /etc/rc.local
 
Old 07-09-2005, 04:20 AM   #27
FlamingBee
Member
 
Registered: Mar 2005
Distribution: Mandrake 10.2
Posts: 35

Original Poster
Rep: Reputation: 15
Thanks for the help guys, however nothing I have tried seems to work, so I think it's time to call it quits. It is unfortunate that I did not manage to get it to work, however I think I can live without it auto-mounting. Once again, thank you ver much for the help.
 
Old 07-10-2005, 01:43 AM   #28
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
Don't give up. It's been so long I forgot about a step (a significant one). I'm really sorry about that.

Create a quick script similar to the following in /etc/init.d (I named mine mountsamba)

Code:
#! /bin/sh
# mountsamba
### BEGIN INIT INFO
# Provides:       mountsamba
# Required-Start: smb  #this tells insserve how to order the script
# X-UnitedLinux-Should-Start:
# Required-Stop:
# Default-Start:  3 5
# Default-Stop:   0 1 2 6
# Description:    mounting drives kim defined in fstab
### END INIT INFO

echo -n "Mounting /mnt/public . . ."
mount /mnt/public
echo "Mounted."

echo -n "Mounting /mnt/linuxweb . . ."
mount /mnt/linuxweb
echo "Mounted."

echo -n "Mounting /mnt/software. . ."
mount /mnt/software
echo "Mounted."
chmod mountsamba with a+rx (or you can use the numerical)

now go to /etc/init.d and run this command:

Code:
 insserv mountsamba
NOW when you reboot it will mount automagically. I'm really sorry I forgot about this step. My machine was Just Working(tm) and when I had to reconfigure a few things today I noticed that script I'd created
 
Old 07-12-2005, 11:04 AM   #29
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
FlamingBee>

Did you try adding the script to your init.d? Again, I apologise for missing that step with my initial reply.

PTrenholme>
I owe you an apology. I had forgotten about the need for the script for actually mounting the share.
 
Old 07-14-2005, 08:29 AM   #30
anand_kt
Member
 
Registered: Dec 2004
Location: Chennai, India
Distribution: Red Hat, Knoppix
Posts: 86

Rep: Reputation: 15
why not try `autofs`...
Its easy to setup...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble mounting a Windows share lowpro2k3 Slackware 2 10-17-2005 05:38 AM
Newbie Question - Auto mounting of server share file dodjie60 Linux - Networking 15 09-12-2005 10:34 AM
Auto mounting Linux smb share on Windows at startup neranjana Linux - Networking 1 07-02-2004 07:56 PM
auto mount windows share bloodhound1600 Linux - Networking 1 11-26-2002 05:16 AM
mounting a windows network share? graystarr Linux - Networking 2 11-09-2002 06:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration