-   Linux - Networking (
-   -   Atheros AR242x Wireless Card won't find any network on Debian Lenny (

lunarnet76 01-14-2011 04:59 AM

Atheros AR242x Wireless Card won't find any network on Debian Lenny
Hi guys,

I am not a complete newbie but stuck with installing my wireless card...

I have downloaded and install some drivers and here are the information I got after:
Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (Rev 01)

wlan0 Link encap:ETHERNET hwdaddr: 00:22:68:92:6b:4b
up broadcast multicasst mtu:1500 metric:1
(then all the fields to 0)

wlan0 IEEE 802.11 ESSID:"" mode:managed frequency@2.412ghz access point: not associatied
(and a bunch of information to 0 or uninteresting I guess)

I have never used the wifi on linux so I am not even sure that I have understood how to connect to a wifi network ... but I have installed something called wifi-radar and it does not detect anything!

I also have tried to install madwifi to make it work but after 10 different tutorial I GAVE UP... nothing ever works, and the official website does not even work...

I would appreciate any help!


ps: I forgot to mention that I am on a Acer Aspire One, here is the main tutorial I have followed

cin_ 01-14-2011 08:52 AM

A Little More Information
What wifi client are you using?
What Desktop Environment, or Window Manager are you using?

ericson007 01-14-2011 03:33 PM

Try network manager, it works well, however, cannot recall seeing it in the debian repo. At times I had huge issues connecting to networks when encryption was used and/or ssid was hidden, disabling authentication and making it visible, then connecting and reinstating the authentication and hidden ssid did the trick. However, have not seen that happen on newer systems often. Another client you may try for debian is wicd I think it was called.

lunarnet76 01-18-2011 10:52 AM

sorry I lost my post ... could not find this forum again ahah


What wifi client are you using?
What Desktop Environment, or Window Manager are you using?
I am not sure ....I am using Gnome, and for the wifi I use the one in system/preferences/network manager editor! and I have also installed wifi-radar

cin_ 01-18-2011 11:31 AM

I use wicd on my Slack box no problems.
If you are using GNOME Network Manager is packaged with GNOME, and was happy with its functionality.

# ifconfig wlan0 up

I too have an AcerAO, D250.
Since we have the ability to turn our wireless cards off, this can sometimes cause some issues where it will stay turned off even when you try to turn it on manually. This should fix all that...

# lspci | grep -i wireless
01:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
# rmmod ath5k
# rfkill block all
# rfkill unblock all
# modprobe ath5k
# rfkill unblock all
# ifconfig wlan0 up

Mind you my card is an Atheros, and so I use the ath5k module. Find the correct one for your card.

lunarnet76 01-18-2011 01:07 PM

thanks a lot, but it still not working, I m giving up and coming back to windows...

cin_ 01-18-2011 02:36 PM

stick around
Device interfacing is a module issue. Modules can either be built into your kernel or loadable kernel modules: the modprobe() command.


# lsmod | grep -E '(mac)|(led)|(cfg80211)'
mac80211              153050  1 ath5k
cfg80211              109656  3 ath5k,mac80211,ath
rfkill                12812  1 cfg80211
led_class              2037  1 ath5k

Where my system says ath5k, yours will say what you should put in place of ath5k in the earlier rmmod() and then use ath_pci for your card in the the modprobe() command.

So you have some options:
You could try to configure your own kernel with the proper support for your devices... (configure tutorial) further breaks down your own specific AcerAO needs as per the configuration

You could try another distro.
Slackware's hugesmp.s kernel allowed all of my AcerAO devices to function.

Or you could just make a UBS'DVD'CD'LiveBoot of Slack's distro. Then at the boot prompt use the Slack kernel, but the Debian harddrive.

boot: hugesmp.s /dev/to/Debian rdinit=ro
Then everything should function, and you can move from there... since you already have a Linux system up, this process is so simple thanks to AlienBob's automation script:

As for the madwifi, it seems your card is compatible:
The madwifi project links to this how-to:

All times are GMT -5. The time now is 09:43 PM.