-   Linux - Networking (
-   -   atheros ar242 wireless connection almost solved (

sonichedgehog 08-25-2009 09:30 PM

atheros ar242 wireless connection almost solved
Its ridiculously difficult to get these wireless cards to work on linux, and this has to be the most difficult fix I have ever tried. I'm posting here for 2 reasons:
1 To list all the steps I have taken while its fresh on my mind. In the end, the actual steps taken were straightforward, but there were hours of trial and error
2 I can now detect my network but can't connect to it, would welcome suggestions. I'm going to try a few things but don't want to play with my home network just yet, as my family are using it successfully.

This was an ASUS X50R, ubuntu9.04. Others have reported that the live cd detects the wireless network but the installed OS doesn't, and that was my experience. Debian Squeeze never saw the network at all and I suspect (but have not tested yet) that the fix is similar.

This draws on excellent work by others, as follows:


I'm basically a debian user, so on ubuntu I tend to enable root password. This is not a popular move! If using ubuntu, most will prefer to use sudo.

Look at the 1st link. I'm not sure how essential it is to disable existing drivers- after all I blacklisted them later- but I couldn't make much sense with the gui option so looked for the drivers with lspci -v and used rmmod. Then continue as the post suggests. (I prefer vim to gedit, if in ubuntu

apt-get install vim

So, the new driver is installed.

Get wicd-

apt-get install wicd
That didn't help, so far. I then went to (2), this included blacklisting the drivers I didn't want.

Then, for the first time, I saw the local wireless networks; but they just "disappeared" after a few minutes. Then, at last, I found the suggestion towards the end of (3) for disabling bluetooth and enabling wireless:


echo 0 > /sys/devices/platform/asus-laptop/bluetooth
echo 1 > /sys/devices/platform/asus-laptop/wlan

As I said, I still haven't connected, but most of the job is done. I use WEP hex, and I think it likely that another encryption option would sort this out; there are WPA options, and others within WEP. WPA/AES has been suggested as a possible option.

I should add that my understanding of drivers is rudimentary and hope that others will rationalize the process outlined here.

EDIT: this is no longer a question, as I have solved it. Although wicd showed my network, I was unable to connect using any of the available forms of encryption. However that was using wicd1.5.9 native to Ubuntu 9.04. I was unable to connect from a source-built 1.6.2; but Debian Lenny has 1.6.1, and that proved adequate.

I have added the echo script mentioned above to rc.local. My laptop will toggle wireless off, but not on, so it needs to be set up in this way.

sourceview 09-02-2009 12:15 AM
you might look at the open-mesh work. They re-burn the routers they send out and they use the atheros chip. Good through g, if you know drivers, they need help with n drivers for atheros. Their little mesh routers work great, and you have online control over every router in the network.

sonichedgehog 10-07-2009 06:00 PM

Thanks, in fact one of my friends is an old-style Unix wizard, uses all sorts of platforms, he's into boosting/ relaying the signals as you describe. My problem (shared by others with Atheros wireless adapters) was non-functioning driver. I have since found that
is sufficient, plus the

echo 1 > /sys/devices/platform/asus-laptop/wlan
to toggle the wireless switch on if the hotkey won't do it.
The solution is similar for both Debian and Ubuntu, but there may be some problem with the build-essential and subversion packages, I think easily solved with

apt-get cdrom
I also found that enabling the root password gives better access to the system. Definitely a case of "your mileage may vary!":D

All times are GMT -5. The time now is 06:14 AM.